Jump to content
LUF Admin

Leica Q: Firmware Update v3.0

Recommended Posts

Guest jvansmit

 

1. Occasional freezing continues. Today the camera froze twice. A new behaviour was that the live view was working as it should, but the camera would not take pictures nor respond to any attempted action. The only remedy still is to take the battery out. Because the camera is so silent I may not immediately realize that the camera is frozen. Therefore I lost a few shots.

 

 

 

I've had some freezes as well...despite changing SD cards.

Share this post


Link to post
Share on other sites

I've had some freezes as well...despite changing SD cards.

 

 

I had the same problem with Transcend SD cards and cheaper SD cards from SanDisk. This was still in the days of firmware V1.0. After changing to the Extreme Pro series from SanDisk (V90), the problem never appeared again.

Share this post


Link to post
Share on other sites

Right, I sense that it may be a buffer/write problem. The few time my camera froze was in the days I was taking both dng and jpeg and shooting too many, too fast for the buffer. then, I'd toggle a couple of buttons and the camera would freeze. I've pretty much learned to shoot within the pace of how quickly the camera can now write dngs (which I only shoot now). Don't know if this is your problem.

Share this post


Link to post
Share on other sites

Ok, I just upgraded. I have some questions please. 1) When I go to the FN button, White Balance shows up and I want Exposure Compensation. Can't get rid of WB.  2) I want to dissarm the Video button.  I did that once, but with the upgrade, I need to do it again. Thanks.

Share this post


Link to post
Share on other sites

Ok, I just upgraded. I have some questions please. 1) When I go to the FN button, White Balance shows up and I want Exposure Compensation. Can't get rid of WB. 2) I want to dissarm the Video button. I did that once, but with the upgrade, I need to do it again. Thanks.

I believe your questions and many others are answered if you’ll read this thread from the beginning.

Share this post


Link to post
Share on other sites
Guest jvansmit

I had the same problem with Transcend SD cards and cheaper SD cards from SanDisk. This was still in the days of firmware V1.0. After changing to the Extreme Pro series from SanDisk (V90), the problem never appeared again.

 

My freezes happened when using Sandisk Pro cards

Share this post


Link to post
Share on other sites
Guest jvansmit

Neither the current firmware nor the previous versions had this problem.

 

Many beta testers had the current software in use for several months, I myself even on two different cameras with different settings. There were no crash problems at any time.

 

 

That's simply untrue....I posted some of my crashes on the beta testing thread (and you even replied!).

 

Once was probably my user error when I chimped & deleted (though I couldn'y replicate this) but the other occasions were random crashes when using 3 different Sandisk Extreme Pro 32Gb cards

 

One of the other beta testers also reported a freeze.

Edited by jvansmit

Share this post


Link to post
Share on other sites

That's simply untrue....I posted some of my crashes on the beta testing thread (and you even replied!).

 

Once was probably my user error when I chimped & deleted (though I couldn'y replicate this) but the other occasions were random crashes when using 3 different Sandisk Extreme Pro 32Gb cards

 

One of the other beta testers also reported a freeze.

Yeah, there was someone who had a freeze when using the Q App and another tester who had a crash, but also told us, that he had crashes before the firmware update. All other beta testers report that they had no crashes.

 

Since the firmware V3.0 is now used by thousands of Q users and there have been no mass reports of crashes, at least not more than with firmware V1.0 or V2.0, how do you come up with the idea to construct a firmware problem?

Share this post


Link to post
Share on other sites

My freezes happened when using Sandisk Pro cards

The red one with 95Mb/sec read an write or which one? The yellow version of the card can only read fast, but write action ist very slower.

Share this post


Link to post
Share on other sites
Guest jvansmit

Yeah, there was someone who had a freeze when using the Q App and another tester who had a crash, but also told us, that he had crashes before the firmware update. All other beta testers report that they had no crashes.

 

Since the firmware V3.0 is now used by thousands of Q users and there have been no mass reports of crashes, at least not more than with firmware V1.0 or V2.0, how do you come up with the idea to construct a firmware problem?

 

 

 

except that I haven't ever claimed it was a firmware problem or 'constructed a firmware problem'.  Like a minority of people in this forum, you simply keep on running interference and twisting other people's observations.

 

I wrote in the beta testing group that I'd had several crashes (using different Sandisk SD cards) after installing the new firmware, and that I'd never previously had a freeze in 2.5 years of using my Q. 

 

You also stated earlier in another thread that none of the beta testers reported freezes.....except that four of us did so (for whatever reason).

 

I'm not going to bother replying to you again.

Edited by jvansmit

Share this post


Link to post
Share on other sites
Guest jvansmit

[

Am curious to know what generation Q are these problems happening. because not everyone is having problems.

 

Thankfully, there’s no evidence to suggest that it’s a widespread issue, and it may be a camera or SD card issue....though I’ve tried different cards.

 

In answer to your question, my Q is approx 3 years old and was the first one received by my dealer so it may have an issue.

 

I’ve also noticed that since the new firmware, I’ve started to use -2/3 exposure compensation whereas previously I’ve routinely used -1/3rd., and the exposure seems inconsistent at night when I’m street shooting.

 

or it could be me getting senile

Edited by jvansmit

Share this post


Link to post
Share on other sites

I received email from Leica about firmware update this morning (and I also recieved one few weeks ago). This still says it's firmware 3.0 so my guess is this is just a reminder about the recent firmware and not another fix?

On the web page for downloads it says version 3.0 so it's probably the same as before, but given how sloppy Leica has been about documenting the upgrade process you never know ...

Share this post


Link to post
Share on other sites

I received email from Leica about firmware update this morning (and I also recieved one few weeks ago). This still says it's firmware 3.0 so my guess is this is just a reminder about the recent firmware and not another fix?

On the web page for downloads it says version 3.0 so it's probably the same as before, but given how sloppy Leica has been about documenting the upgrade process you never know ...

 

The instructions document now at least seem to be accurate where it requires holding down video button when turning on the camera before the update.

 

Also, the firmware file size is exactly the same as the one released few weeks ago so it's probably the same 3.0 version file.

Edited by tgdinamo

Share this post


Link to post
Share on other sites

Hello everyone, since the update I can not remove the visualization of the image in the viewfinder, I explain: once a photo is made, as long as you do not release the shutter, the photo taken remains displayed. However, I removed the auto view of photos. Before the update, I did not have this phenomenon. It's quite painful because I like working by soliciting the trigger constantly to keep the point ... If you have a solution I'm super taker! This MAJ has good things but must rummage through the menus that I have apparently not done enough!
Thank you in advance.

Share this post


Link to post
Share on other sites

Ah, the button i didn't check! Thanks for speedy reply. The update went on very smoothly and this camera's ability to take fantastic pictures far outweighs my ability. That, alone with the tactile pleasure of simply picking it up makes it perfect.

Share this post


Link to post
Share on other sites

Hello everyone, since the update I can not remove the visualization of the image in the viewfinder, I explain: once a photo is made, as long as you do not release the shutter, the photo taken remains displayed. However, I removed the auto view of photos. Before the update, I did not have this phenomenon. It's quite painful because I like working by soliciting the trigger constantly to keep the point ... If you have a solution I'm super taker! This MAJ has good things but must rummage through the menus that I have apparently not done enough!

Thank you in advance.

 

This is the worst thing about firmware 3.0, and no one complains. If you do not go back to previsualization completely off I sell the Q. Can they have done something like that?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...