Jump to content
LUF Admin

Leica Q: Firmware Update v3.0

Recommended Posts

This problem should be addressed directly to Leica, I'm not sure posting on this forum will do anything.

 

Wrote today to Leica Italia, if everyone make same is possible something happens

Share this post


Link to post
Share on other sites

This problem should be addressed directly to Leica, I'm not sure posting on this forum will do anything.

 

i also wrote them twice during the last weeks

Share this post


Link to post
Share on other sites

i also wrote them twice during the last weeks

 

 

Good luck. The last firmware update took only two years. 

Share this post


Link to post
Share on other sites

i also wrote them twice during the last weeks

Fast diplomatic Leica reply...

 

Thank you for your email of interest to Leica products.

 

In effect, the firmware update for Leica Q has provided the additional feature in the Auto Review mode immediately after the image is taken, ie the automatic review will be active as long as the shutter-release button is held down.

 

Give us time to test and in the meantime, we send your report to the software development department and we will give you an update as soon as it is available.

 

Thank you for your contribution.

Edited by benpisati

Share this post


Link to post
Share on other sites

I must be lucky. I updated to 3.0 and then went on holiday (ok long weekend in Paris) and 300+ shots later I am even more enthralled with the camera.

 

No lockup’s

No freezes

No issues.

Still working on processing the images - and I will post in the Q thread later (some already on my webpage)

Share this post


Link to post
Share on other sites

Good luck. The last firmware update took only two years. 

Yes, I am kinda afraid you are right. Leica M 240 lock-up issue took 2 years to fix. This might take just as long..

Share this post


Link to post
Share on other sites

When switching back and forth from manual to autofocus my Q has become non responsive. Once the preview remained on the LCD even after the camera was switched off, I had to remove the battery. I've done a restore and hope that it will remedy the issue but what I've seen in this thread I suspect something's happening due to the 3.0 upgrade. Very disappointing as I had maybe two freezes in the last 20 months.

Share this post


Link to post
Share on other sites

For the record, I read through this thread borderline horrified at what the 3.0 firmware would do to my Q, but went for the update anyways. Zero issues, love the favorites menu, and appreciate some of the new functionality. The image review thing is a non-issue.

Just wanted to add my two cents after reading all the negative posts.

Share this post


Link to post
Share on other sites

Welcome!!

 

Folks tend to post about stuff like this when they have complaints. hence, not representative. I've had a few bugs with 3.0 but think it's terrific nevertheless. some others, with different photographic styles, may feel that certain things they've come to rely on have changed.

Edited by bags27

Share this post


Link to post
Share on other sites

All:

 

I have been following this thread and want to see if there seems to be any consensus in terms of memory cards for the Q with Firmware 3.

 

During my first eight months with the Q, I experienced zero freeze ups. Then, I updated to Firmware 3 and have had two freeze ups while using the camera only sparingly. I’m using a Sandisk 32GB Extreme UHS-I card, with 90MB. 

 

Do there seem to be better results in terms of the Sandisk 64GB Extreme Pro UHS-II or the Lexar Professional 64GB 2000x?

 

Thanks for any input …

Share this post


Link to post
Share on other sites

I've just purchased Leica Q and it will be arriving this coming Tuesday. After reading this whole thread (on the freezing issues) I'm not too sure if I should update to firmware 3.0.

 

I managed to find the firmware 2.0 online, should I just update to firmware 2.0 first while waiting Leica to fix firmware 3.0 issues?

Share this post


Link to post
Share on other sites

I've just purchased Leica Q and it will be arriving this coming Tuesday. After reading this whole thread (on the freezing issues) I'm not too sure if I should update to firmware 3.0.

 

I managed to find the firmware 2.0 online, should I just update to firmware 2.0 first while waiting Leica to fix firmware 3.0 issues?

Rev. 3.0 is an excellent upgrade. Consistent with internet forums, IMHO the negatives or bugs are overblown and the positives are underreported. I recommend upgrading immediately.

Share this post


Link to post
Share on other sites

Rev. 3.0 is an excellent upgrade. Consistent with internet forums, IMHO the negatives or bugs are overblown and the positives are underreported. I recommend upgrading immediately.

+1. I've had practically the same experience. same card; one or two freezes. no big deal. 3.0 is significantly better than 2.0. A number of small improvements made it really smart upgrade.

Share this post


Link to post
Share on other sites

I've just purchased Leica Q and it will be arriving this coming Tuesday. After reading this whole thread (on the freezing issues) I'm not too sure if I should update to firmware 3.0.

 

I managed to find the firmware 2.0 online, should I just update to firmware 2.0 first while waiting Leica to fix firmware 3.0 issues?

 

We received our Q a couple of weeks ago.  It has 2.0 installed and I would imagine yours will as well.  I did upgrade to 3.0 last week and haven't noticed any problems yet. 

Share this post


Link to post
Share on other sites

We received our Q a couple of weeks ago.  It has 2.0 installed and I would imagine yours will as well.  I did upgrade to 3.0 last week and haven't noticed any problems yet. 

 

 

You're right, my Q arrived early today and it comes with firmware 2.0 installed.

 

I've actually tried out 2.0 first and shot about 170 photos, before updating to firmware 3.0. And you guys are right, the 3.0 update is great! and not sure if is just me, but I noticed the exposure metering works faster than 2.0.

Share this post


Link to post
Share on other sites

HI Everyone. I've updated today and I've been playing for a couple of hours. The one big change I notice is that post update, my Q is fine - until about 30 seconds when it starts constantly clicking as the iris moves (I can see it) as is changing the exposure as i reframe. It's really weird. Silent for 30 second as normal then "click click click click" as i reframe. I'm not sure whether its something that's been added in via the update or something I've set/not set as part of trying to get it back to the way I had it n V2. I'm a newbie here and any help would be much appreciated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...