Jump to content
erniethemilk

Firmware Update Tips

Recommended Posts

Advertisement (gone after registration)

Just picked up a used M10-P yesterday and noticed the firmware is not the latest.

I've read through the instructions on how to upgrade firmware and seems straight forward enough, just wondering if anything else is to be considered.  I've done upgrades in the past plenty of times with the likes of Fujifilm cameras, but obviously as a new (to me) camera, don't want to make any mistakes with it!

Share this post


Link to post
Share on other sites

1. Make sure your battery is fully charged before you start - if the battery fails during a firmware upgrade it could brick your M10.

2. Be patient and let it finish completely.

Pete.

Share this post


Link to post
Share on other sites

If you have user profiles, export them to a SD card first, then load them again after update. Most updates prompt you to do this, sometimes they don't. Most times you can export them to the same SD card as you use for the update - I usually do - but the paranoid may wish to use a separate SD card.

Share this post


Link to post
Share on other sites

Thanks for the information guys.... Have tried to update firmware and all I'm getting is a greyed out Firmware menu item, can't go any further than that.

Have tried two different cards each formatted in camera and followed instructions as per the Leica downloads page.

Any ideas?

Share this post


Link to post
Share on other sites

What firmware version does it say in the grayed out menu item?

Share this post


Link to post
Share on other sites

Advertisement (gone after registration)

Had you downloaded the right file ?

Firmware (2.7.5.0) Leica M10-P

Firmware
Chinese English French German Indonesian Italian Japanese Korean Polish Russian Taiwanese
Date: 09/04/2019 Format: FW (114.34 MB)
 
Going further...
 
if yes,
when you are at the page showing grayed 2.6.5.1 what had you done ?

Share this post


Link to post
Share on other sites

Have you extracted the firmware update file and copied it to the root directory ('home' directory) of your SD card?

When I used to use Windoze computers I needed to download the zipped file, extract the update file and drag it onto the root directory on the SD card.  I use Macs now and the extraction takes place automatically.

Since you're seeing a greyed-out menu item it suggests to me that your M10 maybe can't find an upgrade file where it expects it to be - or can't see it because it's encased inside a compressed (zipped) file.

Pete.

Share this post


Link to post
Share on other sites

Downloaded the file direct from Leica Website, copied and pasted directly on to formatted (in camera) SD card.

Just a thought, does the file need to go into the Leica 100Leica file, I've been copying it straight to the SD card - not in a folder of any description.

 

Share this post


Link to post
Share on other sites

The right file must be copied in the root of SD card !

Not in 100xxxx directory.

 

IS it the right file for M10-P ?

Edited by a.noctilux

Share this post


Link to post
Share on other sites

Could also be because you've downloaded the FW update more than once onto the same card? This has happened to me.In this case it overwrites  the original  download and adds a no.2 or 3 to the file name which the camera doesn't recognise. You have to reformat card and download again.

Edited by michali

Share this post


Link to post
Share on other sites
4 minutes ago, a.noctilux said:

The right file must be copied in the root of SD card !

Not in 100xxxx directory.

 

IS it the right file for M10-P ?

That's what I suspected, thanks, have copied file to root.

File Name is: M10-P-2.7.5.0-CUSTOMER.FW which shows as correct M10-P firmware download.

I've re-formatted SD card each time tried so far, so no duplicates of FW on the card.

Share this post


Link to post
Share on other sites
4 minutes ago, a.noctilux said:

Just wait 👍

Awesome, all worked by the look of it... New firmware now showing in camera information.

 

Thanks all for your help 😎

Share this post


Link to post
Share on other sites
8 hours ago, Peter Kilmister said:

@erniethemilk Welcome to the M10-P users. A fabulous camera and I am pleased you have updated the firmware. Please show us some photos when you are ready.

P.S. I am in West Sussex. Get in touch if you are nearby. 

Thanks Peter, appreciate your comments. I'm in Sunny Worcestershire so not too close unfortunately. First impressions of the camera are fantastic. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy