Jump to content
Sign in to follow this  
darkness30

Time for a service

Recommended Posts

Advertisement (gone after registration)

It is time for my R9 to get a service since i cannot change the ISO settings or set timers in anyways now. It either not comes up or shows everything and aint change.

What should i do? I believe it has a warranty on it since its about 2 years old but i am not sure about the USA waranty. I bought it while i was in USA but now i am in Turkey. Does that matter?

 

Thanks,

Mehmet

Share this post


Link to post
Share on other sites

Mehmet,

 

Please look at the contacts between body and back door in your R9.

Clean it whit conctac cleaner or alcool isopropanol , NOT 90% alcool!.

Maybe this solve your problem if not send it to Solms for checking.

I hope you not have one problem whit the back door.

Mine have one problem whit the cover they starts to pull out and nead replacement.

Good luck!

Share this post


Link to post
Share on other sites

Rui, thanks for the tip however, i did clean the contacts but to no avail. This condition started about a year ago. First, i could only change ISO when no film was inserted and no timer function and now it shows 888888 and other symbols at the same time and no other function. It seems like i have no choice but i am also afraid that this might cost a lot and took a lot of time as well.

 

Thanks

Mehmet

Share this post


Link to post
Share on other sites

I had the same problem nearly brand new. If you dont travel with a cotton bud for cleaning contacts, you are likely not to be able to use the camera during a trip. I nearly hoiked my R9 into the Mekong. Bit of a joke. If I had another body with me at the time it would have been swimming with the fish by now.

If it doesnt come good with cleaning the contacts in the film recess I guess it is a send away. Leica need a wake up call. Nice optics, crap cameras.

Share this post


Link to post
Share on other sites

Mehmet,

 

My R8 comes whit 5 years warranty so I think your´s R9 was the same time of warranty.

Can you change the iso settings whitout any film loaded?

Mine R8 give me one problem whit one film canister because they are some dust in the DX contatcs.I clean the film canister DX contacts and inside the R8 DX contacs no more problems.

If you have one Leica agency in your country try to test your camera whit other back door because the problem cam be the small electronic board whit are the LCD and setting bottons for the ISO and timer.

I think Leica cam repair this problem whit cover of warranty.

 

Good Luck,

Share this post


Link to post
Share on other sites

Friends, thank you, thank you, thank you

 

After throughly cleaning the both male and female pins it started working back. Darn, all this time i though there is smtg wrong with my Baby. I also have two SL (old boys) which keep me busy but i cant use all my lenses with them. Still they do the job well.

 

Thanks again for the help and yes Leica should take care of this problem.

 

Mehmet

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy