Jump to content

Lens hood coming apart - what glue?


Recommended Posts

Advertisement (gone after registration)

The lens cap for my 35mm TL lens, is made in two parts. There is a metal hood, with a hard plastic ring at the lens-end to help with the clipping in and out. The two parts have divorced. The first glue I've tried (apparently Silicone based craft glue - though I'm sceptical) hasn't stuck to the plastic sufficiently well.

Anybody got any suggestions as to glues that may work better? I was going to try some black acid-free Silicone next.

Link to post
Share on other sites

I have frequently used Araldites very successfully for mending lens hoods, regardless of the material they are made of. It is a two pot mix and requires some time to attain max strength. Foe a lens hood that is probably not an issue.

Link to post
Share on other sites

  • 2 weeks later...
On 5/8/2024 at 12:22 AM, KitW said:

The lens cap for my 35mm TL lens, is made in two parts. There is a metal hood, with a hard plastic ring at the lens-end to help with the clipping in and out. The two parts have divorced. The first glue I've tried (apparently Silicone based craft glue - though I'm sceptical) hasn't stuck to the plastic sufficiently well.

Anybody got any suggestions as to glues that may work better? I was going to try some black acid-free Silicone next.

I contacted my local Leica store and they ordered me a new hood. Didn’t even ask where I got the 35mm TL lens from (an auction!). When I got the new hood, I repaired the existing hood with Araldite glue, so now have two. To be honest, they are fairly flimsy, so only to be expected. Not what you would usually say about a Leica product. Maybe that is why they got me a new one? 

Link to post
Share on other sites

Posted (edited)

I've used cyanoacrylate (superglue) for this. The space for the glue is very narrow and tight, and I find epoxy resins (araldite) a bit thick for this - difficult to control the excess. Superglue is thin and a few dots around the circumference are enough. But both would work.

Several Leica hoods, all in L-mount IIRC, have this identical failure mode. Irritating but not unrepairable.

Edited by LocalHero1953
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...