Jump to content

M-A 127, Frame selector issue / crooked mount?


Recommended Posts

Advertisement (gone after registration)

Hey- I got recently a brand new Leica M-A Typ 127 and acquired a Voigtländer Ultron VM 35mm 1:2.0 Aspherical II. The moment I received them, I attached the lens correctly matching the red dots while pressing the button and stopped when hearing the securing click, no force was applied nor resistance happened. I started testing the camera and everything was wonderful. I had a 35mm lens but used the frame selector lever to preview other focal lengths, everything worked nicely.

I've taken some beautiful photos with this setup and no problems at all.

Fast forward some time, today I tried to preview other focal length, but this time it didn't work, nothing happens on the viewfinder, I removed the lens (while pressing the button), I played with the Frame preview lever and noticed it was moving alright, while further inspecting the inside I noticed how the camera's mount seemed all crooked and since I didn't notice how it looked before when I first attached the lens so I don't know if that's just how it secures the lens or it's completely crooked lol 

but HOW, I attached the lens correctly, no resistance occurred, I was able to preview the frames before and then suddenly it stops? does anyone have heard of a problem with the frame preview lever? and anyone with the same camera... how the camera's mount chassis look? thanks in advance!

Link to post
Share on other sites

Posted (edited)

Hello,

Welcome here,

in your place, I'd go to ask where you purchased the M-A.

The dealer is there to answer your questions and take to repair if need be.

 

Asking here is not productive.

 

For me the spring which retains the lens is NORMAL.

you don't show the right part of the selection device, near the lever.

Edited by a.noctilux
Link to post
Share on other sites

Posted (edited)

I'm not seeing anything that looks crooked, can you surperimpose an arrow on the photo to illustrate? The very first thing to rule out are user error. Mount the lens and keep your finger off the lens release button as you turn it to lock with a click, never touch the lens release button when mounting a lens, only when taking it off. 

Edited by 250swb
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...