Jump to content

Annoying experience installing CL firmware 4.1


Recommended Posts

Advertisement (gone after registration)

I've just wasted half my evening getting my head around the installation of the latest CL firmware.

- Tried several cards.

- Formatted them using SDFormatter, then in-camera.

- Went to the Leica website download area and downloaded the file.

https://leica-camera.com/en-GB/photography/cameras/cl-tl/cl-black/firmware

Again and again and again, each time getting the message: "No firmware on SD card found"

The problem, it turned out is in the name assigned to the firmware on the site itself:  pm-53973-CL___41_.lfu

As soon as I deleted the prefix "pm-53973-" leaving only CL___41_.lfu all was good.

Why in the world has that prefix been left there... by Leica???  😡

Link to post
Share on other sites
vor 19 Stunden schrieb M9reno:

I've just wasted half my evening getting my head around the installation of the latest CL firmware.

- Tried several cards.

- Formatted them using SDFormatter, then in-camera.

- Went to the Leica website download area and downloaded the file.

https://leica-camera.com/en-GB/photography/cameras/cl-tl/cl-black/firmware

Again and again and again, each time getting the message: "No firmware on SD card found"

The problem, it turned out is in the name assigned to the firmware on the site itself:  pm-53973-CL___41_.lfu

As soon as I deleted the prefix "pm-53973-" leaving only CL___41_.lfu all was good.

Why in the world has that prefix been left there... by Leica???  😡

I had my CL repaired by Leica late summer, it came back with FW 4.0 not 4.1. I decided to try to do the update, and yes the prefix messed it up, took it off and the camera was updated. Thanks for going through this first, I had another piece of software give me frustrating problems today don't know how I would have reacted. All is well.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...