Jump to content

Q2/firmware 2.0 - Unable to update firmware to 3.1


Recommended Posts

Advertisement (gone after registration)

Hello all,

I waited a long time before updating my Q2. But I cannot do it... I'm getting the message there is not firmware on the SD card. The SD card has been reformated, the firmware redownloaded, put at the root level of the card, the battery is fuly charge. No way. Same message.

Anyone encountered such a problem?

Thanks in advance...

André Rombauts,

Belgium

Link to post
Share on other sites

Thanks for your reply... BUT this is not the issue: even the 2.0-> 3.0 gives the message 'No firmware found on the SD card'. I tried a new fresh card, a smaller one (8Gb instead of 128). No way...

The file is named 'pm-55168-Q2___30_.lfu'. Is this correct? I cannot find another one. BTW Leica support site is not that good. If I login my account where I registered the product, I got a message that there are no updates for my model ! If I click on the 'download' link I redirected to a search page that gives me only press releases !!!

Link to post
Share on other sites

I checked the US site ... if I login I cannot find downloads ... so I re-entered the site home ... found Q2 and looked at firmware updates ... only 3.1 on

the site and the naming is similar to what you have. However my Q2M firmware does not have the PM-55xxx only Q2M_1.lfu

Wonder if renaming the file to Q2_30.lfu would make any difference.

See this thread ...

 

Edited by docmoore
Link to post
Share on other sites
7 hours ago, Saulitude said:

I waited a long time before updating my Q2. But I cannot do it... I'm getting the message there is not firmware on the SD card. The SD card has been reformated, the firmware redownloaded, put at the root level of the card, the battery is fuly charge. No way. Same message.
Anyone encountered such a problem?
André Rombauts,Belgium

SOLVED

I ended to contact directly Leitz-Park in Wetzlar and got I reply from T.K. there.

My problem came from their faulty website that was sending bad update file. They apologized and are correcting the webiste.

The correct file for Q2 3.1 update is 'Q2___31_.lfu'. It is not necessary to update 1st from 2.0 to 3.0 before applying 3.1 update. I did it and it worked.

Have a good evening,

André Rombauts, Belgium

Edited by Saulitude
Link to post
Share on other sites

Advertisement (gone after registration)

3 hours ago, Saulitude said:

SOLVED

I ended to contact directly Leitz-Park in Wetzlar and got I reply from T.K. there.

My problem came from their faulty website that was sending bad update file. They apologized and are correcting the webiste.

The correct file for Q2 3.1 update is 'Q2___31_.lfu'. It is not necessary to update 1st from 2.0 to 3.0 before applying 3.1 update. I did it and it worked.

Have a good evening,

André Rombauts, Belgium

The firmware files on Leica's website have all wrong names and need to be renamed after download and before installing.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...