Jump to content

Tele Elmarit M 90 - serviceable problem ?


xme53
 Share

Recommended Posts

Advertisement (gone after registration)

My Tele Elmarit M 90 shows these marks when inspecting under a certain angle. It looks like dried water behind the front-element of the lens. It does not show in photos but still it concerns me. Is this serviceable? Have you ever seen something like this? 

Edited by xme53
Improving clarity
Link to post
Share on other sites

  • xme53 changed the title to Tele Elmarit M 90 - serviceable problem ?

Hard to say what the cause is. Could be balsam separation (if applicable, I did not check whether the optical construction of that lens includes any cemented elements), but I suspect that it may be residues of humidity that has condensed on the inner surface of the first lens element at some point. A competent service person should be able to clean that inner surface.

Link to post
Share on other sites

You may want to send it in for a CLA. It has been effective with the 4 lenses I have sent in. One lens had substantial internal surface fungus, it was all cleaned out, another was a beat up 90 Elmarit. I have used Yousin Ye for my Leica lenses, there are others, DGA, Sheri Krauter and others.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...