Jump to content

50mm Summicron query


Punkrockemo
 Share

Recommended Posts

Advertisement (gone after registration)

I have an older version of the 50mm (Version 4  I think-See picture) that i have had for a while. There a couple of things i am not sure about.

  1. When focusing I find that for subjects up to 2m it back focus's slightly unless I compensate for it. For subjects further away it focus just fine. Aperture does not seem to affect it.
  2. I seem to be able to unscrew the front section of lens (In front of focus lever/barrel)- is that normal?

I assume the lens may need servicing. I am not sure where to go to get that done. I live in the UK

Link to post
Share on other sites

6 minutes ago, Punkrockemo said:

Thank you both. I have found a couple of places I can contact in the collector-Historica forum as suggested.

Does anyone have opinion on if the issue I expereinced is common  

Second issue is not common. In relation to back focus, is this your only lens that does this?  If so, lens needs adjustment, but if your sole lens may be camera rangefinder needs/also needs adjustment. FWIW

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...