Jump to content

Calonox View USB-C port has strange limitation


Recommended Posts

Advertisement (gone after registration)

The Calonox View usb-c port supports charging and the transfer of data (pictures, videos).

It works with usb-c to usb-a cables with chargers or computers which have an usb-a port.

However, the port does not work with an usb-c to usb-c cable. I tested multiple cables and
different chargers and computers. Always the same negative outcome.

The Calonox View device comes with an strange usb-c to usb-a/video-chinch splitter cable.
This cable works - but obviously for charging and data transfer per usb-a only.

I can't find the reason for this unfortunate limitation - especially considering that
usb-c shall replace usb-a ports.

Has someone a solution?

Also, I can't figure out how to update the Calonox View firmware - nor did I find any
information regarding firmwares for this device on Leica's pages. In my case, the
installed firmware is v5.0 but I'm wondering how Leica want's to maintain such a
high-end device without software updates? Has anybody a solutionn to this problem?

 

Link to post
Share on other sites
  • 2 months later...

Hi there Shimo. I also have the Calonox View and was wondering exactly the same about the ability to upgrade the firmware.

Already I have noticed some (what I think are) bugs - perhaps you could check your own device and confirm:

1. Always seems to revert to Brightness level 4 after powering off and on, also reverts to Calibration Mode A, and perhaps other settings don’t get retained either.

2. Now - very strangely - if you select a display mode such as Red Hot and then power off and on, the device restarts in Red Hot mode - but the icon in the header line has reverted to White Hot mode!

3. When on charge, the red led never seems to go out. I’ve left it overnight, but perhaps it takes even longer.

4. The names of the folders in the app are based upon inaccurate and inconsistent dates.

5. The app seems to need me to enter “Device Storage” to trigger a connection to the device.

6. Register Product does not work for the Calonox devices on their website.

All in all Leica seems to have done a good job on the optics and a less good job on the front end software - perhaps unsurprising, given their historic expertise.

It would be great to keep in touch - as you are the only other person I’ve discovered who also owns a Calonox View.

CB

Link to post
Share on other sites

Hi @cloudburst, beginning of the year, I spoke to one of Leicas technical support staff. He confirmed, that they are working on a firmware update to address bugs. At this time he sad that the new firmware would be available end of January. Obviously this did not happen so far. Yes, the current firmware is buggy but you list quite few issues which I can not confirm. I agree, the optics and the hardware quality are superb and sooner or later they should be able to address the software bugs.

1. No, in my case it does keep the last brightness level.

2. No, it works for me, it keeps the last mode and the icon is consistent.

3. No, the red LED does go off after the Calonox View is fully charged.

4. No, names and dates are correct. In my case it's messed up when the storage space gets filled up

5. ?

6. Did not try it.

Which release is your device running on? Here are my data:

GUI: V5.0
SYS: ----
BOOT: V1.3
FPGA: 222
HW: V50B

 

Link to post
Share on other sites

Hi Shimo,

Many thanks for your response. My system into is as follows:

GUI: V5.0

SYS: 20200729194

BOOT: V1.3

FPGA: 222

HW: V50B

So it looks the same as yours except for the SYS line.

 

Can you confirm that you are doing a full power off (as opposed to just power save mode)?

 

All is fine for me, if I just switch in and out of power save mode, however, if I power down and restart, then the following happens:

- Zoom reverts to x1 (this may be normal)

- Brightness level (and icon) reverts to level 4

- Heat display mode (eg. Red Hot) is retained, however, icon in menu and status header reverts wrongly to White Hot

- Contrast reverts to level 1

- Video out (if selected) remains on, however, menu slider says off and icon in status header has disappeared

- Calibration Mode reverts to Auto


All that is quite separate from the various minor issues with the app.

So I’m left wondering what to do about this. What do you think?
 

Many thanks for your help.

 

CB

 

 

 

 

 

Link to post
Share on other sites

Hi @cloudburst, I am 100% certain, yesterday I tested all of our listed issues with my Calonox View by fully powering down the device. Very strange - and by the way - your issue with the "permanent on red LED charging indicator" is anyhow independent of powering down the device. Thy SYS number I did not put down in my post. I suggest to wait few more weeks until a firmware update is available.

Link to post
Share on other sites

Many thanks again @Shimo, I have just this morning had very quick responsive customer care from Leica in the UK, who have confirmed with their counterparts in Germany that my device is “not right” and will be replaced right away.

Thanks to you for your quick response last night! It got things moving, otherwise I would have been left wondering for weeks...

CB

Link to post
Share on other sites
  • 3 weeks later...

Advertisement (gone after registration)

Hi @Shimo - just to let you know I received today a replacement device from Leica and all is now working properly.

Note that my system info on the new device differs in one respect - FPGA is now 229.

Thanks again for your help.

CB

 

Link to post
Share on other sites

Hi @cloudburst, thanks for your update and good luck with your new device. In case you have an "USB-C to USB-C" cable at home, could you test whether your new device can be charged with an USB-C charger or whether you can connect your device with an USB-C to USB-C cable with an USB-C port on your computer and transfer files. At least in my case, my Calonox came only with an "USB-C to USB-A" cable - obviously with this cable any USB-A charger works and also the "USB-C to USB-A" link with the computer works.

Link to post
Share on other sites

@Shimo can I ask you another couple of questions though. Firstly, how do you normally set the calibration mode? How often do you find you need to calibrate. Are there any display artefacts that you see in certain circumstances for example?
And secondly, do you find the contrast settings any use? How do you normally have it set?
 

Thx.

CB

Link to post
Share on other sites
  • 2 weeks later...

@Shimo - connect your device with the Calonox app.
 

Then in the app:

- Hit the circular red button at the bottom of the screen.

You will now be in the “live stream” screen.

- Hit the gear icon near the top right.

You will now see the option to perform a firmware update.

 

CB

Link to post
Share on other sites
  • 2 weeks later...
Am 8.4.2021 um 17:51 schrieb cloudburst:

Hi @Shimo - just to let you know I received today a replacement device from Leica and all is now working properly.

Note that my system info on the new device differs in one respect - FPGA is now 229.

Thanks again for your help.

CB

 

Hi cloudburst,

I just received my Calonox a week ago. It has the build date 2021-04-20. Even it has the same specs as your replacement, I have the exact same issues as you had with your first Calonox. When I switch it off and then on:

  • Zoom reverts back to x1
  • Brightness level (and icon) reverts to level 4 (very annoying)
  • Heat display mode (eg. Red Hot) is retained, however, icon in menu and status header reverts wrongly to White Hot
  • Contrast reverts to level 1 and has no function at all
  • Video out (if selected) remains on, however, menu slider says off and icon in status header has disappeared
  • Calibration Mode reverts to Auto
  • Connected to a mac it does not detect the Calonox (no drive icon ist shown or mapped)

I am a bit frustrated that this happens even to the latest version. Propably I have to go the same way as you and get in contact with the support. Does anyone have the same issues? Is yours really fixed? Or is it a SW-bug?

GUI: 5.0
SYS: 20200729194
Boot: V1.3
FPGA: 229
HW: V50B

Regards
Beo

Link to post
Share on other sites
Posted (edited)

Hi there @beosoundfan_, my replacement unit has been fine so far.

After receiving it, though, my UK Leica contact informed me that the Calonox expert in Leica Germany had come up with a way of resolving the issue without returning the device, so I think this suggests a software rather than hardware issue.

One other issue with my original unit was that the red led stayed on whilst plugged in, rather than turning off to indicate the charge being complete. Does your unit suffer this issue too?
 

Please keep us posted on how you get on. It’s nice to have contact with another user!

ONE WORD OF ADVICE: don’t wait any longer to contact support. Leica processes to return items are much easier as long as it’s done within the first 2 weeks!!
 

CB

Edited by cloudburst
Link to post
Share on other sites

Hi @cloudburst,

thanks for your quick reply. I will get in touch with my dealer which has a close contact to Leica Germany. Hopefully I can fix it by some key strokes or magic tricks 😉 Factory reset and holding down + and - for more than 60 seconds did not fix it.

The red LED is working properly (although different than mentioned in the manual). It turns green (and not off), when fully charged.

The things that makes me wonder is the contrast setting. That seems to have no effect. The picture is not changing. It stays the same. Regardless if I choose 1, 2, 3 or 4.

I'll keep you posted on updates on this topic.

Regards
Beo

Link to post
Share on other sites
On 5/4/2021 at 2:36 PM, beosoundfan_ said:

The red LED is working properly (although different than mentioned in the manual). It turns green (and not off), when fully charged.

The things that makes me wonder is the contrast setting. That seems to have no effect. The picture is not changing. It stays the same. Regardless if I choose 1, 2, 3 or 4.

I had my first Calonox View exchanged for a replacement because of an issue that occured in UltraClear-mode. The device froze twice, giving a still image and the only way to get it working again was a hard reset. I told Leica about this and they wanted to investigate my device so they proposed to give my a replacement. 

My new Calonox is flawless and it has no issues with UltraClear mode anymore. What is new, while my first device had the red led going out when fully charged, the new device's led goes green when fully charged. 

I have wondered about the contrast setting too. After some internet research I believe that in fact it is not a contrast setting (contrast is already enhanced in Ultraclear-mode to improve visibility in bad weather conditions), but I believe it is a setting for sharpness. This model from Infiray has a similar menu and icons, and in the manual you can see that the same icons used in the Calonox to indicate contrast are used in the Infiray to indicate sharpness. Also when you increase the 'contrast' setting in the Calonox you can see that it actually enhances the edges of image elements (especially visible on clouds).

 

 

Link to post
Share on other sites
Posted (edited)

Good to see some other users! And interesting to see the change in LED operation.

Regarding the contrast setting, yes, I can only notice small changes in sharpness, most easily seen when cycling directly between setting 4 and 1.

I do notice a faint ring-shaped artefact at times, when the background is plain (quite large at about 1/5 the size of the screen,  centred left to right and slightly higher than centre). It disappears on a B-mode calibration, but returns most noticeably when moving focus all the way in each direction, with a plain background, and once an A-mode calibration happens. It doesn’t change size. And it is not visible when there is a detailed image on screen.

Anyone else?
 

CB

Edited by cloudburst
Link to post
Share on other sites
  • 2 weeks later...

My unit is still at Leica (my dealer send it to them in order to check/fix it). Therefore I cannot contribute to the observations made here at the moment. But I will check as soon as I get the Calonox back.

The statement by @WimDel is very interesting. Looking at the specs and look of the symbols/software/UI I have the impression that the Calonox ist electronic wise 100% the chinese Infiray. Even the app looks almost the same. If that is true I am a bit disappointed because the price of the Leica is 1.000€ more. Sure the optics and haptics are better but...

That also explains probably why the Mac OS is not supportet and the app is not designed for iPad (cheap offshore app development). Outsourcing/Re-branding is a bad idea, Leica. If this would have been 100% native Leica stuff than, I would bet, those things would look a bit different (e.g. video out would have been HDMI and not analog S-Video). I must confess that I am a bit frustrated by this observation. At least I hope that Leica will improve/enhance the firmware in the near future. Why? The Infiray has more features (Picture-in-Picture, more picture modes etc.). So, there is room for improvement 😉

Link to post
Share on other sites
On 5/8/2021 at 12:08 PM, cloudburst said:

I do notice a faint ring-shaped artefact at times, when the background is plain (quite large at about 1/5 the size of the screen,  centred left to right and slightly higher than centre). It disappears on a B-mode calibration, but returns most noticeably when moving focus all the way in each direction, with a plain background, and once an A-mode calibration happens. It doesn’t change size. And it is not visible when there is a detailed image on screen.

Anyone else?

Yes I noticed that too, while scanning the sky for migratory birds. Indeed using B-mode calibration certainly made a difference. Although I find it not the most comfortable way of calibrating, constantly putting the lenscap on and off. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By LUF Admin
      Leica hat die neue Firmware V 3.0 für die Leica SL2 vorgestellt.
      Die Verbesserungen im Detail:
      Neuer Autofokus-Algorithmus Verbesserte Augen/Gesicht/Kopf/Körper-Erkennung und Fokusverfolgung. HEVC Video Kompression Interne 4K-Aufzeichnung mit 10 Bit bei 60p/50p mit h.265-Codec. Long-GOP Die Aufzeichnung für 10-Bit-Codecs mit 150 - 200 MB/s bietet die gleiche Bildqualität wie All-Intra, aber weniger als die Hälfte der Datengröße. Segmentiertes Video Die Videoaufzeichnung wird in 1-Minuten-Segmente aufgeteilt, um Datenverlust zu vermeiden. Individuelle Viewing LUTs Upload-Funktion für individuelle Look-Up-Tabellen. Erweiterte Live-View-Funktion Bessere Steuerung der Bildkomposition bei schwachem Licht für das Live View-Bild. Bild-Überlagerung Ermöglicht die Ausrichtung der Kameraposition auf der Grundlage eines zuvor aufgenommenen Bildes, das im EVF oder auf dem LCD-Bildschirm transparent angezeigt wird. Automatischer Follow Focus Definition von drei Fokuspunkten für die automatische Fokusverlagerung während der Videoaufnahme. Die FN-Tasten können nun verwendet werden. Schärfeeinstellung in Video und Live-View zusätzlich zu vordefinierter Sequenz. Wave form monitor Professionelle Belichtungsbewertung des Videosignals. Color Bar Referenz für korrekte Farbkorrektur und Tonsteuerung in der Postproduktion. Aufnahmeanzeige Rahmen (Tally Mode) Kamera zeigt roten Rahmen im Display bei Videoaufnahme. Belichtungsmessung mit Lichterpriorität Messmethode mit der Priorität für den Erhalt der Lichter. Dynamikbereich Steuerung Helligkeit in Schattenbereichen erhöhen. Hell-Dunkel-Steuerung Präzise Steuerung der Kontrasteinstellung. » Zur Downloadseite Leica SL2 Firmware 3.0
    • By wolan
      Hi,
      I have recently bought an SL2-S and at beginning I'll mainly use with manual focus (M) Lenses.
      However, I really like the 90-280mm tele and I might buy second hand
      A couple of questions about autofocus:
      in all honesty, how good is the SL2-s autofocus when compared to say a Nikon Z6 (the camera I own)? same question as above for most advanced autofocus features, auto-focus tracking, face recognition etc. If am not mistaken, a massive firmware update for the SL2-s with significant improvements for the autofocus system was announced. Has it been released? In the 2.0 I have not seen much about the autofocus Many thanks in advance for your answers.
      Cheers.
    • By LUF Admin
      Leica has updated the Leica Q2 (V 3.1) and Leica Q2 Monochrome (V 1.1) firmware.
      The Improvements:
      Pixel mapping to hide defective sensor pixels. Extended setting options for Touch AF when the electronic viewfinder is activated » Download Leica Q2 Firmware V 3.1
      » Download Leica Q2 Monochrome Firmware V 1.1
       
    • By Jeff Lee
      I just brought a D2 but I have a problem. When I turn on the D2 without the SD card all the function is good but once I inserted the SD card the shutter speed button is out of control. When I press down the shutter speed button it take around 10-15 seconds to shoot a photo and each 10-15 seconds it will automatically shoot another photo. And so wired when I look at the photo info in my PC it shows it is took by D3 not D2 but every time I reboot the camera it will allow me to press the shutter speed button again ... here is photo that I check my firmware in D2 ... anyone know how to fix it ? 

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By Shimo
      Das Calonox View har eine USB-C Schnittstelle zum Laden des Akkus als auch zum Übertragen von Daten (Fotos). Verwendet man eine USB-C zu USB-A Kabel funktioniert die Schnittstelle auch sowohl am Rechner als auch mit verschiedenen Ladegeräten. Verwendet man allerdings ein USB-C zu USB-C Kabel, funktioniert die Schnittstelle nicht. Ich habe sowohl verschiedene Kabel, als auch verschiedene Netzteile und Rechner ausprobiert. Die Firmware auf dem Calonox View ist 5.0. Ich habe bisher keine Möglichkeit gefunden, wie man die Firmware aktualisieren kann, noch habe ich bei Leica eine neuere Firmware gefunden - was nachvollziehbar ist, da das Gerät ja neu auf dem Markt ist. Hat jemand bzgl. der USB-C Schnittstelle ähnliche Erfahrungen gemacht? Weiss jemand wie man die Firmware aktualisieren kann?
      Ansonsten aber eine super Wärmebildkamera. Die Qualität ist wirklich Leica typisch super.
       

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
×
×
  • Create New...