Jump to content

SL2 post Firmware 2.0 update occasionally freezing


Shashinka
 Share

Recommended Posts

Advertisement (gone after registration)

I wonder if anyone else if experiencing the SL2 freezing, no response, even if I switch off the OLED display and LCD panel still show information.  This only seems to have happened after I updated to the latest firmware V2.0.  The only action is to remove the battery and then start again.  This has happened 2-3 times in the last week or so.  So not immediately after the update, which is slightly more concerning.  

Link to post
Share on other sites

I have have been using my SL2 since November, so far I haven't experienced any freezes, neither before nor after the update. I would have it checked at the Leica Store, if I were you. Maybe they can roll back to the original firmware and then re-perfom the last firmware-update (if that is possible).

P.S.: You have posted this in the German section of the forum, which might be the reason that noone has answered so far. 😉

Edited by Macberg
Link to post
Share on other sites

3 hours ago, Macberg said:

I have have been using my SL2 since November, so far I haven't experienced any freezes, neither before nor after the update. I would have it checked at the Leica Store, if I were you. Maybe they can roll back to the original firmware and then re-perfom the last firmware-update (if that is possible).

P.S.: You have posted this in the German section of the forum, which might be the reason that noone has answered so far. 😉

thanks for the reply - I will speak to the Uk Leica tech support.

Link to post
Share on other sites

29 minutes ago, mediafotografie said:

same here, I used the SL2 for several month, no freezing.

But wait, I've got an exception: SL2 in combination with a Nikon flash can freeze. Could't try a Leica flash because don't own one.

I never had issues with the freezing before, but now you mention flash I have recently tried the `Godox' brand of transmitters (Canon Type) just for central pin firing.  I really wish Leica would reach out to Godox to have their own version of the transmitter.  Perhaps this is the cause.

Link to post
Share on other sites

Advertisement (gone after registration)

25 minutes ago, scroy said:

I have not experienced any freezing at this point.  Is the antecedent the same or random?

 

It was random, but having thought about things that recently changed, I started to use the Godox transmitters for off camera flash.  As much as I have 3 x sf60 + controller, they are pretty limited in features (apart from HSS) and the Godox system would suit me better.  Perhaps the Godox transmitters (Canon Ver) are causing the freezing.  My issue is the transmitter was not connected to the camera on one of the occasions when it locked up.

 

Link to post
Share on other sites

  • 3 weeks later...

I know I’m late but I have add the same thing happen to me. At our studio we have flashpoint and Godox......exact same things seem to have happened to me like 3 or 4 times. I’m using Nikon Godox pro trigger...(center pin situation). This happened to me a few times before the new firmware 2.0.  I’m not shooting in burst mode..I use single shot. Every now and again it gets pretty fast as far as the poses  but nothing super fast. If I had to guess it probably has something to do with the non Leica trigger situation. 

Link to post
Share on other sites

2 hours ago, dathinc said:

I know I’m late but I have add the same thing happen to me. At our studio we have flashpoint and Godox......exact same things seem to have happened to me like 3 or 4 times. I’m using Nikon Godox pro trigger...(center pin situation). This happened to me a few times before the new firmware 2.0.  I’m not shooting in burst mode..I use single shot. Every now and again it gets pretty fast as far as the poses  but nothing super fast. If I had to guess it probably has something to do with the non Leica trigger situation. 

I think you are correct.  I wish Leica would realise that people will have to use additional flash systems to connect.  Even if they had used the panasonic contact and triggering system it would have helped.  I don’t have Any faith that they will sort out, flash for the, has been notoriously weak and even the sf60 and controller combination is extremely limiting for professional use.  So the question is about long term damage and warranty invalidation.

Link to post
Share on other sites

On 23/8/2020 at 14:50, Shashinka said:

Mi chiedo se qualcun altro abbia riscontrato il congelamento di SL2, nessuna risposta, anche se spengo il display OLED e il pannello LCD mostra ancora le informazioni. Questo sembra essere successo solo dopo aver aggiornato all'ultimo firmware V2.0. L'unica azione è rimuovere la batteria e poi ricominciare. Questo è successo 2-3 volte nell'ultima settimana circa. Quindi non subito dopo l'aggiornamento, che è leggermente più preoccupante.  

For this reason after 4 months of life of my SL2 sent today to Leica Wetzlar ............ still hard to believe it

Link to post
Share on other sites

7 hours ago, Shashinka said:

I think you are correct.  I wish Leica would realise that people will have to use additional flash systems to connect.  Even if they had used the panasonic contact and triggering system it would have helped.  I don’t have Any faith that they will sort out, flash for the, has been notoriously weak and even the sf60 and controller combination is extremely limiting for professional use.  So the question is about long term damage and warranty invalidation.

Honestly for it to be such a awesome device thats a work horse I can't help but feel like I purchased a monster truck for a Le Mans  race. I won't get into my fillings on the fact I can't seamlessly shoot tethered through capture one without doing a bunch of extra stuff. Why even have a hotshoe if we can only use Leica Speed Lights? The photographers I have learned to love that shoot these beautiful cameras have been using strobes forever now why can't Leica produce or allow someone else to produce a trigger that is actually for LEICA?????? Now I'm sad. 😞 COVID goin on.....they will probably have my camera till 2021/

Link to post
Share on other sites

  • 1 month later...

Exactly the same situation with my Sl2 camera as well. Today I experienced this again when shoot ing on location, and have previously also experienced this several times.

I shoot a series of pictures, and after a while the camera freezes with the last picture on displays inside the viewfinder on the camera, the only option to continue shooting is to turn off the battery grip and remove the battery in the camera. Then I can continue. Today I used the camera without a flash trigger. Have also experienced that the camera freezes when using the Profoto air TTL transmitter (For Nikon) My SL2 also has the latest version of firmware (2.0).

Have any of you who have experienced the same problems received any explanation or solution to the problems?

Link to post
Share on other sites

after few frustrating shoots I have to say the SL2 software it is not good.

I got in touch with Leica software team and they didn't seam interested.

Freezing and after not connecting is embarrassing when you have a high profile shoot and the client is waiting.

this is what keep happening! The camera some time freezes on a tether shoot with Leica Image Shutter software. after restarting the software won't see the camera and no tether is possible . A this point you may think the camera or computer is the problem.

Breacking down the factors. Use another laptop with fresh install new system and Leica software, all up to date. Capture one to view. changed cable and batteries and still nothing.

I take out the 2nd SL2  and connect to the first laptop. It all works for one hour and then the Leica software does not come up!. when connected  it only seam the Leica software on the computer is not seen it. The camera shows all the indicator that it is connected, status light and screen said connected.

at this point I take out the iPad but it is not really a work tool with Fotos app.

I take back the first SL2 that previously was not connecting, and after a few tries it connects again.

This dance of switching camera got me true the shoot, with some pain and frustration.

If Leica is not leasing this camera will never improve and probably never bee a professional studio camera, at this point we don't even need to bother with Light Triggers .

In my experience the SL2 is only usable for what it can do. Available Light shoots not connected anywhere .

 

Link to post
Share on other sites

  • 3 weeks later...
On 10/26/2020 at 10:25 AM, MoWa said:

Exactly the same situation with my Sl2 camera as well. Today I experienced this again when shoot ing on location, and have previously also experienced this several times.

I shoot a series of pictures, and after a while the camera freezes with the last picture on displays inside the viewfinder on the camera, the only option to continue shooting is to turn off the battery grip and remove the battery in the camera. Then I can continue. Today I used the camera without a flash trigger. Have also experienced that the camera freezes when using the Profoto air TTL transmitter (For Nikon) My SL2 also has the latest version of firmware (2.0).

Have any of you who have experienced the same problems received any explanation or solution to the problems?

I'm mailing mine off tomorrow and will update you once I get it back. I think my son just selected the report button smh .... hopefully the admins will see it was a accident. I'll update you. I was told to always use Nikon triggers.....I would like the technical reason were having this problem.

Link to post
Share on other sites

I’m experiencing the same freezing issue. Especially when viewing my photos. Some people have suggested it’s the SD card and the use of SD Formatter,  but I doubt it’s the card. 
when the camera freezes, the only option is to take the battery out.

this issue is truly tainting my experience with this amazing camera.

if firmware 3.0 fails to fix this, I will be putting my SL2 up for sale in favour of the Canon R5.

sad.

Link to post
Share on other sites

14 hours ago, dathinc said:

I'm mailing mine off tomorrow and will update you once I get it back. I think my son just selected the report button smh .... hopefully the admins will see it was a accident. I'll update you. I was told to always use Nikon triggers.....I would like the technical reason were having this problem.

Sorry to hear.. I have also been told that Nikon triggers where ok. I have heard that Leica will try to cooperate with Profoto to user their (Nikon) trigger because Leica have the same pin position as Nikon. 

1 hour ago, Eldad said:

I’m experiencing the same freezing issue. Especially when viewing my photos. Some people have suggested it’s the SD card and the use of SD Formatter,  but I doubt it’s the card. 
when the camera freezes, the only option is to take the battery out.

this issue is truly tainting my experience with this amazing camera.

if firmware 3.0 fails to fix this, I will be putting my SL2 up for sale in favour of the Canon R5.

sad.

I am sure the freezing has nothing to do with the card type, I have used several types of SD card, and also shoot tethered. same thing happens. My camera has the latest firmware 2.0.

I have been in contact with Leica here I Norway regarding these problems, and the sad news I got today is that I have to send my SL2 away to Leica in Germany for about 2-4 weeks.:-(

Maybe same thing for you guys?

Link to post
Share on other sites

On 17/11/2020 at 21:23, MoWa said:

Mi dispiace sentire .. Mi è stato anche detto che i trigger Nikon dove sono ok. Ho sentito che Leica proverà a collaborare con Profoto per utilizzare il loro trigger (Nikon) perché Leica ha la stessa posizione del perno di Nikon. 

Sono sicuro che il congelamento non ha nulla a che fare con il tipo di scheda, ho usato diversi tipi di scheda SD e ho anche sparato con il tethering. la stessa cosa accade. La mia fotocamera ha l'ultimo firmware 2.0.

Sono stato in contatto con Leica qui in Norvegia per quanto riguarda questi problemi e la triste notizia che ho ricevuto oggi è che devo inviare la mia SL2 a Leica in Germania per circa 2-4 settimane. 😞

Forse la stessa cosa per voi ragazzi?

My SL2 returned from Wetzlar with the shutter replaced because it was defective.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...