Jump to content

R4: Shutter Button Question & Disassembly Help

Recommended Posts

Posted (edited)

Advertisement (gone after registration)


Found this lovely forum while searching for info on a Leica R4 body described as having a "small problem". It belongs to a friend who gave me the option of buying it off him cheap, in its existing state, and trying to fix it and re-sell to a collector. I have been reading up on this and trying a few things and had a couple observations and questions that I am hoping the experts in this forum can help me with.

1) When I received it, I discovered that the shutter was not just firing with a delay, it was stuck and unusable. The film advance lever was stuck as well, indicating that the shutter probably froze midway through its cycle. The mirror was down, but the DOF preview lever was "loose". 

2) The battery LED would light, but there was no activity in the viewfinder, meaning no leds or anything at all. The camera seemed dead. New batteries did not change anything. 

3) After a fair bit of research, I found a thread (unsure where) that suggested "smacking" the camera bottom on a bed or similar soft surface. Somewhat frustrated, I did this, and it actually worked. The shutter finished its cycle and the film advance lever was working again, AND the viewfinder leds worked. I checked the meter and it seems fine too.

4) Advance the lever (no film), press the shutter, and same exact problem. But over many tests, I discovered that in B and 100, both mechanical modes, it would sometimes fire with a big delay, and other times get completely stuck. Smacking always releases the shutter.

5) Based on many threads in this forum, I believe this problem is typically related to dirty magnetic dampers. However, I find mixed information on how to reach the magnets. There was one thread that suggested it can be reached from the bottom plate and is easy, while another suggested it is behind the dof preview lever and complicated to reach, requiring some degree of disassembly. Unfortunately, I did not find information on WHAT disassembly is required.

6) In the meantime, I have also found that in all of the electronic modes (manual operation, but shutter speed electronic), the shutter button actually never fully depresses and therefore the shutter never fires at all. It feels like a half-press only in the electronic modes. In the mechanical mode, I can clearly see and feel the shutter go much deeper and actuate something. 

So my questions:

1) Is the shutter button behaving normally? Is there something else I am missing, as to why the shutter button won't fully depress in electronic mode, but works in mechanical mode?

2) If its the dampers, do I go from the bottom or the top? In any case, how do I get the top plate off and get any sort of serious disassembly done on this camera? I see one screw in the back, by the eye-piece control dial, and know that the top most screw on the mount holds the top plate down. But are those the only two screws? What else do I need to remove to get the top plate off? I am guessing the film rewind lever (on the left side, over the ISO dial) needs to come off, and the entire ISO dial mechanism probably needs to be lifted off too. What about on the right side, how do I get under the film advance lever and the shutter control?

3) Given the fact that the meter seems to work properly, I am guessing the electronics on this sample are okay (its a 156xxxx serial number). But just to be sure, if the electronics are toast, how do I know this? 

Any help/advice is appreciated, including an opinion on what price its worth buying at and then trying to fix it so I can keep it for myself, OR sell in working condition to a collector. A warning that it might be more valuable sold off to a collector in present condition than executing a botched repair and destroying its value completely is also taken in the right spirit. 



PS - I literally went thru every single page of the English forum looking for answers. Now after posting, I see threads related to this in the German forum! Is there a way for me to search on the other language forums? Any pointers appreciated, but please understand that I did a pretty comprehensive search and processed what information I already found before making this thread :)

Edited by karthikrr
Added a note regarding other language forums

Share this post

Link to post
Share on other sites

Maybe some pics will explain my question better?

Here, in the mechanical 1/100 setting, the shutter button depresses fully, and the shutter fires, though there is a varying amount of delay between the shutter press and the actual release. I believe this is a dirty magnet. Main thing to note is that the button depresses fully, it goes in all the way.



In this case, when using the electronic settings, the button does not go in all the way. It feels no different from the shutter being pushed when the film advance lever has not been cocked. The depth is significantly less, and it feels like the button is being stopped by something. I am not even sure if this is an actual problem, or if the shutter button is only meant to go in that much and then the electronics are meant to take over? Not sure how to diagnose this. Any help is appreciated.

Share this post

Link to post
Share on other sites

Hello karthikrr,

I just received my second hand R4 (so I am also new to this forum as a NEW Leica owner) and although externally it is in excellent condition, it seems to have the same problem you describe.

I was wondering if you found a solution to your issue and if so, if you wouldn't mind sharing it?


Edited by Lentakis

Share this post

Link to post
Share on other sites
On 9/2/2020 at 12:56 PM, Lentakis said:

Hello karthikrr,

I just received my second hand R4 (so I am also new to this forum as a NEW Leica owner) and although externally it is in excellent condition, it seems to have the same problem you describe.

I was wondering if you found a solution to your issue and if so, if you wouldn't mind sharing it?


Hi @Lentakis,

Nope, no solution yet. It seems this has been posted in the wrong forum, since I definitely saw some members talking about these issues in the past, but perhaps they have all moved on to other forums now :(

Anyway, for what its worth, perhaps you could describe your camera and problem in more detail and we could compare notes and see if there are any differences that will help us narrow down the issue. To start with, do you only have the stuck shutter problem, or do you also face the shutter button not depressing fully issue? Do you get the LED displays in the viewfinder and does metering work properly with the battery inserted? Lastly, when the shutter gets stuck, are you able to "knock" it loose by gently, well, knocking the camera on a pillow or some such thing?

I notice also that after I leave the camera alone for a day or two, I can always get 2-3 shutter releases before the shutter gets stuck again. This seems to imply to me that the sticky magnet issue is probably definitely one of my problems. But I am unable to address the fact that the shutter button does not want to depress fully in electronic modes. Since I have no working camera to compare with, I do not know if that is normal behaviour or not. If someone else reads this, it doesn't matter if you don't have an R4, could you check on your R camera and let me know how the shutter is supposed to behave?

Worst case, I am tempted to just sell it off as a defective body. I don't particularly feel inspired to try to open it up and poke around, I would rather make some money on it and buy something else that I can actually use!


Share this post

Link to post
Share on other sites

This is how the shutter button is supposed to behave.  Except for the delay stuff, and needing to give it a good smack.

Share this post

Link to post
Share on other sites


Guys, seems, you are mixing things up. There is no such thing like a "magnetic" damper. There is a mirror (shutter)  release magnet - behind the bottom plate - and there is the "mirror damper"- behind the aperture close down lever. When the magnet is sticky, there will be a problem with the electrical release, and when the "mirror damper" is not working correctly, there will be a shutter delay. All of this issues has often been discusted in this forum.  The release magnet is easy to reach, while cleaning the damper involves quite some dismantling.  

Sorry, haven't got time at the moment for more explanations. But again, there is lots of information about these matters in the forum.

Good luck,


Share this post

Link to post
Share on other sites

Advertisement (gone after registration)

Hi guys!

Thank you all for your input. 

I'm going to search through the forum at Torsten's suggestion to see if I can come up with more technical information. A schematic would have been great but the Leica Camera Repair Handbook by Tomosy costs $375 on Amazon.

I'll search for more information and keep you posted how it goes if/when I perform the surgery.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By boojum
      OK. I am starting from that point where we all start: total ignorance.  I receive my M8.2 today when FedEx delivers the little honey.  I would not normally run an eBay camera by a repair facility to check it but this is special.  And the seller has a 30 return window so I want a skilled tech to 1) look it over and evaluate its condition and, 2) do a CLA if needed.  I will bring it up with the new lens so that the tech can check how well the lens gets along with the rangefinder.
      I have read on this board and in this sub-forum that two esteemed Leica techs will not open an M8/M8.2 because of "grounding issues."  I have asked Wetzlar and finally Leica NJ about this.  They have danced all around this and are as good at equivocation as any politician or time-share salesman.  The best I could get out of them was that taking the camera to a non-Leica facility may void my warranty.  They have not said that any other tech is unable to inspect, evaluate or repair the M8/M8.2.
      So I am going to be a guinea pig on this.  I will take some pics when the camera arrives, of course, just to make sure it works.  Tomorrow I will drive up to PDX and drop it off with a repair facility I have had do work in the past.  They did the job right in the past on a Pentax digital.  I will see what happens.  I will know it worked before I brought it up.  I will have the digital proof.  I will also see what these fellows can do.  And the tech left me a message to the effect that the M9 was pretty much an M8/M8.2 inside but with a bigger sensor.  So we know he has opened up a few of them.
      As they used to say on TV, "Tape at Eleven."
    • By twcxz
      Hi everyone, 
      I'm currently working on a project to once and for all fix the analogue Leica CL's broken take up spool problem, by 3D printing them. 
      I've ran a roll through mine with version 2 of the spool and it works pretty good, but i'm working on version 3 which should be better still - I got the dimensions slightly wrong on this one - it's too short.
      How many of you CL owners would be interested in buying such an item? They'd cost around £20 and be sold through eBay all said and done, and I'd make a video showing how to take apart the CL and install them, as well as reassembly - International shipping would happen too through the eBay GSP as I'm UK based.
      The attached photo is version 2 and not by any means the final version as this is still in very early development, but the quality of the ones that go on sale will be much higher. This one was printed by a friend of mine, but I'm soon going to acquire my own printer and make them much better.
      I know also that this doesn't look anything like the original, but when I copied the original part dimension for dimension, curve by curve, it didn't work and suffered the same problems as the original.. immediately. Thus I simplified it and made it more "3D Printer friendly."

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By Effzeh
      Hallo zusammen,
      Bei meiner R4 muss ich den Spannhebel ziemlich weit drehen bis alles in der Kamera gespannt ist.
      Dann ist mir beim Einlegen eines Films aufgefallen, dass die Trommel auf der der Film läuft sich nach dem spannen wieder etwas zurück dreht und der Film nicht straff in der Kamera liegt.
      Auf den Negativstreifen sieht man, dass die Abstände zwischen den Bildern variieren. Überlappen von Bildern ist aber nicht der Fall.
      Jemand eine Idee ob und wie man das wieder korrekt eingestellt bekommt?
    • By Glere
      Hi! I have to disassembly the top plate of my Leica R7 for cleaning contacts (selector mode not recognize all the modes as it should). The ASA dial it's not a problem but the program dial and wind advance lever are quite difficult. 
      I've seen some Minolta's XD disassembly videos but all of them had an indentation for tools on the shutter dial.
      If anyone can show me or tell me how to put this 2 things apart..

      (pic found in the web, only for demostration)

      Thank you very much.

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By Glere
      Hi! I have a mint Leica R7, worked always without any issue but today I noticed when attaching the Summicron the "A" (full and centered) modes were no displaying when changing the modes (it displayed "m" and even the controls were manual), the same for the program mode (where it said time priority").

      is it possible that maybe the metal contact of the selector needs a clean or the electronic has a big problem? or what can it be?

      (the lens I'm using is a "R only" lens, I had the R4s2 before and it functioned in all modes with no problems)
  • Create New...