Jump to content
NilsJ

Shutter release and film advance lever stuck

Recommended Posts

Advertisement (gone after registration)

Now my dear Leicaflex SL will not fire off. The release button is stuck and I cannot advance the film either. I do not remember that I did something strange. The problem appeared at frame 28!!! Suggestions for solutions very much appreciated!!!

Share this post


Link to post
Share on other sites

No, it was a 36 exp roll. But after  developing the roll (just now), I see that the roll was not exposed. It apparently did not engage properly. That explains why it felt strange rewinding ... 

Share this post


Link to post
Share on other sites

Does the film now have stripped sprocket holes as a result of the misfeed?

 

Share this post


Link to post
Share on other sites

No, I cannot see anything different in the sprocket holes. The film was probably not fed at all. Thanks for asking me to clarify. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy