Jump to content
Sign in to follow this  
photoshack

Cannot subscribe to see what it can do (FOTOS Pro)

Recommended Posts

Advertisement (gone after registration)

Have ipad Pro and cannot after months of attempts to purchase; says "purchasing Lieca Fotos Pro failed - please try again later (OK)."  This behavior is on V 2.04 version.  I am pretty sure it worked at one point, but it never seems to log in and do whatever the hell it does to be active.

I confirm that it is a live working Apple ID that I always use when it it attempts to purchase.   I also tried to restore purchase (since I think it worked once when I first got the Q2) but it fails the same way.

Anyway I have no idea if the app is worth $50 since I can't get it to finish.   Maybe you guys can tell me if I am missing anything?

thanks

vin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy