Jump to content
Sign in to follow this  
joy yee

Can not use SL lens on the CL

Recommended Posts

Advertisement (gone after registration)

I have download the latest firmware of 3.1, but I still get error message for the SL lens. Saying I need to update firmware.

Share this post


Link to post
Share on other sites

If I am not mistaken, I think the lens needs to be upgraded from an SL body first time.. I could be wrong, never had this problem before myself.

Share this post


Link to post
Share on other sites

You are absolutely right, although Leica themselves thought there CL firmware would be able to work with SL lens, it turns out that only the SL body can do it. Thanks for you advise

Share this post


Link to post
Share on other sites

I'm not sure where you are based, but in the UK we have red dot cameras that would be happy to allow you to upgrade your lens on a used SL body or even the Leica store Mayfair would do it for you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...