Jump to content
Johnclare369

Cable shutter release not working

Recommended Posts

Advertisement (gone after registration)

I lost my cable release which I had used on my M10 since I got the body about two years ago. So I bought a new one (A Leica one) in the Leica Store in Mayfair, London. It worked for the first day, then stopped working. It's odd because you wouldn't think anything could go wrong with something so mechanical and simple. But it has. When I press the shutter release at the end of the cable, the prong at the other end does not stick out (the action what would normally trigger the shutter). I can't see anywhere to screw it tighter etc. 
 

All idea welcome as I can't easily get back to the store to return it. 

Share this post


Link to post
Share on other sites

Just return it. They will replace it without fuss. My cable release was bought for pennies in the early 1970s and works as well with my Leica M10-P as it did on my Nikon SLR years ago.

Share this post


Link to post
Share on other sites

The thumb plunger goes down all the way yet nothing pokes out the other end, it sounds impossible! Or is nothing moving and its a case of the cable release lock being 'on'? A good candidate for a Christmas Quiz either way.

Share this post


Link to post
Share on other sites
13 hours ago, Johnclare369 said:

All idea welcome as I can't easily get back to the store to return it. 

As Peter says - just post it back. Plenty on e-bay, just get correct threads. Nikon ones work fine.

Edited by pedaes

Share this post


Link to post
Share on other sites

Sounds like the plunger has become disconnected from the plunger somewhere inside the cable release.  I remember years ago I had a cable release that occasionally did the same thing because the screw collar that held the cable release to the outer sheathing had worked loose so the plunger just pushed the outer sheath with it and the prong didn't appear.  Half a minute's work putting things back in place and re-tightening the screw collar sorted things out so perhaps something similar has happened to yours.

Of course these days few things are made to be fixable so it might be a case of returning it to Leica Mayfair for a replacement or refund.

Pete.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ahl
      I am using an S1R as my backup to my SL2. I cannot get the official sl2 cable release therefore my question is : can I use the cable release from my S1R which has a thinner body with the SL2 with a simple adapter as they both have the same number of contacts. Using the phone app is not the right solution for me because of the small time delay trying to shoot at moving birds in a nest.
    • By amyinthecity
      Hi!  Newbie Leica owner here.  I've been using my Leica Q for a few months on the silent mode (no sound for anything) and suddenly, today, the shutter is making a fairly loud clicking sound when I shoot a picture.  I checked my "acoustic signal" settings and everything is set to "off."  I changed some settings and returned them to off (hoping it just needed a boost!) and that didn't work.  I then reset the camera and that didn't work, either!  The shutter makes a click no matter what.
       
      I'm worried I have broken my camera somehow -- and hope you all have some ideas for me.  Thanks so much!
       
      Amy
    • By echeveria
      Hi all,

      I'm a new Leica owner. Got an R6 off a local photographer who let me use it for a few weeks before purchase. Worked fine; price was right, so I paid him for it. I have put through maybe 5-6 rolls through it successfully over the course of my testing period and then shortly after purchase.
      Tried loading a fresh roll of film the other day. Put the leader in the spool, pressed the shutter button, but the mirror is not moving after I press on the button. The shutter button seems to press down fine, however. Since the mirror is not moving after I hit the shutter, I am not able to wind forward the film.
      I have tried:
      moving all parts individually: the mirror, film spool, winder, shutter, film release/double exposure button all move the way that they should. There are no snags or tension. The mirror in particular moves up and down smoothly and doesn't seem out of alignment. The winder and spool do not seem to be loose or have tension; they feel like they move fine. firing the camera with the back open/closed on different shutter speeds tried pressing shutter button/winding the lever at the same time, tried pressing the rewind button and winding the lever at the same time. Since the moving parts seem to be ok, it leads me to think maybe something needs an oiling? Or maybe a spring rusted or got stretched? Or something got unattached?
      I want to open the camera up and try and see what's going on when I fire the shutter. However I wanted to come here for some advice guidance first. There just doesn't seem to be much in the way of R6 troubleshooting online.
      One thing to add: I notice while switching between shutter speeds I do hear a mechanical buzz. Doesn't seem to be on every change of the shutter however.
      Any thoughts appreciated. Thanks!
    • By kentishrev
      I have a general question, that I guess will apply to CL, TL and others.  I know from experience on the CL that the mechanical shutter produces far better images than the elecronic shutter (there is a demonstrable banding issue indoors, and generally mechanical just 'looks' better).  This view seems to be supported by many other posts.  However, I'd simply welcome an explanation of 'why' this is the case.  In a digital camera, what advantage does the mechanical shutter provide?  I'm just intrigued.  Many thanks.
    • By Ildjarn
      First sample is at 1/125 ss. Notice the white stripe near the right edge. It looks pretty much the same at 1/250 and 1/500, however, at 1/60 it's gone. I haven't seen the results at 1/60, but that's what I've been told.
      Last sample is at 1/1000 and things are much worse there. 
      I am going to make more tests, but what do you think it can be? Shutter? A body was stored without lens attached to it and without front cap covering the mount, so shutter was basically uncovered. However, I couldn't find any obvious signs of damage on shutter.
      And if it's a shutter problem, repair would probably cost more then a camera itself, right?

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy