Jump to content
NickTheo

SL2 & LEICA FOTOS 2.0 - Has anyone gotten it to work?

Recommended Posts

Advertisement (gone after registration)

Hello - received my SL2 today and have been putting it through the paces...  

One of the things I was eager to see if they had improved at all is the new FOTOS app integration.  FOTOS 1.0 on the the Q2 and SL1 has been nothing short of awful so I had high hopes for this new iteration.  

So far with FOTOS 2.0 I have not even been able to complete a full connection between SL2 camera and iPhone 11 Pro running latest iOS 13 OS even once...  Sometimes it connects (but takes forever to do so) but only the live view functionality works but not the image download or review.  Most times it doesn't complete a connection at all, I join the camera wifi and then the wheel spins and spins and the blue light on the camera blinks and then nothing on the app happens. 

I have tried pairing and repairing the phone to camera several times, restarted the phone, restarted the camera, etc.   Has anyone gotten this thing to work?  Even when the camera says "App Connected" the app seems to spin it's wheel like it isn't working.

I have to say this is not a great look for a 6k camera that it doesn't work with the latest/greatest smartphone and their own app out of the box, especially when Leica is looking to charge for FOTOS PRO now.  Please help if anyone can.  Thanks.

Edited by NickTheo

Share this post


Link to post
Share on other sites

Update:  If you have even one .ARW file on the SD card it looks like it completely beats the camera connection to the app.  New SD card seems to have repaired this issue.  Heads up for those who encounter the same issue.  Also, as before, if you have a lot of files on the SD card it slows the app down drastically.

Share this post


Link to post
Share on other sites
  • Just out of curiosity does the GPS metadata sync ?   Now that it has been removed from the SL2  I was wondering whether this is functioning  as with the Q2 it was promised but never delivered ?

Share this post


Link to post
Share on other sites

Hi, 

I too am so disappointed with the functionality of the update.

i cannot understand why the app always reverts to the P exposure mode when you switch between Remote and the viewer modes. Generally I shoot in M and it’s unnecessarily annoying to have to re-select the exposure mode when switching functions of the app.

Also, how do you select the Pro version. I entered all the info, signed up for the subscription, selected Fotos Pro in settings but the app seems identical to the standard Fotos.

And another thing.......what’s the use of USB-c if LIS doesn’t see the SL2!

I love the menu system. I loved the SL menus but the SL2 menus are superb.

Let’s just hope these issues are just because it’s early days.

 

Grant

Share this post


Link to post
Share on other sites
vor 38 Minuten schrieb GHPhoto:

And another thing.......what’s the use of USB-c if LIS doesn’t see the SL2!

I've tried the SL2 connected to an iMac in the store (presentation day) via USB-C with Leica Image Shuttle and it worked flawlessly.

Share this post


Link to post
Share on other sites

Advertisement (gone after registration)

6 hours ago, GHPhoto said:

.

i cannot understand why the app always reverts to the P exposure mode when you switch between Remote and the viewer modes. Generally I shoot in M and it’s unnecessarily annoying to have to re-select the exposure mode when switching functions of the app.

That has been a characteristic of Fotos in earlier versions so it is a design decision.  I also think it is wrong, and should be pushed back against.  Fotos should bring the camera up in whatever state it was put in before the connection is made.  This is no more work than the present organization

present:  Connect;Send state mode P AF etc

should be:  Connect; Read state and display it.

and the second option would be a lot less annoying.

Share this post


Link to post
Share on other sites
7 hours ago, GHPhoto said:

<snip>.

Let’s just hope these issues are just because it’s early days.

 

Grant

It was early days a year ago. Go Live day is very late in the process.

Share this post


Link to post
Share on other sites

The Leica fotos blue tooth remote control/pics download worked on my SL2 w/o a glitch.

Share this post


Link to post
Share on other sites
16 minutes ago, sillbeers15 said:

The Leica fotos blue tooth remote control/pics download worked on my SL2 w/o a glitch.

On iOS or Android? No SL2 on the Android Leica FOTOS app that I downloaded yesterday.

Share this post


Link to post
Share on other sites
6 minutes ago, helged said:

On iOS or Android? No SL2 on the Android Leica FOTOS app that I downloaded yesterday.

I used the iPhone XS.

Share this post


Link to post
Share on other sites
1 hour ago, scott kirkpatrick said:

As far as I can tell PlayStore is still offering FOTOS 1.3 from October.  The 2.0 for Android has not appeared yet

I have just seen your message and found it's available for my phone (Android)

Maybe I'll be able to test after dinner..

Share this post


Link to post
Share on other sites

You're right.  I just got it as well.

Here's what is claimed:

Faster and more stable

stop and start remote video recording

redesigned experience for Android 10

support for SL2

Fotos Pro features.

Share this post


Link to post
Share on other sites

I have three Moto G phones (cheap, used in different parts of the world).  The Moto G Android 5 that I use at home doesn't even see Fotos.  The Moto G5 running Android 7 downloaded Fotos and it seems to work, although it still has the problem that a camera with over 1000 pictures in 4 folders confuses it.  It can't decide where to start bringing up icons.  My Moto G6 running Android 9 sees the new Fotos but can't download it.  I think there is some protection that is keeping it out.  

Sigh.  Open source phones.  I'll keep working on this.  I didn't find Fotos on iOS to be so tricky, of course. 

Share this post


Link to post
Share on other sites

I didn’t have any problem on iphone 11, ipad mini and ipad pro but I son’t see any added value except on ipad the link with Lightroom which works fine but is more a gadget.

Concerning the gps transmission of data, I see nothing. As I am still witing for my SL2, I hve made the tests with my CL.

Share this post


Link to post
Share on other sites

I read Jono's piece and how he had used the two card slots to capture images in both DNG and JPEGs. The DNG card is in the first position. I was able to connect to both an iPhone and iPad Pro, but no images would upload. When I took out the card with the DNG files and moved the JPEG card to the #1 position, the pictures loaded.

I suspect that, no matter how good the Fotos app is, 75 90 meg files are going to scare it half to death.

Once uploaded to my iPad, there was, in face, quite easy and fast LR integration. All in, pretty pleased with the way it is working, but note to all: big raw files will scare your Apple devices.

 

 

Edited by johnbuckley

Share this post


Link to post
Share on other sites
1 hour ago, marcolinger said:

Concerning the gps transmission of data, I see nothing. As I am still witing for my SL2, I hve made the tests with my CL.

GPS transmission occurs over blueTooth.  So it will happen on Q2 and SL2.

Share this post


Link to post
Share on other sites
6 hours ago, helged said:

On iOS or Android? No SL2 on the Android Leica FOTOS app that I downloaded yesterday.

It was an option when you select SL: SL or SL2

Share this post


Link to post
Share on other sites

Is anyone else having issues with LIS seeing the SL2?

I've gone the the usual procedures of uninstalling/reinstalling etc etc, w/- w/o SD card but LIS will not see the camera.

Any ideas, anyone?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy