Jump to content
Thomas Call

Failure to load firmware 3.1

Recommended Posts

Advertisement (gone after registration)

Hello, I feel a bit embarrassed and frustrated since I didn’t think this would be a problem. It’s hard to describe my difficulty but here it goes. I have repeatedly been unsuccessful in trying to update my Leica q with firmware 3.1. I’ve used three SD cards since reading some blogs this seemed to work. But, it hasn’t for me. What occurs is that while depressing the video button, then turning on the camera a window appears that appears to display the process starting, but then abruptly ceases, the screen goes blank and then the normal screen appears. For the life of me I can’t figure out what I’m doing wrong. Any ideas? Thank you 

Share this post


Link to post
Share on other sites

Had the same problem. I charged my battery to 100% and then it worked like a charm...

Share this post


Link to post
Share on other sites

Thank you, I’ll give it another go. I have charged my battery until the green light extinguishes but haven’t left it longer than that. 

Share this post


Link to post
Share on other sites

It's potentially dangerous to modify firmware with insufficient power. Hence the cut-off. Make sure your battery is fully charged before installing new firmware. 

Share this post


Link to post
Share on other sites

Tom, make sure you downloaded the right file and put it in the SD card root directory.

Share this post


Link to post
Share on other sites

Advertisement (gone after registration)

26 minutes ago, DQ03 said:

Tom, make sure you downloaded the right file and put it in the SD card root directory.

Root Directory means just drag the update file on top of the SD card.
Keep it simple, people.

 

Share this post


Link to post
Share on other sites

Thank you everyone that have tried to help and all of your suggestions/recommendations have been spot on, and I have followed them diligently, but alas the same issue vexes me. Today I went to a Leica dealer in Houston and asked their Leica guy, bought a new battery and SD card. I returned home, fully charged the battery, formatted the SD card, and embarked on a final attempt. The one difference I noted was when I moved the firmware download onto the SD card, at first it displayed with just “pdf’ as the label,  but changed to a doc with the upper corner folded as all my other trials have displayed too. I think my next step is to call the Leica center in New Jersey on Monday and go from there. But again, thank you all very much, in just perusing other posts I’ve already learned a great deal. 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Thomas Call said:

The one difference I noted was when I moved the firmware download onto the SD card, at first it displayed with just “pdf’ as the label,  but changed to a doc with the upper corner folded as all my other trials have displayed too.

 

The correct filename should end with .QUF

Did you perhaps download an instructions file by accident. A wrong file name would end in .PDF

 

Edited by pico

Share this post


Link to post
Share on other sites

Thank you Pico for that info. I had watched a YouTube video of the process and saw the file ended in quf, that peaked my curiosity since mine is a pdf and you’re right. When I open it, I’m like this sure looks like instructions. That’s it definitely. Wow, now I know why. But now my question would be how do I download the correct file, because I click on the file included in the firmware updates. It’s right there with the download file beside it. I have a MacBook Pro. There has to be something I’m missing. 

Share this post


Link to post
Share on other sites

OMG, I’m laughing because I totally missed it when I had been opening the firmware updates that the first one is THE FIRMWARE, I was downloading the English installation instructions. Oye, from ignorance there comes enlightenment, thanks to all of you. I successfully updated to 3.1 without turning my Leica q into an ornament. Thanks everyone and sorry it took so long for eyes to be open. Now to learn all about the new update. 

Share this post


Link to post
Share on other sites

Good for you with a happy ending! 👍

This is exactly what I suspected in the beginning: downloading the wrong file.

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...