Jump to content
antonioxrosa

M10 no Menu, No Play, No LV

Recommended Posts

Advertisement (gone after registration)

I have a Leica M10 since April last year combined with a summicron 35mm. Since last month I add a summarit 75mm 2.4 to the family. I am facing a couple of issues since then and I am not even sure if they are related. When I put on the 75mm for the first time the camera did't recognise the lens, than after moving in the menu to manual and then again to auto again the problem was solved. Latter I started to have a new issue. On a random basis  the buttons ( Menu, Play, Lv) does't work. Everything else work perfectly. It can be only a perception but I started to come to the conclusion  that after switching to the summarit 75mm the problem tend to appear. Today it happened again after having been using the 75mm lens for a while.  but this time on a permanent way. They do not worked at all.

After several attempts I realised that pressing the shutter at same time the buttons ( Menu, Play, Lv) worked. 

Then, after have redding about the internal battery, I kept the Leica switch on during one hour. The problem seems to have disappear. However   I am affraid that, if I switch again to the summarit 75mm that the problem will re-appear.

Anyone have experience this type of issues?... Any clues on the causes or on the solutions?

Cheers

Share this post


Link to post
Share on other sites

I never had this issue.

Though when you mentioned that the 75mm wasn‘t recognized properly there might be a weird interaction between lens detection and other camera functions. 

You should contact Customer Care and describe your problem. 

Share this post


Link to post
Share on other sites

Just a minor point: It is a good practice to shut off the camera before changing lenses. Best of luck.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy