Jump to content
Sign in to follow this  
bender73

Leica Q with SF 20 Flash

Recommended Posts

Advertisement (gone after registration)

Does anyone know why the Leica Q's LCD and EVF flickers constantly with a flash mounted in Manual mode?  Or AA?  I know it will not do TTL, but it seems like it is a "setting effect."  In Aperture Priority the screen is consistent.  If I try to move to 1/60 to 1/200 or such the screen blinks rhythmically and consistently.

Share this post


Link to post
Share on other sites

Hi there. Just bought a Q and found this post as I have the same problems with the SF24. I’ve had no answers to my post but I’m just going to get a newer Leica flash as the older ones might not be compatible. Robin.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy