Jump to content
AnDe

Leica T rattle

Recommended Posts

I just bought a second hand Leica T with a 18-56 lens. To my surprise there is a quite noticeable rattle between the house and the lens! 

When I compare this with my M8,  that holds its lens like a vice it doesn’t seem right? 

Should it rattle, or have some previous owner dropped it?

Thanks

A

Share this post


Link to post
Share on other sites

I have the same camera/lens combination and no rattle at all. But Fromm time to time I heard a few people mentioning that. I guess as long as the zoom works well and you have no problem with focus, etc, you shouldn’t pay too much attention. It really depends how bad it is!

Share this post


Link to post
Share on other sites

Just wondering, did the previous owner have that plastic T cover on it?  Impossible to put on or off, a total product flop.  

In any event, I tried one on my original T and it took a great amount of effort of bending and pushing the camera body to pry it off such the T  mount has a slightly 'looser-when-lens-attached kind of wobble' now, when the lens is attached. Absolutely no effect on image quality, or any other functions; everything works just as it should. 

 

Share this post


Link to post
Share on other sites

 I must do some more testing to see if it works properly. 

2/3 Swedish Leica resellers I have called told me I probably should have it looked on... :/

Dont know if the plastic cover have ever been used on it.

link to video, crank up the volume and you can hear it. https://youtu.be/Mt23wdxhEiw

Share this post


Link to post
Share on other sites

I have the TL2 - no lateral play in the mount at all. You sometimes get a stiff rotational play, not just with the TL2, but with the M bodies as well, depending on the lens, but it's usually very little and makes no obvious difference to the performance. 

If this is lateral play, then it shouldn't happen.

I've just checked my cameras: slight rotational play in CL+11-23, TL2+18 and SL+24-90 - least of all with the TL2+18mm lens. Not at all loose (no "rattle"). No lateral play at all.

Edited by LocalHero1953

Share this post


Link to post
Share on other sites
On 12/20/2018 at 10:25 PM, AnDe said:

I just bought a second hand Leica T with a 18-56 lens

It looks like a bayonet crash. I have neither a lens, nor a Chinese adapter with Nikon so do not depart, as on video. Backlash is completely absent.

Share this post


Link to post
Share on other sites
4 hours ago, al_exus said:

It looks like a bayonet crash. I have neither a lens, nor a Chinese adapter with Nikon so do not depart, as on video. Backlash is completely absent.

 This is a Leica lens and camera. Not sure I fully understand?

Share this post


Link to post
Share on other sites

In your video, the lens is very loose. it should not be. My lens does not move at all in the bayonet. Therefore, you have a problem in the bayonet

Edited by al_exus

Share this post


Link to post
Share on other sites
3 hours ago, al_exus said:

In your video, the lens is very loose. it should not be. My lens does not move at all in the bayonet. Therefore, you have a problem in the bayonet

Yes, I agree! 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×