Jump to content
Sign in to follow this  
Bro

Help my Leica CF D won't work!

Recommended Posts

Advertisement (gone after registration)

Hi Can anyone help please? 

I have recently bought a Leica D-Lux 109 with the CF D flash. I know the flash worked when I first opened the box but now I can't get it to work. In the menu the 'flash' option is greyed out. What am I doing wrong? 

 

Share this post


Link to post
Share on other sites

Take a look at page 179 in your handbook (I think it was 179).

There are several threads in this forum where users are experiencing similar "problems".

Share this post


Link to post
Share on other sites

I had the same   problem shortly after purchase after trying another flash which we were sure worked  we deduced it was the camera. I sent the

camera for repair after 3 attempts at a repair failed Leica arranged for a  new camera  .   

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By yaacovk
      Recently i buyed a flash with synch cable for my LEICA M4.
      After made one shot with the flash, i exidently pressed again on the shuter release without advancing to the next frame.
      I payed attention that the flash fired again.
      I want to mention that the shutter speed dial is in the flash mode
      Is it normal? or i have a problem?
      Thanks in advance.
      Yaacov.
    • By Think!
      I am looking for an off camera flash solution for my M10 (which would possibly also work for my M240)
      Is there any chance that my Nikon Flashes or Fuji Flashes (Nissin) would work? Otherwise I am looking for a good solution with a controller that may also manage more than one flash lights. Is there a Godox Solution that fits? Thank you for your advice
       
    • By rjsphd
      I own a m10 and a SL.  The latter is used with both SL and M lenses.
      I picked up a SF 60 used and have enjoyed it.  I would like to experience TTL with off-camera strobes, so I am considering the C1, but have questions:
      1) will it provide TTL sync for both cameras, even the SL+M lenses?
      2) Will the Nissin Air 10s controller do the job at half the price as the Leica C1?
      3) Which Nissin strobes have you triggered successfully with the C1 (as fill or secondary strobes)?
       
      Thanks in advance!
    • By Leica-STEVE
      I love my Lux5 but my Paul C. Buff trigger for top of my Leica wont fire studio strobes.  Anyone else know why or what setti9ng I need to do this?  Thanks in advance.  Major project coming up.  
    • By Corey
      I have a problem to get the SF 40 flash working on the CL camera.  All the settings are as per the manual and the flash setting is on TTL but the flash icon on the display is crossed out meaning the flash will not fire although the camera flash setting is on. I have tried it on manual and auto but it still does not work. The flash tests good when I press the test fire, I have also changed the batteries but have had no success.  I was hoping to get information from someone who may have experienced the same problem as I have.   
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy