Jump to content
Sign in to follow this  
Badluck

My first digital M + Luigi case.

Recommended Posts

Advertisement (gone after registration)

After shooting for a while with my m6, i finally bit the bullet and bought an M10. Bought a Luigi Case with my initials stamped on the strap. Cant say enough good things about the case and the service he offers.

 

 

Need to get another lens now. Thinking 28 Summicron.

 

Share this post


Link to post
Share on other sites

I have used Luigi cases on, lets see.. the R8, M6, M7, R9, DMR, S2. S 006, S007, M, M240, MP and M10...

He is by far and away, the leading craftsman and INNOVATOR out  there.

We designed the DMR and S cases together over the internet and they are ingeniously constructed and fit like the proverbial glove.

Furthermore, the cases have saved my cameras on multiple occasions in the arctic and antarctic for the elements and damage..

Albert 😃

Share this post


Link to post
Share on other sites

Love Luigi. Just got his Genius strap for the SL, which is fantastic, and I've had cases and straps for all my M cameras. Don't intend on getting a case for the SL, as it's already built super-robustly, and it's big enough... I don't need it to feel like a D800, more than it does.

But his work is incredible. Super high quality, and makes for a lovely feel in the hand. I love his cases.

Share this post


Link to post
Share on other sites
On 11/3/2018 at 4:40 PM, Badluck said:

Need to get another lens now. Thinking 28 Summicron.

Congratulations with your new camera! A 28mm Summicron seems to be a reasonable combination with your 50mm Summilux.

Share this post


Link to post
Share on other sites
1 hour ago, Alex U. said:

And what does JDW mean? On my Luigi I do not have these letters.

 

On 11/3/2018 at 4:40 PM, Badluck said:

Bought a Luigi Case with my initials stamped on the strap.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By Wolle
      Zum Verkauf steht meine neuwertige M10 in Silber
      Die Kamera ist in einwandfreiem Zustand. Da ich die Kamera tadellos Verkaufen möchte wurde sie von Leica in Wetzlar überprüft und der Sensor gereinigt.
      Die nötige Dokumentation von Leica liegt vor. Werksgarantie besteht noch bis Mai 2020.
      Interessenten melden sich am besten per Telefon unter: +49 171 32 123 23 oder Email: wolle@sundivecenter.com
      Dies ist ein Privatverkauf. Keine Rücknahme und Gewährleistung!
    • By antonioxrosa
      Hi,
      I have a Leica M10 with a sum micron 35mm since last year and I am wondering if I could use my Nikon 50mm ai 1.2 lens with it. I now that there are convertors but not sure how focusing will work with the rangefinder. Anyone has experience on this combo? 
       
    • By antonioxrosa
      I have a Leica M10 since April last year combined with a summicron 35mm. Since last month I add a summarit 75mm 2.4 to the family. I am facing a couple of issues since then and I am not even sure if they are related. When I put on the 75mm for the first time the camera did't recognise the lens, than after moving in the menu to manual and then again to auto again the problem was solved. Latter I started to have a new issue. On a random basis  the buttons ( Menu, Play, Lv) does't work. Everything else work perfectly. It can be only a perception but I started to come to the conclusion  that after switching to the summarit 75mm the problem tend to appear. Today it happened again after having been using the 75mm lens for a while.  but this time on a permanent way. They do not worked at all.
      After several attempts I realised that pressing the shutter at same time the buttons ( Menu, Play, Lv) worked. 
      Then, after have redding about the internal battery, I kept the Leica switch on during one hour. The problem seems to have disappear. However   I am affraid that, if I switch again to the summarit 75mm that the problem will re-appear.
      Anyone have experience this type of issues?... Any clues on the causes or on the solutions?
      Cheers
    • By ADrake0506
      Presently I own the Leica M262, Q and CL.  I've been wondering if I should pull the trigger and get an M10.  But I'm not sure if there will be a significant difference with image quality, when comparing it against the Q and/or CL.   I absolutely love the Q and haven't put much time into the CL - other than the lack of battery life I like.  When I look at photos from others, I have to remember they are posting their very best images and most include some post work.  
      I'm not a professional and I am new to the Leica family.
      Just hopeful to get a variety of feedback from those who might have different levels of experience and knowledge.
       
      Thank you
    • By indergaard
      I just finished my image-heavy review of the Leica M10 after about eight months of ownership. I hope you enjoy my review, which is a follow-up review of late Leica M240 review I did a couple of years ago. But most importantly I hope you enjoy the photographs.
      Check it out at: https://indergaard.net/2018/10/14/the-very-late-leica-m10-review/
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy