Jump to content
Infiniumguy

Fotos App experience

Recommended Posts

I downloaded the FOTOS app and started using it. 

 

A mixed bag so far. 

Positives:

Much quicker response compared to Q app. Almost zero lag when pressing the shutter button compared to 1.5 seconds with the Q app. 

Easy uploading of photos to iphone

Easier connections to wifi

Touch focus works well  

 

Negatives

Wifi quit unexpectedly 3 times within 15 minutes of usage. The last time totally locked up the Q and it would not turn on with the on-off switch. Removing and reinstalling the battery brought it back to normal operation.

Continuous drive mode never worked even trying different ways to select it. Meaning on the camera and or on the app.

I’ll add more if I learn anything new  

I did turn in the observations to the Leica Support link on the app  

 

Edited by Infiniumguy

Share this post


Link to post
Share on other sites

Looks much more user friendly than the previous app. I found it fast to connect with much less faffing about. The only thing I noticed was that when capturing photos the app didn’t show the correct f-stop on the screen (said it was 1.7 when it was 4)... anyone else seen that?

Share this post


Link to post
Share on other sites

I can’t connect. It keeps showing the message “check camera wifi is turned on and try again”. Even if the iphone is already connected to the camera via settings/wifi. The old app (Leica Q) works flawlessly. Bummer. 

Edited by leoberaldo

Share this post


Link to post
Share on other sites
5 hours ago, leoberaldo said:

I can’t connect. It keeps showing the message “check camera wifi is turned on and try again”. Even if the iphone is already connected to the camera via settings/wifi. The old app (Leica Q) works flawlessly. Bummer. 

Make sure you have the latest version of firmware installed.  I have not tried with the Q yet, but with an M10-P I had a very frustrating time till I thought of downloading and installing the new firmware.  With that done it was a very easy connection.  

I agree with all the positive comments Infiniumguy lists above and fortunately have not suffered any break in connection.  Will check out more features tonight.  However one disappointment was the very slow transfer of DNG files to the iPhone.  This may be a WiFi speed limitation, but disappointing nonetheless.  I may use the app as a remote device and to transfer a few files occasionally, but you can forget about transferring a large number of files!

 

Share this post


Link to post
Share on other sites

Folks,

Don't throw your Q app yet. It's so much better than the "FOTOS" app! I just compared the two and the number of additional manual controls such as third increments in shutter, aperture and ISO really help fine tune your initial exposure. Then, you have the crop lines for 35 and 50mm that are no longer available on the other app. The layout on the old app is not that convoluted and it just takes using to accustom yourself. I have not experienced a lot of trouble connecting the Q and phone device since  upgrading my iPhone to the 7plus. I must say that I was expecting a lot more from this new app. I just hope that Leica is not going to drop the Q app all together and continue to address some of the complaints about the connection drops!

Alton

Share this post


Link to post
Share on other sites
4 hours ago, vikasmg said:

Make sure you have the latest version of firmware installed.  I have not tried with the Q yet, but with an M10-P I had a very frustrating time till I thought of downloading and installing the new firmware.  With that done it was a very easy connection.  

Actually, both (phone and camera) are with he latest OS/firmware. I had the same problem using the beta versions of Fotos. I have just sent a user feedback to Leica via app. Let’s see if there is a bug. 

Share this post


Link to post
Share on other sites
5 hours ago, vikasmg said:

... and fortunately have not suffered any break in connection.  

I have to eat my words.  I'm experiencing the same dropping of connections with the Leica CL.  I need to switch the camera off and on and get back in WLAN before reconnecting.  Hardly a good situation if you're trying to take pictures remotely!

I've also reported the problem.

 

Edited by vikasmg

Share this post


Link to post
Share on other sites

I tried it.  No issues in about 5 minutes of use.  I do like that it will set up the connection to camera without me having to go into wifi settings and change networks.  I remember having to do that when using the Q app.  I'll keep both apps on my phone for now.   A remote shutter is sometimes a nice thing to have.

Share this post


Link to post
Share on other sites

The app automatically moved my focus mode from single point to face detection then left the camera in that mode when I shut off the app. 

While I’m disappointed so far, it appears that Leica has a bigger commitment to the FOTOS app. If that’s true, they’ll make improvements and it’ll get better, hopefully. Having an APP that serves their entire product line seems to me would pressure Wetzlar to get it right. 

I already prefer the FOTOS app versus the Q app, but FOTOS needs work to be solid. Leica needs to communicate their commitment and followup quickly with fixes so they don’t lose our interest and the app get a bad label that sticks. IMHO. 

I’m very appreciative of the easy way Leica included a link to their support area for documenting bugs or suggestions. 

Edited by Infiniumguy

Share this post


Link to post
Share on other sites
4 hours ago, Doudeke said:

I like the Q, a lot. I like my Iphone 8, a lot. But I don't connect them. I think that is because,

I don't like it that they becomes friends.  

It seems like they don't want to be friends anyhow (based on feedback about how reliable the wifi seems to be working).

Share this post


Link to post
Share on other sites

Doesn't work. Neither my iPhone 8 nor my Huawei P20, with the latest software will read the QR Code produced by my M10 with the latest firmware. I have wasted a lot of time this morning messing around with this. I also note that now the Leica M app, which I have only used a couple of times, most recently this morning, will not work either. Anyone hoping to use this to look at the photos on their M10-D should proceed with caution.

William

Share this post


Link to post
Share on other sites

I just cant get the camera to connect to the wifi at all so that I can get the QR code. There isnt a new firmware version for the Q is there? It looks like Leica need to invest quite heavily in the software department if they want to stay in competition because my experience so far with both the Q app and Fotos. It is such a shame because I thought Fotos would have resolved the old issues. I am staying away from the apps for now and for the forseeable future by the looks of it. Sorry for the pessimistic view but I think it is appalling that in this day and age Leica is useless of creating an app for cameras which cost £3.5k and above. 🤬🤬

 

PS: If anyone from Leica reads this then this is my recommendation: Sack the software developers and employ new ones. Hell, maybe get some on loan from Apple or even commission Apple to create an app.

Share this post


Link to post
Share on other sites
2 hours ago, likealot said:

I just cant get the camera to connect to the wifi at all so that I can get the QR code.

I don't remember for sure, but I think that if you connect the camera to an existing network there is no need for the QR code.  The QR code is used when the camera creates a network.

Menu ==> WLAN ==> WLAN Mode = Create WLAN.

To join an existing network set the WLAN mode to Join WLAN then enter the  Setup menu to set up your connection.  If you do that the Q app will just work assuming you connect the camera to the same network as your phone.   Alas, the FOTOS app doesn't seem to work in that mode.  It wants to connect to a camera that creates its own network.  At least I haven't found a way to tell the app to use the current network.

Share this post


Link to post
Share on other sites

I think the facility to use an external wifi network no longer exists with latest firmware - on the CL and SL this is true. Fotos is intended to connect to the camera via a new wifi network created by the camera itself.

I hope connecting to an external network is reinstated - it allowed you to access your photos via a web browser on a PC as well as a mobile device.

Share this post


Link to post
Share on other sites

Reinstating the facilty to connect to an existing WLAN would require a new firmware for the cameras. I am a little bit sceptical that they would do so after having cancelled this facility by the firmware to introduce the new app.

Share this post


Link to post
Share on other sites

 

4 hours ago, LocalHero1953 said:

I think the facility to use an external wifi network no longer exists with latest firmware - on the CL and SL this is true. Fotos is intended to connect to the camera via a new wifi network created by the camera itself.

I hope connecting to an external network is reinstated - it allowed you to access your photos via a web browser on a PC as well as a mobile device.

Mine is working with the Leica M app on this basis when I change from my home WiFi to the camera WiFi on my iPhone. Fotos, which is based upon scanning a QR Code, does not work at all for me. The whole thing sounds to me like a work in progress from Leica. Hopefully, they will get it right some day. I consider using apps and WiFi on smartphones to be a very flakey way of controlling cameras and downloading photos at this point in time. 

William

Share this post


Link to post
Share on other sites
13 hours ago, UliWer said:

Reinstating the facilty to connect to an existing WLAN would require a new firmware for the cameras. I am a little bit sceptical that they would do so after having cancelled this facility by the firmware to introduce the new app.

I don't understand.   The  Q with existing firmware connects to existing networks when the WLAN Mode is set to Join WLAN.  I believe it always has.  No new camera firmware required.   

Share this post


Link to post
Share on other sites

The Fotos App works for me (iPhone X) with both my TL2 and SL (don't have an M10, yet).

I can get a connection, and some functions - the App is, however, bug-ridden (flee infested?).  For example, if I set either camera to manual, the App switches over to P mode.  I loath software that makes those sorts of decisions for me.  It should be intuitive and relatively invisible.  I've also logged what I've found using the in-App contact.  No acknowledgement - there's only one thing worse than being a Beta tester without being asked, and that's when you take the time to provide the feed back, and get no thanks or acknowledgement.  A simple automatic reply would be a good start ...

Share this post


Link to post
Share on other sites
On 10/25/2018 at 8:01 PM, vikasmg said:

I have to eat my words.  I'm experiencing the same dropping of connections with the Leica CL.  I need to switch the camera off and on and get back in WLAN before reconnecting.  Hardly a good situation if you're trying to take pictures remotely!

I've also reported the problem.

 

I've just received a positive response from Leica.  I had reported that <<I’m loosing connection to the camera very frequently when using remote control to take picture.<< and just got this response:

>>

Dear Mr. Gore ,

Thanks for your feedback. 
We are intensively working on the analysis of possible connection issues.
You can expect improvements with updates in the new future.
Thanks for your understanding and providing the feedback, it helps a lot to improve Leica FOTOS.

Mit freundlichen Grüßen/Kind regards
Leica Camera AG
Customer Care / Leica FOTOS App Support
Am Leitz-Park 5 / 35578 Wetzlar/ Germany
+49 6441 2080 111 / app-support@leica-camera.com

<<

Sounds good.  Specially if "new future" is actually meant to be "near future" ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×