Jump to content

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By IntrepidTraveller6
      I have noticed in the two more recent outings with my M240 that i have a lot of dust on my sensor. The attached image is from the most recent outing to see the airshow. The circles are the spot removal I had to do to fix all the dust. As you can see it is substantial. Note that I was stopped down to F22 on a 90mm lens to get the depth needed for the air crafts and people to be in focus. So the dust was more apparent in the image. 
      I have cleaned the sensor with the blower multiple times. I have cleaned the sensor with swab and solution once between the outings. I switch lenses often enough for dust to get in, I expect it to happen. My problem is that after cleaning the sensor so thoroughly I should not have this much dust. It appears that using the blower provides minimal help and the swab basically nothing. 
      Has anyone experienced such persistent dust? Could this be some sort of corrosion on the sensor?
      I am debating sending it in for a repair and service to fix the issue. Has anyone used this service before and has an idea of cost, procedure, and effectiveness in getting a clean sensor back?

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
×
×
  • Create New...