Jump to content
Ric66

tl2 overexposure at 6400 iso only?

Recommended Posts

I am finding my TL2 is repeatedly overexposing, only at 6400 iso?

 

I have tried 2 lenses, all exposure modes, neutral contrast and variable contrast subjects and it’s repeatable. Firmware version is 1.4.

 

If I put the iso at any other setting I get a good exposure.

 

Can anyone else replicate this?

Edited by Ric66

Share this post


Link to post
Share on other sites

Hi!

i have had exactly the same behaviour with my TL2. Latest yesterday. My firmware is still 1.4, i think i must go up to 1.5 to see if it solves the problem. This overexposure is big, nearly two steps. I stumbled into it when i raised my ISO to 6400 from 3200. I took it back to 3200, problems solved, at least for the moment. Lens, Macro-Elmarit-TL. Do you still have this problem?

Share this post


Link to post
Share on other sites

Hi - I am afraid I no longer have the camera as I returned it and have switched to the CL. I did not want to wait to see if the next TL2  firmware release fixed the issue. Hopefully the recent firmware release will fix it. 

Share this post


Link to post
Share on other sites
Am 29.10.2018 um 09:37 schrieb Origokonst:

Hi!

i have had exactly the same behaviour with my TL2. Latest yesterday. My firmware is still 1.4, i think i must go up to 1.5 to see if it solves the problem. This overexposure is big, nearly two steps. I stumbled into it when i raised my ISO to 6400 from 3200. I took it back to 3200, problems solved, at least for the moment. Lens, Macro-Elmarit-TL. Do you still have this problem?

According to Leica the ISO6400 problem was addressed with FW 1.5.   

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...