Jump to content
jmlynek

Leica CM problem

Recommended Posts

Hello All,

 

It seems my lovely 10 year old Leica CM has come down with an issue. The aperture blades are frozen and do not change when the shutter is fired. I have re-booted the camera several times by removing the battery and it seems to affect the aperture blades but not consistently.

 

In effect, the camera is useless.

 

Does anyone know if Leica US or Germany will repair this or if there are any other options?

 

Thank you all.

Share this post


Link to post
Share on other sites

Hello All,

 

It seems my lovely 10 year old Leica CM has come down with an issue. The aperture blades are frozen and do not change when the shutter is fired. I have re-booted the camera several times by removing the battery and it seems to affect the aperture blades but not consistently.

 

In effect, the camera is useless.

 

Does anyone know if Leica US or Germany will repair this or if there are any other options?

 

Thank you all.

Leica should still be supporting the camera. Given the crazy prices asked for used ones it would be still be economically sensible to have it repaired.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×