Jump to content
  1. paddycook

    paddycook

  2. m_k_s

    m_k_s

  3. hkgmatt

    hkgmatt

  4. lx1713

    lx1713

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Coppereye1960
      After many years with Canon 5Ds I made the move to Leica M (240) in December 2016. I’ve chopped and changed the kit around so now I have :
      Leica M10 with 21mm/35mm f1.2 Voigtlander/50mm Summilux, 50mm collapsible Elmar (1954),90mm and 135mm - all Leica unless specified
      Leica Q my favourite camera EVER!

      Leica S-E (typ 006) with a 70mm f2.5, 120mm macro
      Ive even got and use a Sofort and a 1958 M3 single stroke ( used mainly with the Elmar)
      I’ve also had and sold a Monochrom ( CCD Sensor - imho the best rendering)
      I bought the S-E for studio work which due to illness I may not be able to do or at least very little.  I am considering using the S-E as a part exchange on a Leica SL and either a 24mm-90mm or a 75mm lens ( preferable ) and the M to SL converter.
      after a long preamble my question is if I was to trade for an SL should it be for the Mark I or the SL2.

      Obviously I may need to add cash but your thoughts would be helpful.
       
       I shoot 90% Portraits of which 80% are in the outside world almost street ( hence 75mm lens ).  The other 10% is my abstract art and I would use whatever I need  ( Start with  Q and M3 ) 
      thank you in advance
       
       
    • By Haribhau
      Question for SL users: I have the opportunity to trade my Panasonic S1 (that I se with SL glass) for a Leica SL. Of course I will spend some cash out of pocket.  I wanted to find out if anyone has experience with a similar shift and what factors I must keep in mind in going from an S1 to a relatively older (technology wise) camera body.  Also I mostly use this for shooting in a studio. 
      Pic (shot on the s1) for attention. 
      Greatly appreciate your thoughts.  
      Thank you.

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By 1234
      For unknown reason(s) an oddity is happening with indicated exposure times seen in viewfinder. After making an exposure, for the next two exposures there is no variation in indicated exposure time when panning about with camera. After the third exposure, the indication again varies properly as you pan about different scenes. Then repeats. As if there were an unwanted exposure lock mode in effect for 2nd and 3rd shot of a 3 shot sequence..
      Cannot find any obvious settings error likely to be the cause. The bracketing is set to 0.
      Tried to reload latest firmware but it "completes" in about two seconds so never happened. Does Leica determine the actual present checksum of the loaded firmware and decide that a reload is not necessary??
      What am I missing here? Thanks.
       
    • By Jacek.PL
      LEICA APO-MACRO-ELMARIT-TL 60 f/2.8, silver - (#4629438) is in great condition. I rate it cosmetically a (90%) but optically 100%. The focus is smooth, the autofocus and aperture function properly, and the glass is clean and clear with no haze, marks, or fungs, scratches. This lens includes a Leica lens pouch, a Leicalens hood , front & rear caps, and the original instructions & box(full factory set)
      I'm the owner from new. The lens was bought new at the Leica store.
      Payment: paypal or bank tansfer directly to my bank
      shipment: UPS with international tracking - 50EUR
       
      It's not only macro lens. It's excellent for portrait and mid telefoto (fov=90 mm with CL/TL camera)
       
      https://en.leica-camera.com/Photography/Leica-CL-TL2/Lenses-for-Leica-TL/Prime-Lenses/Leica-APO-Macro-Elmarit-TL-60mm-f2.8-ASPH.
    • By Shashinka
      Apologies if this topic is already in the system by me, but for some reason I could not find what I had posted.
      Anyway the issue I seem to be having since updating the firmware to v2.0 is that I have had a couple of crashes, or my camera locking up.  The on/off button does nothing, the OLED display and LCD are still on.  The only remedy to reset is to remove the battery.  So far its happened 3 times.  Anybody else experiencing this?
×
×
  • Create New...