Jump to content

Recommended Posts

Advertisement (gone after registration)

How often do folks typically need to wet clean their SL sensors?

Lately my SL is picking up quite a bit of dust, and I seem to need to clean about once every 8 weeks or so, and I am not in a particularly dusty environment when I change lenses.

Share this post


Link to post
Share on other sites

How often do you switch the camera off? SL has a built-in anti-dust feature, which is activated every time you turn the camera on. If you still see something in there, just flip the switch a few times. However, sometimes a stubborn speck just does not come out. In that case, read on.

 

The best way to clean any sensor is electrostatic. Use the tool called Arctic Butterfly. It is fast, clean, simple and super effective.

 

If your camera "is picking up quite a bit of dust", you must be doing something wrong like leaving the body without a lens, or a body cap, or changing lenses with the camera bayonet facing up.

Share this post


Link to post
Share on other sites

The first thing to do when dust is found on the sensor is to attempt to blow it off with a hand bulb blower. Remove the lens, hold the camera at an angle so that the sensor is facing downward, and then blow forcefully with the blower. If that does not work, try the Arctic Butterfly of a gel stick. When all else fails, a wet cleaning is in order. I have done this on both Sony and Leica cameras with perfect success every time.

Share this post


Link to post
Share on other sites

Thanks for the Arctic Butterfly solution.  The internal solution and bulb blower were not sufficient, but the  Arctic Butterfly works really well.

Again thanks for the suggestion!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By ashley12234
      Hey everyone, 
      I just got my m2 off ebay and had a look through the viewfinder only to see 2 main very noticeable spots. I attached a picture and the one on the lower left looks much dimmer and looks like a dot and a hair almost? It's kind of light greyish and I think it's a particle or dust but I'm not quite sure. However, in the middle the speck seems much darker (basically black) and more prominent. Could this be separation or is it another speckle of dust (imo it doesn't seem like one). If this has happened to you or you know what it is, any input on how to fix or your thoughts would would be greatly appreciated! 
      Also the shutter curtain on the front seems a little pushed forward and I can see the whole seam on it, is that normal? The curtain works 100% fine but I'm not sure if Im supposed to see the whole seam and overlap of the two curtains. On the back it stays slightly open by 1mm or so (didn't include a pic sorry)... should it cause a light leak? The camera was also recently CLA'd.
      Lastly, the viewfinder has some "gold specks" which I think is separation, but I hope i'm wrong.  
      Please help if you can clarify, recommend a fix, or give any thoughts on ^^. Overall the camera seems amazing and none of the things I mentioned has really bothered me, but if I can learn more about them then it would be great.
      Thanks in advance, 
      Ashley

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By 35mmview
      I'm thinking of going to the Holi festival in Delhi (the coloured dust thrown everywhere one) this year and obviously want to take my M240.
      I can throw on a 15mm lens which means I can pretty much point and shoot but what is the best way to protect the whole thing.
      Is it freezer bags and tape are are there custom options?
      Many thanks in advance, Dave.
    • By chris7opher
      Hi Everyone,
       
      I recently notice a small/short black line at the edge of images taken with M9P. I’m not sure what causes the fault. 
       
      Can anyone please have at these 2 images, and share your thoughts? Thank you.
       
      - Chris

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By inkbox
      My Leica D-Lux 3 that displays (1) a purple color shift for white colors in bright light; and (2) a photos show a green or yellow tint in low light.
      I have looked over the presets and defaults. I cannot find a switch that improves the display.
      I believe that the exposure sensor is damaged or malfunctioning.
      Otherwise, the camera is in good shape cosmetically and according to a review of the presets and default, working correctly.
      A used replacement on Ebay is about $150 to $200.
      My questions are:
      -1- Can I send my camera to the Leica repair for a new sensor for that amount of money? I know about the submission form that requires a maximum repair cost to be stated.
      -2- Is a Leica repaired camera totally checked out and then repaired so as to insure long lasting functioning?
      -3- Is it better to purchase another non-leica camera for $150 to $200 with improved specifications like increased megapixels?
      Thanks for reviewing my questions,
      Inkbox  
      PS I encountered an error when uploading files; although I deleted the upload files, I cannot upload replacements.
      I have used up all of my storage space and cannot locate a delete button in My Attachments. 
    • By goatsby
      I have a M9 that shows signs of slight corrosion and I’ve been holding off on sending it in as the corrosion doesn’t show up under normal shooting conditions. I heard on another forum that  that Leica is planning to discontinue replacing sensors for the M9, is this true? I know supplies must be limited but thought I had another year or so to get the sensor done. Has anyone else heard this? 
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy