Jump to content
Sign in to follow this  
Jodad

UK Leica engineers/CLA/Body/Lens work

Recommended Posts

Advertisement (gone after registration)

Hey all

 

Who do you guys recommend in England that is actually still in business?

I've got an iiig and need the speeds checked and the RF realigned (certainly vertically realigned) and also the "second image" in the RE is so ultra light/faded/barely visible too.

Also, evidently i need to get my lens lubed although i have a feeling that isn't too difficult following a couple of YouTube videos?

 

As always, thanks a lot!

Share this post


Link to post
Share on other sites

Thanks a noctilux. Their service seems pretty comprehensive and the price isn't bad. I'm guessing by your message that you haven't used them though.

Anyone have experience with cameraworks-uk?

Share this post


Link to post
Share on other sites

I would recommend Camera works. I was very pleased with the work they did for me.

Share this post


Link to post
Share on other sites

I had several M lenses and a Leica M6 serviced by Malcolm Taylor. Great chap to chat on the phone and he does excellent work! I hope he is well and still working.

 

Koray

Share this post


Link to post
Share on other sites

My 1937 Leica II was serviced by Newton Ellis in Liverpool many years ago... and I've just entrusted it to them again along with my 1937 9cm Elmar. Once I have those back, I plan on sending them my 5cm Summar, 13.5cm Hektor lenses and IIIf camera.

 

You can find them at http://www.newtonellis.com

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Similar Content

    • By TommyPlouffe
      I've recently acquired a very cheap 35mm Summicron v4 M in very good shape. However, the front and back elements are filled with dust (or fungus). The edges don't have any obvious fungus or anything. The are only specs here and there, but mostly in the center of the elements.
       
      What do you guys think? Is it dust or fungus?
       
      Here are some pictures:
       

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden! /applications/core/interface/imageproxy/imageproxy.php?img=https://image.ibb.co/mWgTto/02.jpg&key=dfa3577007ffc0f89917cf31bdb3e39330b67bfb31a2363fd728084b324bf0ed">
      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden! /applications/core/interface/imageproxy/imageproxy.php?img=https://image.ibb.co/kpqMDo/03.jpg&key=0af36ed154eb04363034ff1865ff57ec6c18e4885d36a42494ed70a9381bd94d">  
    • By rosshj
      Hello,
       
      I recently acquired two Leica M cameras from an auction. One is a M3, the other is a M2. They both are cosmetically in pretty nice condition, but the viewfinder on each seems to have an issue.
       
      The M3 seems like it may have some separation going on and the focusing patch seems pretty dim. The frame lines for the 90mm seems permanently visible as well.
       
       

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!  
      The M2 has what looks like dark spot inside the viewfinder—I'm not sure that this could be. When you looks through the viewfinder it still seems bright and the patch is clearly visible.
       

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!  
       
      I'm wondering if anyone can help identify the issue and also let me know if you think it can be fixed. Other than the viewfinders, the cameras seems in really great shape. Hopefully a CLA can clear things up, or a recement. 
       
      Thanks!
       
      Ross
    • By carl170
      Hi All.
       
      I have bought my first Leica M series, a rather battered M2. It has a few issues.
       
      The slower speeds don't seem quite right, the shutter button doesn't pop back up and the wind lever only springs back about 3/4 of the way. I don't think it will be difficult to sort.
       
      On a positive note, the self-timer works and the rangefinder is clean and clear and the focusing part of the rangefinder also seems fine,
       
      So I am looking for someone in the UK who can fix these issues. I am in the Newcastle Upon Tyne area, if there is anyone local, that would be even better.
       
      Also, is there anyone I should avoid? I have heard of people having to wait months to get their camera back and costs escalating.
       
      Lastly, does anyone care to share what the costs are likely to be? I have had my Rolleis serviced by an ex Rollei employee and he charges around £70 for a CLA, but I am guessing the cost of a Leica CLA will be more.
       
      Thanks for any replies.
       
      Regard
       
      Carl
    • By lecycliste
      Anyone have a ballpark estimate/experience with approximate CLA cost for hazy 180mm f/3.4 APO-Telyt?
       
      There are many of these at bargain prices on eBay with haze or fungus.
    • By Robclarke
      I have recently bought a Leica M3 and have run a couple of films through it and have thoroughly enjoyed using it. I have owned an M6ttl for a number of years.
       
      As far as I can tell it all works great but I am not sure the film advance is as smooth as I have read about (but this could be a myth). Also there is a bit of dust or something in the viewfinder which is not really a problem in use. I would quite like to get it CLA'd just to know it is working as well as it can.
       
      I was just wondering what the general opinion of getting a cla on a camera that is working ok, is it completely unnecessary?
       
      I was thinking of using Aperture in London as I can get to them easily have used them in the past for Hasselblad repairs.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy