Jump to content

Old Leica Collapsible Lens with M10


Recommended Posts

Advertisement (gone after registration)

Dear Senior members,

 

I just received my m10 camera early October.

Besides using the modern Leica lens, I do like the compactness of the old collapsible Leica lens of the 1950s.

I have the old Leica ELMOM 50 / 2.8 and SOONC 35 / 3.5, both are in collapsible version.

 

The m10 instruction booklet advises not to collapse the lens whilst mounted on the camera, as it risk damaging the camera and lens.

Is my understanding correct?

 

Thank you.

 

Benedict

Link to post
Share on other sites

Yes... not to collapse old lenses is a general advice which is better to follow, even if the effective risk of damage in some cases is not so significant : the only really comfortable to collapse are the last Elmar M 50 f 2,8 and the Macro Elmar M 90 f4.

 

Btw... why do you mention the SOONC ? It's a Summaron 35mm f3,5... which is NOT a collapsible lens...

 (it can be "goggled", which is a configuration that works also on all new digital M bodies)

Edited by luigi bertolotti
Link to post
Share on other sites

Yes... not to collapse old lenses is a general advice which is better to follow, even if the effective risk of damage in some cases is not so significant : the only really comfortable to collapse are the last Elmar M 50 f 2,8 and the Macro Elmar M 90 f4.

 

Btw... why do you mention the SOONC ? It's a Summaron 35mm f3,5... which is NOT a collapsible lens...

 (it can be "goggled", which is a configuration that works also on all new digital M bodies)

Thanks for your good advice.

 

Yes, I am mistaken, the SOONC Summaron 35mm 3.5 is rigid type.  I was thinking of Voigtlander Heliar 50mm 3.5 lens which is collapsible.

 

Cheers!

Link to post
Share on other sites

Collapse the 50 in your hand while not on the camera.

 

Does the barrel protrude past the mount on the rear of the lens?

 

That should answer your question.

I believe there was a 90 or 135mm collapsible that could damage am M digital but that was the only one.

Link to post
Share on other sites
Collapse the 50 in your hand while not on the camera.

Does the barrel protrude past the mount on the rear of the lens?

That should answer your question.

I believe there was a 90 or 135mm collapsible that could damage am M digital but that was the only one.[/quote

 

The voigtlander Heliar 50 3.5 has barrel protrude past the rear mount.

The Elmar dont protrude.

So i now can use your recommended method of checking.

 

Thanks for sharing your experience.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By clngood
      Hi guys, so I had my "reporter edition" of M10-P sent in, which had freezing issue, and Leica replaced the old CMOS with a whole new one. So far, no freezing, however, I run into 2 new "issues" if they really are.
       
      1st one: Sometimes when I press the "Play" button to view the photos, a brief "loading" appears on the screen for like less than 1 second. I didn't do that right after pressing the shutter, even when I was in the menu screen, and that happened, but not very often.
       
      2nd one: Sometimes when I press buttons (like Play or Menu), and there is no response, so I had to press them again, and this is not very often either.
       
      I don't remember that I ever had those 2 issues before I sent my M10-P in. I wonder if it has something to do with the very low battery? Have you guys encountered same things on your M10 or M10-P? Are they really issues?
    • By Rick in CO
      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By xme53
      My Tele Elmarit M 90 shows these marks when inspecting under a certain angle. It looks like dried water behind the front-element of the lens. It does not show in photos but still it concerns me. Is this serviceable? Have you ever seen something like this? 

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By Linus458
      I found this Carl Zeiss Jena lens for Leica SM (M39) at a flea market. This is what I could find about it:
      The Herar should be cheaper opportunity to the Carl Zeiss Biogon. It was originally produced for the Contax mount. The lens was produced around 500-1000 times. The one i found appears to be a prototype/sample for the Leica screw mount M39. It has a connection for the range finder and the aperture can be controlled with the front ring of the lens. It was produced before 1939. 
      I hope I got everything right.
      My two questions:
      Are the infos are all right (age, Version etc.)
      and since inform own a Leica with drew Mount I want to sell it. What is the right price? (I only found two offers online both around 3000usd, is it really worth that much?) 
      I also read that one was sold at a Auction at Christies in 1992. 
      I’m very thankful for any held or answer ✌🏻

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By clngood
      Dear all,
       
      I bought the "reporter edition" of M10-P about 5 months ago. And it constantly has freezing issue. For the past few weeks, it's just been way too often, like 1 out 2 days it would freeze. I always turn the EV on when I'm shooting, and before it's about to freeze, the EV looks like it's having dropped frames, pretty lagging and then it would freeze, so I have to take the battery out and restart the camera. And many times it just freezes after I turn the camera on, I don't even get to press the shutter.
       
      Yesterday, I went out shooting and it froze again, but this time, after I restarted the camera like I always did, I found that the screen got a dark horizontal line on the very top of it (please view the photo I uploaded). I checked the photos, it's usually without the line on them, unless the ISO is 4000 or higher, then I got part of the line (or banding?) on the left side.
       
      Is this normal? Should I send the camera in for a replacement of the CMOS or something?
       

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
×
×
  • Create New...