Jump to content

Leica lens does not work with Leica body but works with Canon w Adapter

Recommended Posts

Advertisement (gone after registration)

Dear All,

I received two Leica R Lenses today - Leica R 50/2 ROM and 80-200/4 ROM. I tried them with my old Leica R4 and R3 but when I click the shutter, the aperture looks like got stock - looks dark while looking through camera's view finder , it happened with both the R4 and R3 bodies and both the lenses have same problem.


But, I put Leitax mount on each of the lenses and use with my Canon body, they work without any problem. 


A friend of mine thought the ROM version lenses have this issue with older camera but I noticed it is not the case because I used the ROM version of my Leica R 35/2 lens with the old bodies as above and it works fine.


I am confused now.


Can somebody tell me what the problem could be?


Thanking you in advance. 

Link to post
Share on other sites

Do they work as normal (not with the Leitax mounts attached) on any other R bodies?

My fist thought was the aperture mechanism tired, or sticking? Changing the mount to Leitax may be allowing the mechanism to free up?


I tried them with my R4 and R3, and they give the problem with both the bodies as above. I do not have other bodies at this moment.

Link to post
Share on other sites

Advertisement (gone after registration)

Many thanks friends. The lenses were brought to repair but the expert who repairs says they are 100% ok , it is not the lenses but the camera has the problem -


both lenses have been checked and 100% OK. The problem often appears when the pistons that damp the mirror movement in the R cameras need cleaning. Your 35 mm runs a tiny bit lighter, so the problem isn't appearing with this lens-camera combo. Also depends on the chosen aperture

Link to post
Share on other sites

I had this problem with my Canon 5DSR. When I use my Summicron-R 50mm with no cams, it works on all of my Canon cameras without any problems.  But when I use an Elmarit-R 28mm F/2.8, it works on the older Canon DSLR's, but the mirror hangs and I get an error on the screen.  Sometimes, I just get the error before I even try to take a photo and it's only the Canon 5DSR, not a 6D or other Canon or Sony cameras.


After trying to figure out what could be hanging (I checked the 3 cams on this lens), and I discovered that there is a ring around the interior glass.  If you unscrew that ring, it comes right out and it worked 100% on my 5DSR and all of the other Canon's as well.


Last week I had the ring on and didn't know it, but when I tried to take some photos with the Canon 5DSR, I immediately got an error as soon as I turned on the power.  I didn't see that it was the ring because it's black and blends into the rest of the internal structure of the lens.  However, as soon as I discovered that it was there and I unscrewed the ring, the camera took photos fine w/o the mirror hanging up and w/o the errors.


Something to think about.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...