Jump to content
MichaelU

Firmware 1.6 available

Recommended Posts

Advertisement (gone after registration)

Installed the new FW this morning but it took considerably longer than the indicated 90 seconds. I only have the 23mm TL lens.

 

Hope to try the camera with a SKINK pinhole lens later today. 

 

dunk

Share this post


Link to post
Share on other sites

You cannot disable exposure simulation. I was hoping that they would have allowed for an image boost while in M mode with flash but it is the same old story.  You only get a image boost while it is focusing.  

Share this post


Link to post
Share on other sites

Has anyone else noticed an increase in EVF/screen lag time after installing firmware 1.6?  I now consistently have a 2.5-3 second gap after making an exposure (in single mode) during which the EVF/screen remains frozen on the previous exposure (precluding accurate reframing or refocusing).  My T has never been super fast in this domain, but my sense is I am worse off after this firmware update, which aside from the app functionality, contributes nothing to my shooting experience, as I use only M lenses with the adapter.  Just curious if others have noticed this or have any advice for mitigating it.

Share this post


Link to post
Share on other sites

Has anyone else noticed an increase in EVF/screen lag time after installing firmware 1.6?  I now consistently have a 2.5-3 second gap after making an exposure (in single mode) during which the EVF/screen remains frozen on the previous exposure (precluding accurate reframing or refocusing).  My T has never been super fast in this domain, but my sense is I am worse off after this firmware update, which aside from the app functionality, contributes nothing to my shooting experience, as I use only M lenses with the adapter.  Just curious if others have noticed this or have any advice for mitigating it.

 

 

What's your SD card make/brand and specification? 

 

dunk

Edited by dkCambridgeshire

Share this post


Link to post
Share on other sites

What's your SD card make/brand and specification? 

 

dunk

 

A fair question.  I have an SDHC I SanDisk Extreme Pro that writes @ 95 Mb/s.   

For what it's worth, I notice no difference between writing to the card or to the camera's internal memory.  Nor does there appear to be a difference between writing DNG+JPG superfine at highest resolution and JPG only at the lowest resolution.

Edited by nocturnal1

Share this post


Link to post
Share on other sites

Advertisement (gone after registration)

There is definitely a problem here with 1.6 when the camera is in manual focus mode. I tried the TL-35 lens in manual focus mode with a Sandisk Extreme Pro card and it is SLOW to write and the LCD freezes up during the write. Depressing the shutter halfway does nothing to refresh the LCD. You can continue to take shots - but you can't see what you are aiming at.

 

I know this was a problem before with M glass, but I don't recall having a problem with the T lenses in Manual mode before.

 

Leica - we need a fix please ASAP.

Share this post


Link to post
Share on other sites

There is definitely a problem here with 1.6 when the camera is in manual focus mode. I tried the TL-35 lens in manual focus mode with a Sandisk Extreme Pro card and it is SLOW to write and the LCD freezes up during the write. Depressing the shutter halfway does nothing to refresh the LCD. You can continue to take shots - but you can't see what you are aiming at.

I know this was a problem before with M glass, but I don't recall having a problem with the T lenses in Manual mode before.

Leica - we need a fix please ASAP.

It was also a problem with T lenses in manual focus mode.

So it is all manual focus.

Share this post


Link to post
Share on other sites

I haven't upgraded  to the new firmware yet.  This past weekend I tried a 90-280 SL lens on the T and it appeared to have the OIS functioning.  The sales rep and I both thought it looked smoother in the viewfinder.  The pictures though looked slightly blurred,  compared to the 55-135 T lens the images were less sharp.   Has anyone tried the SL lenses on the T?  What kind of results did you get? 

 

I did, in fact im using the SL 24-90 as my normal zoom lens when i go out to shoot some pictures. Sold my 18-56. the IQ is way better with the 24-90 compared to the 18-56

Share this post


Link to post
Share on other sites
Guest VVJ

I did, in fact im using the SL 24-90 as my normal zoom lens when i go out to shoot some pictures. Sold my 18-56. the IQ is way better with the 24-90 compared to the 18-56

 

I tried the 24-90 on the T today.  It was actually more balanced than I thought it would be...

 

I did find it a lot easier to lock focus with the T lenses than with the SL 24-90.

 

Is that also your experience?

Share this post


Link to post
Share on other sites

New firmware update certainly seems to have cured the freezing of the camera when using the 60mm 2.8

Share this post


Link to post
Share on other sites
Guest VVJ

Firmware 1.6.1 is available http://leicarumors.com/2017/01/12/firmware-updates-for-leica-t-1-6-1-and-leica-tl-2-11-released.aspx/

 

I wonder what us T users are missing from the TL exclusive firmware?

 

I am intrigued by that as well.  LR kind of combined 1.6 and 1.6.1.  1.6.1 only seems to solve the issues of the camera with the 60mm (which I don't own).  The performance improvements were already provided with 1.6.

 

I just upgraded but if you don't own the 60mm there is probably really no reason whatsoever to upgrade.

Share this post


Link to post
Share on other sites

Leica TL has firmware 2.11 now.

Does anyone know if  this firmware also works for leica T?

Share this post


Link to post
Share on other sites

Leica TL has firmware 2.11 now.

Does anyone know if  this firmware also works for leica T?

There's a new version for the T as well; they call it Version 1.61

Share this post


Link to post
Share on other sites
Guest VVJ

There's a new version for the T as well; they call it Version 1.61

 

Understood.  The question is: if the Leica T and TL are identical cameras (except for the internal memory) why are there two different versions of the firmware?

Share this post


Link to post
Share on other sites

Both 1.61 for T, and 2.11 for TL, firmwares are for 60 mm, f/2.8.

My original question was if we can use the TL firmware on T camera?

I asked Leica in NJ, but haven't had any response yet!

As Joris mentioned, both cameras are the same, except for the interior memory. Therefore, my guess is there should not be a problem!

If TL firmware is giving more features or better functions than the T firmware; then, could we use it?...

Share this post


Link to post
Share on other sites

Excellent point Louis. I attempted to install the TL firmware on my T and no go. This X-factor is the only thing that might cause me to consider the upgrade. If the advanced firmware created for TL only can get more out of essentially the same hardware, I'm interested. It would be good business on Leica's part.

Share this post


Link to post
Share on other sites

They're two different camera models thus must have two different firmware requirements and must have built-in safeguards to prevent use of the other's firmware upgrades. If the two cameras had firmware compatibility there would be no need for  Leica to write / issue separate firmware upgrades. 

 

dunk

Share this post


Link to post
Share on other sites

The is the response I received from Leica in regard to firmware between TL and T:

 

"The firmware files are not interchangeable but rest assured that improvements for the TL are integrated into new firmware for the T as well."

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...