Jump to content
Sign in to follow this  
Future2001

Had to drop my baby off at Leica NJ

Recommended Posts

Advertisement (gone after registration)

My Leica developed a  misalignment during my trip to Chicago last week. It was prominent at infinity. Shm it sucked so I emailed Leica repair got a out of the office message Then on Monday Bill Weier emailed me back and told me to bring it in they can fix it in an hour or so if I brought it in early in the morning while I waited. Cool my Leica also had some play in the screen and it's been like that since the last fix but I didn't mention it. Went there in the morning and the place seemed busy. Bill came right out and was a great guy. I had brought my Zeiss lens with me so he took the set to the back. A few minutes later he said,"Hey your rangefinder is out of alignment but so is your lens. It's back focusing. We can fix the rangefinder but not the lens"  

 

Oh NO! But hey I had a warranty with Zeiss so off that goes tomorrow. Then Bill says," Hey did you know about this?" as he pushes on the screen with his finger. I shake my head yes. He says," Hey when its this bad that means the seals failed completely and they need to fix it because dust is going into the camera." 

 

Well last time it came back cleaned with no dust behind the lcd but then developed the play. So I say ok well let's get that fixed you convinced me. He said it should take 3 weeks. 

 

Long story short... my camera is gone long gone lol. I drove all the way there because last time shipping something expensive ups lost it and that was a fiasco. 

 

Sorry for boring you guys. Oh ps. There weren't any free magazines...... 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Glere
      Hi! I have a mint Leica R7, worked always without any issue but today I noticed when attaching the Summicron the "A" (full and centered) modes were no displaying when changing the modes (it displayed "m" and even the controls were manual), the same for the program mode (where it said time priority").

      is it possible that maybe the metal contact of the selector needs a clean or the electronic has a big problem? or what can it be?

      (the lens I'm using is a "R only" lens, I had the R4s2 before and it functioned in all modes with no problems)
      Thanks
    • By simonCL
      Hi all! 
       
      Apologies in advance for the length of this post! 
       
      I was wondering if you all are able to give me some advice or words of wisdom on whether I should get a Rangefinder Leica. 
       
      At the moment I’m currently using and enjoying my Leica CL & 23mm f2 Summicron. Purchased in Oct 2018. I absolutely love shooting with the CL and for me it was the upgrade I was always wanting. I even adapt some rare and unique vintage m42 lenses to it and get some amazing results. 
       
      Now I’m no professional photographer, just a hobby shooter but the Leica CL I have had really developed my love and passion for photography. At the time of purchasing the CL I was using a Nikon D7500 which I still have (but never use) so for me, at the time the CL was the next step up, and I never thought of going for a rangefinder (couldn’t afford the m10 and lenses anyway lol). 
       
      But now having visited the Sydney Leica store on many occasions to try out the M10 and the rangefinder systems, I’ve grown more interest for a Rangefinder. 
       
      I’m interested in the M240, maybe the M262. I like the appeal of a brassing body though (a bit of individualism I’d say). But honestly I’m not sure which system to go for (and I don’t have the money for a new M10). 
       
      What are the PROS and CONS for each system? What makes you want to stay with that system? (if you have one) what would you recommend I do or go for? 
       
      Now I’ve done heaps of research and reviews on both systems but I really want to hear from everyday people who use them. 
       
      Thanks! 
    • By clngood
      Hi guys,
       
      Recently I bought a new Leica M-E (typ240)and it's basically an M240. And a few days ago, when I tried to do some continuous shootings (the shutter not being hold all the way, but rapidly pressing the shutter when the screen was black and the red light was flashing), I found out that among a series of photos I shot at the same scene, there was one that was a bit underexposured (you can obviously tell the difference between that one and others), and this kind of issue happened a few times when they were all ISO, Shutter speed Auto, and the aperture was fixed.
       
      After noticing that, I started to do some continuous shootings of over 10 photos to testify it, and there was even one black frame, but others were fine, and judging from the exposure parameter, there was absolutely no possibility that one could be a black frame. When I got back home, I did a few more rounds of continuous shootings, and I even tried to make ISO, Shutter speed and aperture all fixed, and Underexposure issue happened again.
       
      The firmware is the latest one (2.0.6.0). So I'm wondering if you guys have had the same issue? Is it normal? And how to deal with it?
       
    • By thgbrian
      Hello Everyone, 
      My M240's Shutter Speed dial has become misaligned. When set to A the camera reads 1/30th.
       
      Does anyone know how to fix this or do I have to send it into Leica? If so, how much would something like this cost to get fixed?
       
      Thanks!
    • By inkbox
      My Leica D-Lux 3 that displays (1) a purple color shift for white colors in bright light; and (2) a photos show a green or yellow tint in low light.
      I have looked over the presets and defaults. I cannot find a switch that improves the display.
      I believe that the exposure sensor is damaged or malfunctioning.
      Otherwise, the camera is in good shape cosmetically and according to a review of the presets and default, working correctly.
      A used replacement on Ebay is about $150 to $200.
      My questions are:
      -1- Can I send my camera to the Leica repair for a new sensor for that amount of money? I know about the submission form that requires a maximum repair cost to be stated.
      -2- Is a Leica repaired camera totally checked out and then repaired so as to insure long lasting functioning?
      -3- Is it better to purchase another non-leica camera for $150 to $200 with improved specifications like increased megapixels?
      Thanks for reviewing my questions,
      Inkbox  
      PS I encountered an error when uploading files; although I deleted the upload files, I cannot upload replacements.
      I have used up all of my storage space and cannot locate a delete button in My Attachments. 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy