Jump to content
  1. Jan Böttcher

    Jan Böttcher

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By maldo127
      Hello!
      I bought my M7 last year and it started giving me issues when in aperture priority. I had put 50ish rolls through it before the issue started. When it is in aperture priority mode it does not give me the a shutter speed reading, it gives me the the the triangle and circles. When this occurs, two possible things can happen when I click the shutter button. The first thing that happens is no photo is taken; the shutter button does nothing. The second thing that occurs is the shutter goes off but it remains open. It stays open even if it turn off the camera. The shutter only releases when I move the shutter speed dial to to 60 or 125 (the shutter speeds that fire without a battery). 
      Things I have tried. New batteries and changing the ISO speed selector from manual to DX.
      My questions: Does anyone else have experience with these issues? If you had a similar issue and sent it to Leica, how much did it cost?
      Thank you so much for your help, if this has already been answered a link to the topic would be appreciated. 
    • By Sung Kim
      Hi there guys
      I was using kentmere 400 and when I was rewinding the film somehow the it ripped out
      So decided pull it by myself on changing bag
      Tried with the finger and no success.
      Tried with tweezers. Hooked in something and pull it out.
      It was spring  

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden! Like pictured
       

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden! coming out form the take up spool area
       
      For now, all functions works. I can cock the shuuter and fire it, open the bottom cover and film count reset, film advance and rewind
      Any one have idea what this piece is for?
    • By mr_bom
      Hello members,
      I’m curious about the new Summaron-M 28mm 5.6
      It’s Focusing tab stuck at the framelines selector and cannot go to close focus. 
      Does this occurs to every M-body that has rectangle framelines selector? 😅
      Thanks in advance
      Thatchapon

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By justkane
      Hello, Newbie post here!
      I purchased a really beautiful M7 back in February and initially sent it in to service for a shutter curtain and rangefinder calibration after finding flaws in the first few rolls back from the lab. The work was done in March and all seemed well. Now there's a new super weird and annoying problem and I'm curious if any technicians and fellow M7 owners have experienced this.
      When powering on, the first shot seems to lock up the shutter halfway when using electronic speeds snd auto mode. It sounds like the soft click of the front curtain opening for a long exposure, but never completes the exposure with that louder clack. I am able to complete the exposure jam by switching to one of the mechanical speeds and press the release. It then clacks and allows me to advance again.
      Here's the weird part: as long as I keep the power switch on, I can now capture normal electronic shutter speeds without issue. Once I turn it off and then on again, that first powered frame will lock up. I've changed the batteries (using Duracell DL 1/3N CR1/3N 3v Lithiums), the battery gate and contacts appear clean, the meter appears to be displaying and working normally. Literally just the shutter lock up on the first powered frame is the issue. 
      The service technician is a bit stumped by this issue and has suggested that I keep the power switch on and only advance when ready to shoot, or live with the oddity to avoid having to pony up for what could be the need for a new circuit board.
      Anyone have experience with this issue?
      What is the going rate for a trip to Leica for a new board and CLA? Would it be less of headache to sell the body at a low price and live another day with an M6 or MP instead? Yes, I do dream of an MP...
       
      Thanks in advance!
    • By k0ffe
      Hi, 
      I have to choose between two mint condition cameras, one is a upgraded viewfinder M7 and second one is a m6 classic with a recent CLA. 
      I like the M7 as it gives me the option for aperture priority IF I want. But the one thing that worries me is the electronics, compared to the M6 mechanical inside. 
       
      Please advise as I need to make a quick choice. The price is not the factor i need help with just the talk around riliabilty and posabilty to service IF it breaks down in a couple of years. 
×
×
  • Create New...