Jump to content

Leica T App + Wifi + Firmware 1.5.1


Recommended Posts

Advertisement (gone after registration)

We are attempting to create a direct connection from the Leica T to the Leica T app.

 

Leica T

Firmware 1.5.1

iPhone 6 Plus - iOS is up to date - 9.3.1

Verizon (which shouldn't matter at all but you never know)

 

When placed in direct connect mode the camera waits for the phone to connect. When the Leica T wifi network is selected on the phone the camera acknowledges the connection with a success message and the phone shows the camera's wifi network as selected. The phone shows a full set of network identity that confirms the phone is connected in it's wifi settings.

 

Then the Leica T app is launched on the phone. It begins "Searching for camera in Leica T network" but simply never connects. Eventually the app times out and and says it cannot find the network, even though the phone is still "connected" to the Leica T wifi network in the phone wifi settings.

 

We even "Reset the caches" in the Leica App settings.

 

Anyone have any ideas?

 

Thanks much.

Link to post
Share on other sites

Try restarting your iPhone. (see Apple’s iPhone User Guide) It worked for me when I had the same problem.

 

Thank you euston. It worked for me too. Attention Louis2 if you didn't succeed to get it work. Very good tip. 

Link to post
Share on other sites

Thank you euston. It worked for me too. Attention Louis2 if you didn't succeed to get it work. Very good tip. 

 

To make absolutely sure, I restarted my IPhone and went through the whole process for ...th time. I can connect T with my IPhone, ... BUT, ... I still get black screen on my IPhone and see nothing to shoot!.....

 

I am using non-leica manual lenses, and I believe this is my problem! I do not have any leica or Leica T lens to try!... This is the problem I am having from the beginning; and,  I wish leica had the courtesy of giving us some instructions, or telling us what to expect!...

 

I am just giving up for ...th time!

Edited by Louis2
Link to post
Share on other sites

Advertisement (gone after registration)

Hi Louis2

I restart my I phone by pressing the home button and the on/off button on top simultaneously till the screen is totally black,

wait a minute and start the I phone again.

Turn the Leica T on, tap WiFi,  WiFi on OK,  APP connection OK.

Go to I phone WiFi settings and select Leica T, wait till connection confirmed. At this moment the Leica T screen says WiFi succesfully connected.

Open the Leica T app. Is the big Dot (6cm in the middle) grey or red? Grey is failure, red is OK. Tap this Dot if red and connection

is completed.

I would recommend to load the camera with the SD card and a couple of images on it as the app opens with the images on the SD card. Put also a lens on the camera full open without body cap because by tapping the camera icon top right you open the camera

remote section and you see the actual image captured by the camera.

I use I phone 5 and latest I Pad Air both IOS 9.3.1. Leica T/ Leica M adapter T/ M lenses/ EVF.

After succesfullyconnected I made a couple of tests:

Without EVF

Without EVF and lens

Without EVF, lens and adapter and T body cap only.

In all cases I can make the T app working and I doubt if using an EVF, Leica adapter and Leica M lenses or third party lenses

has something to do with the T app installation.

I remember one occasion the Leica T screen gave me a password!!!!!!! I gave it in a box in WiFi settings on my I Pad and OK.

So watch your Leica T screen.

Hope this will be of help.

Dre

 

 

 

 

To make absolutely sure, I restarted my IPhone and went through the whole process for ...th time. I can connect T with my IPhone, ... BUT, ... I still get black screen on my IPhone and see nothing to shoot!.....

 

I am using non-leica manual lenses, and I believe this is my problem! I do not have any leica or Leica T lens to try!... This is the problem I am having from the beginning; and,  I wish leica had the courtesy of giving us some instructions, or telling us what to expect!...

 

I am just giving up for ...th time!

Link to post
Share on other sites

Hi Louis2

I restart my I phone by pressing the home button and the on/off button on top simultaneously till the screen is totally black,

wait a minute and start the I phone again.

Turn the Leica T on, tap WiFi,  WiFi on OK,  APP connection OK.

Go to I phone WiFi settings and select Leica T, wait till connection confirmed. At this moment the Leica T screen says WiFi succesfully connected.

Open the Leica T app. Is the big Dot (6cm in the middle) grey or red? Grey is failure, red is OK. Tap this Dot if red and connection

is completed.

I would recommend to load the camera with the SD card and a couple of images on it as the app opens with the images on the SD card. Put also a lens on the camera full open without body cap because by tapping the camera icon top right you open the camera

remote section and you see the actual image captured by the camera.

I use I phone 5 and latest I Pad Air both IOS 9.3.1. Leica T/ Leica M adapter T/ M lenses/ EVF.

After succesfullyconnected I made a couple of tests:

Without EVF

Without EVF and lens

Without EVF, lens and adapter and T body cap only.

In all cases I can make the T app working and I doubt if using an EVF, Leica adapter and Leica M lenses or third party lenses

has something to do with the T app installation.

I remember one occasion the Leica T screen gave me a password!!!!!!! I gave it in a box in WiFi settings on my I Pad and OK.

So watch your Leica T screen.

Hope this will be of help.

Dre

 

Much appreciated, Dre.

I have been doing everything you said for months without any success. I have IPhone 6, and my App is the latest, as is my firmware. But I am using only Nikkor lenses. With and without Visoflex, I am connecting my IPhone and T, but I do not have any image on my phone; only black screen!...

Thanks again,

All the best,

Louis

Link to post
Share on other sites

I tried using the app yesterday. Visor led in place, app and camera with the most recent versions.  In 3 attempts I was able to connect only once and in that time only one of 10 pics were transferred.

 

the iPad Pro -connected to the camera during the 2 times it failed, opened the app but nothing happened after waiting for a few minutes.  Not sure what to try next.  Restarted camera  and iPad 

Link to post
Share on other sites

  • 5 months later...

Nothing works for me:

Leica T, firmware 1.55

Leica T app on iPhone with iOS10

Leica T app on iPad with iOS 9.3.5

When I start only camera: I can choose between "direct" and WiFi"

When I start LeicaT app it opens with searching in WiFi, no option to connect "direct".

When I set camera to "Wifi" it sees the WiFi and asks to put in the password, when I do that it seems to connect but then "hangs" no way to do anything, I have to take out the battery to shut off the camera.

The app, just keeps searching, never sees the camera. Does not matter which (iPhone/iPad) I open.

Edited by LexS
Link to post
Share on other sites

  • 3 weeks later...

Nothing works for me:

Leica T, firmware 1.55

Leica T app on iPhone with iOS10

Leica T app on iPad with iOS 9.3.5

When I start only camera: I can choose between "direct" and WiFi"

When I start LeicaT app it opens with searching in WiFi, no option to connect "direct".

When I set camera to "Wifi" it sees the WiFi and asks to put in the password, when I do that it seems to connect but then "hangs" no way to do anything, I have to take out the battery to shut off the camera.

The app, just keeps searching, never sees the camera. Does not matter which (iPhone/iPad) I open.

I have the same issues. Nothing works. That's really frustrating.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...