Jump to content
dbchun

Leica T write speed? (searching for best SDXC memory card)

Recommended Posts

Advertisement (gone after registration)

as a proud new owner of a Leica T to complement my film M6, I'm searching around for the best memory card that the Leica T can take full advantage of. 

i'm always interested in the latest and greatest but it doesn't make much sense if the limiting factor is the camera

 

it seems new cards are released frequently, with the most recent spec being Class 10 and UHS-3 classification

 

has anyone done a test on the write speeds of the Leica T? i've done some google and forum searches but cannot find an answer

 

been shopping for cards and have concluded I want a SanDisk extreme pro card.  now I'm trying to figure out if we'd be able to notice a difference using a UHS-1 vs. UHS-3 card with the Leica T

 

thanks! 

Edited by dbchun

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Freggio
      Hello,
       
      Took my Leica S2 out in London yesterday to see how it performed out of the studio. Took a total of about 50 shots in groups of a dozen or so in 3 locations.
       
      Apon my return I discovered that instead of my usual CF AND SD cards I only had the SD card in the camera. Strangely the S2 only saved 8 images (all DNG) to the SD. A single image from the first location. 7 from the second and none at all from the last location.
       
      This has never happened before. The battery was fully charged and didn't require changing during the day. The SD card has plenty of space on it. BUT the S2 was set to save in parallel and I've never not had both CF and SD in the camera together AND The camera was set to save DNG only.
       
      I'm trying to reproduce the same issue now. Seems that there's maybe an issue with having the camera set to parallel saving when DNG only is selected and there's only an SD card present.
       
      Can anyone confirm that for me? Or could this be something more serious?
       
      Cheers,
       
      Freggio.
       
       
       
       
    • By gwpics
      I am very pleased to say that my M9 returned home today after being with Leica since September for the removal of an SD card label (Fuji 16gb card) jammed in the shutter, and for a sensor clean and service. It came as a surprise as they had bot notified me it was on its way, but they appear to have done a great job, and sent it back in its own box by UPS.
      Now to tackle Fuji about the SD card, who seemed to be pretty disinterested when I spoke to them on phone.
       
      Gerry
    • By BjarniM
      I've seen this with the other Leica cameras i have as well, and it's the same with my new M10.
       
      How do i force my M10 to start image numbering from 0 and not continue from the number that last was written to the card (even though it came from another Leica)?
    • By fastfashn
      Good day. I was using the T last night for some fun, tuned it off, a few hours later back on, and it said the SD card was corrupted. I took the camera home, downloaded the pix I had taken, which were fine, and formatted the card. I have not run across this particular issue before. 
       
      Any ideas?
       
      The SD card is only about a month old, and it was formatted before I used it in the camera (originally). It's not the highest priced card out there, probably not the fastest.
    • By Lits
      Hello,
      I'm a new Q owner. I just got mine, a "mint-condition used" from B & H.
       
      I charged the battery and inserted the SD card... and couldn't! 
      It won't go all the way down for a latch/click sound... It bounces right back with a springy-sound.
      I thought maybe I wasn't pushing it hard enough, and I did give more pressure, but I was afraid I'd break something.
      I've tried with 4 different cards and none worked.
       
      Has anyone experienced the same problem? Could it be a defect, or an user error??
       
      I emailed B & H but they're on vacation until mid-next week. 
      I was hoping to take it to my vacation next week
      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!  
      Any suggestions/opinions will be greatly appreciated.
      Thanks in advance!
       
      -Lits.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy