Jump to content
Sign in to follow this  
nondas.gr

dlux-6 and SD card on OSX issue

Recommended Posts

Advertisement (gone after registration)

I 'm using my dlux-6 with Apple Aperture and i 'm having an issue deleting my photos from the SD. After copying my photos to the program, Aperture asks me if i want to delete them and eject the disk. I confirm but nothing happens:confused:. The only way is to delete/format the SD from within the camera (annoying)...

Today i noticed that i don't have permission rights on any SD i connect with the camera (read only) but from a card reader i have no problem

. I tried various solutions but nothing yet.

Anybody with Dlux6 and OSX can confirm this? Thanks

Share this post


Link to post
Share on other sites
…. The only way is to delete/format the SD from within the camera (annoying)...

….

 

Well, annoying or not, that is the proper way to do it, with any camera and any operating system! ALWAYS format the card in camera, using the camera´s own format command from its menu.

 

And, as for downloading from the card, using a card reader instead of an USB cord from the camera is safer and (usually) faster. When returning from an extended shoot with several cards to download from, it´s really the only sensible thing to do.

 

As for the specific hardware you mention, I own a D-Lux 6 and a Mac, but I use Lightroom instead of Aperture. And, just as with my other cameras, I haven´t even taken the USB cord out of its plastic bag since I came home with the camera; I use a card reader (it´s built into my Mac Mini).

Share this post


Link to post
Share on other sites

I appreciate your responses. Everyone has its own workflow at the end. I would like to use the simplicity Aperture offers (connect, import, delete, eject) and the possibly to wright data on the SD but for some reason that option is not available. Any other ideas would be great. Thanks

Share this post


Link to post
Share on other sites

Hmm, I generally would format in camera, too, but see my previous post here: http://www.l-camera-forum.com/leica-forum/leica-m9-forum/328657-sd-card-hiccups-digital-travel-advice.html

 

...and in particular stevesurf's recommendation for this free program which might prove helpful: https://www.sdcard.org/downloads/formatter_4/

Share this post


Link to post
Share on other sites

Advertisement (gone after registration)

With one exception leave your workflow as it is. The exception is the one several of us have written above - delete and format SD cards in the camera, not in the computer.

Share this post


Link to post
Share on other sites
Well, annoying or not, that is the proper way to do it, with any camera and any operating system! ALWAYS format the card in camera, using the camera´s own format command from its menu.

 

Unless one uses SDFormatter.

 

OP - run Disk Utility to fix all permissions. Hope that does the trick.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...