Jump to content
  1. hmcl

    hmcl

  2. Sandokan

    Sandokan

  • Similar Content

    • By S.L.Dixon
      Hi,
      I have had a M6 (serial number is in the 1665000 range) for about 7 years now and to be honest, haven't used it a lot in the last few years, but fired it up again recently and noticed that I think the light meter is functioning odd. In the past, I could press the shutter button when the film wasn't wound on and the light meter would activate, briefly, and then I could set the exposure. Now it doesn't do that, but when I wind film on, it will activate the light meter and not turn off until a photo is taken.
      I ran a roll of film through and it works fine - i.e the exposures were fine - it just seems to activate differently that it used to. Is this a common thing anyone knows about?
      I live in Melbourne, Australia and it's tough to get a repairer here who will look at an M6.  Any advice would be REALLY helpful. 
      Thanks in advance!
      Scott
      (Also, I added a photo of my camera just 'cause it's a nice looking thing.)

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By Maien_
      Hello there!
      I feel like something is wrong with my Leica M6, but I can't confirm as it's my very first Leica (and I LOVE it).
      When it is 'powered' (fresh new batteries and not on Bulb mode), if I press the shutter half-way or even all-the-way, I don't get any reading in the viewfinder.
      The light meter is powered on and giving me a reading only when the wind lever has been pulled completely and the camera is ready to take a picture.
      While I can still use the camera properly, in specific light conditions (low light, cloudy and changing light) it's a bit risky to use as sometimes I have to wait 10-15 mins to have the natural lighting I'm looking for and the trigger could be pressed by inadvertence at any moment.
      Could you guys please confirm that:
      This is not normal, and the light meter should give me a reading even though I didn't pull the lever (as long as the camera is not on Bulb mode) It wouldn't be too crazy to fix as it should 'just' be a connection missing Thank you in advance.
    • By carbon_dragon
      I'm currently using Apple Aperture for my Leica M9 but as Apple no longer supports it, it's only a matter of time before I will have to convert (maybe to Capture One). In the meantime, should I buy an M10, will it's DNG files be readable by Aperture even if Apple no longer adds support for new cameras. Note I'm not positive Apple isn't doing this, but it would kind of be typical so I'm kind of assuming this is true.
       
      In other words, will buying an M10 mean an IMMEDIATE conversion to another program?
       
      Thanks.
    • By kentishrev
      I have recently bought a used Summilux 50mm.  The serial number starts 250..., so I think it's from around 1972.
       
      It's been working fine since May on M9, M6 and CL (with adapter).  Using today on M-D and the focus and aperture rings are starting to stick when focus nears infinity.  Put simply, if I'm at around f8, then move focus towards infinity, the rings 'catch' and turning the focus starts to turn the aperture at the same pace, moving it up (from, say, f8 to f11).
       
      Anyone else had this happen.  If no easy fix then I have a 12 month warranty, but it would be a shame to lose it for a few weeks.
       
      thank you
       
    • By nbhung
      Hi Guys,
       
      I've been using my M6 TTL without an issue for sometime and then I left it dormant for around a year when I left the country...
       
      Now the meter wont work
      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden! , the M6 would work fine and still take pictures if exposed correctly with an external light meter, but the mechanism now would not turn on.   
      I'm based in NYC and have sent it to the Leica repair and they sent it back saying that they can't fix it because they "no longer have the parts", I contact Sherry Krauter and she said that she gets her parts from Leica, so if they don't have it, she won't either.
       
      So really now I'm just asking for help!
       
      Thanks!
       
      H
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy