Jump to content

M240 firmware FW 2.0.0.11 Update [Merged]


Recommended Posts

  • Replies 139
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

from this afternoon ..... auto wb and nil done in LR   M+Novoflex+Macro Elmarit R 100/2.8 ISO 1600   ....... needs -200k to be spot on ..... but a matter of taste really..... this was indoors with mixed window/incandescent and a touch of icelight....   ..... I've added a second with WB adjusted (for about the 5th time .... teeth and lipstick look a bit blue to me, so maybe the original is closer than I thought.....) Hello guest! Please register or sign in to view the hidden content. Ha

No problems uploading firmware. No glitches seem to be introduced.   Color and WB seems good. Color and WB OOC is much better than the RX1. Skin tones look fine now OOC. Huge improvement. Photos downloaded into LR now need very little, if any, PP work on color.   Seems to solve many of the bugs with no ill effect. I think Leica has done a good job for their first firmware release and it seems to address the major problem of the WB. Files look great.   Looking forward to the ne

errr........ the main complaint when the M appeared was the images didn't look like the M9 ...... now they do ....... Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!  the main difference is the wider dynamic range, ability to manipulate the files to a much greater extent in LR ..... without imparting horrible artefacts ... and the flexibility of LV/EVF and usage of almost any lenses ......   An

Posted Images

Leica Forum Blog has all details

 

http://www.l-camera-forum.com/leica-news/2013/10/leica-m-firmware-update-v2-0-0-11/

 

Until now (3 p.m.) the new firmware is only available via the German Leica website but software should include all language versions.

 

Update:

Now the English website has the update too:

Leica Camera AG - Photography - LEICA M

 

Andreas

 

BTW - the new firmware is tested by 30 forum members - thanks!

Link to post
Share on other sites

It's an easy and straightforward FW upgrade...initial observations are that skin tones are much improved and AutoWB is now very consistent frame to frame, making post much easier and faster. The AutoWB isn't perfect all the time, and can be tricked especially under mixed artificial lighting, but no camera from any manufacturer is ever 100% perfect in this.

Link to post
Share on other sites
Little disappointed they didn't provide the ability to at least turn off the movie button. Reassigning and even exposure comp I can live with till next round but how much code would have been needed to just turn off the dam movie button.

 

It's Leica. Not Fuji. It's how they roll.

Link to post
Share on other sites

No problems uploading firmware. No glitches seem to be introduced.

 

Color and WB seems good. Color and WB OOC is much better than the RX1. Skin tones look fine now OOC. Huge improvement. Photos downloaded into LR now need very little, if any, PP work on color.

 

Seems to solve many of the bugs with no ill effect. I think Leica has done a good job for their first firmware release and it seems to address the major problem of the WB. Files look great.

 

Looking forward to the next release that I know a lot of folks hope addresses some of the wish list items and some other things. Personally, I'm glad Leica didn't wait to bundle that all together which, I assume, would have delayed this release that vastly improves the color.

 

I don't think "early adopters" are going to have any problems or surprises. I am confident that owners are going to be quite pleased with the color now. Go for it.

 

Rick

Edited by RickLeica
Link to post
Share on other sites
Guest WPalank

Any bets to how long before the first, "I can't get the firmware to load" (because the firmware has to be in the upper root directory) or 'I'm on a Mac and can't unzip or open the file" (that's because your system software or OS has already done that for you immediately on download)?

 

I give it 1 hour.

Link to post
Share on other sites
Any bets to how long before the first, "I can't get the firmware to load" (because the firmware has to be in the upper root directory) or 'I'm on a Mac and can't unzip or open the file" (that's because your system software or OS has already done that for you immediately on download)?

 

I give it 1 hour.

 

Just to be clear: This is not a problem with the software being buggy and not loading.

 

This would be a problem with the user not putting the file in the top or root of the SD card and realizing that on Mac you don't have to unzip the downloaded file.

 

I found no problems with the upload of this software. It is solid. I still recommend it and I don't foresee anybody having problems with it.

Link to post
Share on other sites

Lets keep it simple - on a Mac you just lift the file as seen on desktop and drop on top of formatted SD card also on desktop. Done, eject and place in camera. Just in case anyone was put off not knowing you were kidding.

Link to post
Share on other sites
Guest WPalank
Just to be clear: This is not a problem with the software being buggy and not loading.

 

This would be a problem with the user not putting the file in the top or root of the SD card and realizing that on Mac you don't have to unzip the downloaded file.

 

I found no problems with the upload of this software. It is solid. I still recommend it and I don't foresee anybody having problems with it.

 

That is why I immediately followed with the solution. Clear as hell to me. Please read the parentheses. they look like this (), but with words in the middle

 

With every firmware update the Forum typically gets filled with people that will actually START threads with those problems.

Link to post
Share on other sites

AWB is greatly improved, and at least with my M, the red edge issue has improved somewhat, but still exists--more apparent with my 35 Summicron ASPH than with my 24 Elmar APSH. I hope Leica will continue to work on this issue. I know it is generally an alignment issue that can vary from body to body, lens to lens--so I am considering sending my M to Solms for a checkup (ughh).

Link to post
Share on other sites

Hmmm, can't say I'm impressed by what I'm seeing, which is kinda worrying considering I've just decided the buy the thing.

Does anybody that is speaking out in favour of the firmware have any pictures of before and after situations to show just how the awb handles things differently? At the moment it's only those that remain sceptical about the firmware that are posting such comparisons.

Link to post
Share on other sites

Just a chime in post to confirm and agree with Stephen and Rick's posts above. AWB, Colors OOC improved. Stability of LV function is improved. FW is stable and no downsides and considerable upside to upgrading. I have had no problems with red cornering with a 21 MM Leica SEL or 35MM Summicron. The 35 had no problems before update, the 21 MM was only shot with the updated FW.

 

Leica is aware of other issues like the preferences of some users to have Auto ISO function in Manual Mode, ISO settings displayed in red instead of white and being hard to read, instability at higher operating temps with shut downs and are getting FW out that corrects the most pressing issues ( Color Rendition) first.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...