Jump to content

Leica M8 Rewind noise - bit worrying


zekoko

Recommended Posts

Advertisement (gone after registration)

Hello all,

 

My M8 rewind noise has been worrying me for a while now. When I click the shutter, the rewind noise in S mode is long and laboured, it almost sounds as something might if a battery is low (I have tested this on a fully charged battery).

 

After a few minutes of use, the rewind noise sounds better.

 

If I shoot in C mode, the rewind noise is crisp and fast, as it should be, this only happens in S mode.

 

Does anyone know why this might be?

 

I enquired with Leica about costs for having this services at Solms, and they informed me it would unlikely be less than $300 for a general service, which makes me thing it might be a lot more if there is an issue :S

 

Is there any advice anyone could give me?

 

Thank you very much in advance

Simon

Link to post
Share on other sites

It depends on how reliable you want your camera to be. If you can afford to have it quit at an inconvenient time just use it as is. It might carry on like this forever or even cure itself. But personally I would send it in for a full CLA.

Link to post
Share on other sites

It depends on how reliable you want your camera to be. If you can afford to have it quit at an inconvenient time just use it as is. It might carry on like this forever or even cure itself. But personally I would send it in for a full CLA.

 

Thank you Jaapv.

 

Is the CLA the Leica service in Solms? Do you know what that involves? I emailed Leica Mayfair to ask for details on what work is carried out and what they provide but all they would tell me is would cost a minimum of 300 euros.

Link to post
Share on other sites

My M8 does the same occasionally, usually first thing in the morning after it has not been used for a few days. So far it has been OK after the first or second actuation.

 

Recently it locked up totally and required a reset by removing the battery for a day. That happened in continuous mode when I accidentally switched to 'B' instead of 'A' on the shutter dial.

 

I keep putting off the inconvenience and cost of a service but I think it is probably required. It has done about 15000 actuations which doesn't seem much for that class of camera.

Edited by mike_j
  • Like 1
Link to post
Share on other sites

Yup, I need to get mine serviced too. It's frustrating as I was saving to upgrade, with a view to selling the M8, but I can't sell it if it is faulty.

 

Worried the service is going to cost a stupid amount, the worry is it is going to cost me £700 when the value of the camera is maybe £1100

 

Also, I am trying to find out a bit more information on what the service provides, with little luck.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...