Jump to content

Image Review with the EVF


marknorton

Recommended Posts

Advertisement (gone after registration)

A question to those of you with an X2 and the EVF.

 

Obviously, when you connect it and press the button, Live View gets diverted to the EVF. What about image review - the images you see after taking a shot or when you press Play. Do these come out on the EVF or still on the LCD?

 

I have the new M and would much prefer to continue seeing images on the LCD but instead, they go to the EVF so that browsing images is done with the camera to your eye unless of course you switch off the EVF.

Link to post
Share on other sites

Thank you, I thought as much. Leica seem to have adopted this as a company standard and carried it through to the M. I like the EVF but don't want to spend my life with my eye to it. There should be an option to let the user choose.

Link to post
Share on other sites

Mine comes on with the LCD and not the EVF. I just tried it to be double sure....

 

But I have auto preview turned off. Maybe that's why. My set up is EVF always on and then after I release the shutter I'll hit the play button if I want to preview. The image shows up on the LCD and not in the EVF. It takes a quick second before it appears and then it shows up and the EVF goes black. To return to normal, I touch the shutter release and the image goes out of play mode.

 

Sounds like an issue only with the 240 (?) And do you have the Olympus or the Leica? I saw your post in the M section, sounds like you have the Oly version. Maybe it's an Olympus issue? I got the Leica branded one only because it was part of a trade-in deal I made and it came with the camera. Anyway, it works fine for me and I can preview with the LCD while the EVF is on and functioning (it doesn't appear in the EVF when I hit play.)

Edited by CalArts 99
Link to post
Share on other sites

Thank you for that. I tried it on the M and even if you have auto-review switched off, pressing play still brings the images up on the EVF. Contrast that with the Menu button which appears on the LCD and goes back to the EVF on exit.

 

So the X2 and M are inconsistent. There is no EVF always on button on the M too.

 

Seems to me there are 3 possible uses for the EVF - framing/focussing, image review and image playback. The first should always be active if the EVF is on, the other two should be down to user preference.

Link to post
Share on other sites

Thank you for that. I tried it on the M and even if you have auto-review switched off, pressing play still brings the images up on the EVF. Contrast that with the Menu button which appears on the LCD and goes back to the EVF on exit.

 

So the X2 and M are inconsistent. There is no EVF always on button on the M too.

 

Seems to me there are 3 possible uses for the EVF - framing/focussing, image review and image playback. The first should always be active if the EVF is on, the other two should be down to user preference.

 

Does the M have a "play on monitor" setting? I just looked again, and that's why mine shows on the monitor instead of the EVF. If I select it to off, then it appears in the EVF.

 

Mine is set up to show everything in the EVF (including menu) and the only thing I have to show up in the LCD display is the image review. It works great (for my preferences) and I really like using the EVF with the X2. I do have the OVF, too, which I use for 'quick' use on the street, etc.. But the EVF is very useful for the way I'm using the X2.

Link to post
Share on other sites

Advertisement (gone after registration)

btw, when I said "always on" I meant that the EVF stays on always unless I physically turn it off with the EVF on/off button. It goes to sleep with the rest of the camera after 10 minutes (the max setting in the menu.)

 

If I turn off the EVF while the camera is on, then everything (including playback and menu) reverts to the LCD. If the EVF is on, it stays on and everything except playback/review is through the EVF. I would certainly dislike the EVF setup if I had to review the image via the EVF only, that does sound poorly implemented. But it doesn't work that way, at least not on my set up.....

Link to post
Share on other sites

Image review goes on the EVF, it is annoying. One extra press in the EVF is required to view in the LCD, then one other press to use the EVF again.

 

Leica should fix this. It seems a small enough code bit to do and update on firmware.

 

See my post above: select "play on monitor" from "off" to "on" in the X2 menu. Then it will appear on the LCD display and not in the EVF when you hit the "play" button. Everything else (including menu) still shows up in the EVF. And you don't have to physically turn the EVF on and off (just leave it on all the time; it will shut off when the camera shuts off or go off when the camera sleeps depending on the sleep time you have set in the menu.)

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...