Jump to content
Sign in to follow this  
AncientCityPhoto

Nature / Fine Art with M8 & 75mm

Recommended Posts

Advertisement (gone after registration)

http://gallery.ancientcityphoto.com/photos/i-Gsxw9K5/0/S/i-Gsxw9K5-S.jpg

 

http://gallery.ancientcityphoto.com/photos/i-HSkdMd5/0/S/i-HSkdMd5-S.jpg

 

http://gallery.ancientcityphoto.com/photos/i-jmTFTKH/0/S/i-jmTFTKH-S.jpg

 

http://gallery.ancientcityphoto.com/photos/i-jDfrdSn/0/M/i-jDfrdSn-M.jpg

 

I shot all of these with the M8 and Voigtlander 75mm F/2.5. I've worked on this project for over a year now. This combination of camera and lens and specific lighting conditions were the only combo that was giving me exactly the rendition I wanted. It's amazing how awesome the M8 is. I love that camera!

 

I have a few on my blog, and will be putting up some more and some behind the scenes kinda stuff shortly.

 

I also have an ebook available that features these images and more. It was designed for digital reading. You can see it here if you are interested. http://soundvisionpassion.com/2012/0...now-available/

Share this post


Link to post
Share on other sites

Wonderful photographic endeavors..however the pictures posted are so small!!

Also , many people will not click on links, its better to post the images here.

 

Thanks for sharing your photography

 

Cheers, JRM

Share this post


Link to post
Share on other sites

very interesting pictures and worthwhile showing them here on LUF.

One could enjoy more because at least in the forum there is an acceptable size.

May we encourage you to share them. Thanks for the link anyway.

Share this post


Link to post
Share on other sites

You can post them up to 960 pixels on any side, and up to 300 KB files. Please post directly here - Many of us will not click through. And as John also points out, bigger, please.

Share this post


Link to post
Share on other sites

How do I post them so they appear? I try to but the link always appears instead. When I am typing my post, I see the actual photo appear. I clicked on the photo icon and placed the link where it asked me and hit ok. The photo appears, but when the post goes live the image is only shown in link form. How do I edit or repost them?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue., Read more about our Privacy Policy