Jump to content
Sign in to follow this  
Philippe D.

Firmware v.1.91 for M8 available

Recommended Posts

When I got to the German website, the firmware was 1.091 but the explanation referred to 1.09 and only contained the list of fixes that were openly announced for 1.09 (improved process, as I recall). So my theory is that the firmware shouldn't have been released until its documentation is ready, and probably until it is ready in several major languages.

 

In the meantime, I like the extra info on the Play screen, and mine takes pictures without any obvious difficulty. My camera now says lens detection "on" or "off." Now off to the hex editor for a quick scan of the code.

 

scott

Share this post


Link to post
Share on other sites
Guest guy_mancuso

Well I was just trying to help some folks that were getting that XML extension. As Long as everyone knows leica RELEASED it and not me than I will stay out of any trouble. Just don't want to rock anyones boat. I honestly thought it was a official release since it was on there website, sometime the US is a day behind what Germany does.

Share this post


Link to post
Share on other sites
Guest sirvine

I'm picturing someone at Leica watching this thread carefully over the next day or so to see if they broke anyone's camera.

 

Judging by the confusion surrounding the .xml suffix, I get the impression some of the "beta testers" are in over their heads. Reverting to old firmware versions is not always as easy as it looks. I'm sure it'll all sort itself out, but if there was ever a scenario that screamed caution it would be the mysterious unannounced firmware download posted on the last day of the pre-announced deadline month and subsequently pulled without explanation.

Share this post


Link to post
Share on other sites
Guest guy_mancuso

Hmmm i just shot this 15 minutes ago for e-bay. First time I shot jpgs . This is straight out of the camera on AWB

Share this post


Link to post
Share on other sites
Hmmm i just shot this 15 minutes ago for e-bay. First time I shot jpgs . This is straight out of the camera on AWB

 

@Guy

 

Looks fine. However I just made a very short test wih JPGS and DNGs, AWB and tungsten, all before and after the update to 1.091.

 

Sad to say I could not realize any changes concerning WB so far.

 

Best

Holger

Share this post


Link to post
Share on other sites

Re-install 1.091 and now all is OK.

 

The first time I did it, I formatted the SD card first and so the 2nd install was exactly the same. I have no idea, except the first time, I had the 12mm Voit on the body, the second time I used had the coded 35/1.4. I don't know if this could have mattered. During the initial install, checking for encoded lenses was enabled. The second time I had it turned off.

Share this post


Link to post
Share on other sites

Guy, many thanks. As Leica seems to have pulled their version, I took it from you and it seems to work fine. If it does not, we can always re load 1.9. I hope anyway. Many thanks for all what you do for us!

 

Blasko, have you ever thought that your uniquely postulated epistles may give all Hungarians a bad name. Which would be a real shame. At least you could change your handle. Please!

Share this post


Link to post
Share on other sites

From the sublime to the ridiculous

 

/applications/core/interface/imageproxy/imageproxy.php?img=http://www.slack.co.uk/oddsandends/L1002395.jpg&key=411a8b0e29d0e463f03efc4dcb4fb6419c7036e68b6a81bcf849e136cc8134d8">

 

spot the 3 dead ipods, the old Kaiser Chiefs CD, and the old Linn Deck . . . . and of course, Guy's photo

 

again - jpg, ISO 640, AWB - it doesn't tidy the office though:o

Share this post


Link to post
Share on other sites
Guest guy_mancuso
@Guy

 

Looks fine. However I just made a very short test wih JPGS and DNGs, AWB and tungsten, all before and after the update to 1.091.

 

Sad to say I could not realize any changes concerning WB so far.

 

Best

Holger

 

 

Hard to say but improvement maybe realized more in those sticky lighting spots to . So normal stuff it may appear as usual and this depends on so many variables like the color of the subject itself can give a reading way off with any firmware. But issues like Tungsten and such are really tough on any camera but try using a tungsten setting for those . Sometimes AWB has no clue what light your really under. So easy to fool WB. Not knowing what they did exactly things look improved and i am sure many of the bugs are fixed also. i need to play more myself but I was impressed by that jpeg , that is purely dead on the money. It should be fun to see what we all find .

Share this post


Link to post
Share on other sites
Guest guy_mancuso
From the sublime to the ridiculous

 

/applications/core/interface/imageproxy/imageproxy.php?img=http://www.slack.co.uk/oddsandends/L1002395.jpg&key=411a8b0e29d0e463f03efc4dcb4fb6419c7036e68b6a81bcf849e136cc8134d8">

 

spot the 3 dead ipods, the old Kaiser Chiefs CD, and the old Linn Deck . . . . and of course, Guy's photo

 

again - jpg, ISO 640, AWB - it doesn't tidy the office though:o

 

 

Not fair you have a glass of wine

Share this post


Link to post
Share on other sites
From the sublime to the ridiculous

 

/applications/core/interface/imageproxy/imageproxy.php?img=http://www.slack.co.uk/oddsandends/L1002395.jpg&key=411a8b0e29d0e463f03efc4dcb4fb6419c7036e68b6a81bcf849e136cc8134d8">

 

spot the 3 dead ipods, the old Kaiser Chiefs CD, and the old Linn Deck . . . . and of course, Guy's photo

 

again - jpg, ISO 640, AWB - it doesn't tidy the office though:o

 

If I show this pic to the bride maybe she'll get off my back about my office.

 

Just so it's in this thread, I started a new one stating that v.1.10 will not be available until April.

 

Go to that thread, please, don't hemorrhage here.

Share this post


Link to post
Share on other sites
Not fair you have a glass of wine

Don't worry - it's empty now!

 

Of course, it's hard to tell, but I really don't think that AWB on 1.09 would have managed that - and it really is very good too (I know, I'm looking at the scene right now).

Share this post


Link to post
Share on other sites
Blasko, have you ever thought that your uniquely postulated epistles may give all Hungarians a bad name. Which would be a real shame. At least you could change your handle. Please!

 

@George

 

Why should Blaskos writing give a bad name to Hungarians at all? Who would / should feel that?

 

Would be very easy to find an American’s strange comment in this forum as well as somebody's from my country (German) ... So - does this give all Americans or Germans a bad name?

 

I dont't hope so.

 

Best

Holger

Share this post


Link to post
Share on other sites
does the update say( m8-1_09-1.upd.xml) ?

 

That (on a Mac) would mean that you downloaded m8-1_09.upd twice, and the second file was renamed by the Mac like this. The real filename is m8-1_091.upd.

Share this post


Link to post
Share on other sites
Hi Philippe,

 

Leica has the the same typing mistake in the first screen of the upgrade. (At least in German language)

 

Arne

 

I was going to post that too (about the English version). I read the thread from the start, downloaded Guy's upd file, and was installing it as I got to the warnings

The white balance does look better. If someone is really dedicated, they could try one firmware, update it and try the other.

 

To summarize a potential reason for the removal of the update: on the installation screen of the firmware, it asks if you want to install firmware 1.91. Then when you check the firmware version, it is 1.091, which makes more sense, as it is just before 1.10.

 

About magyarman, he has been on my ignore list for months now. What a load of useless, negative posts. Click on his name in one of his posts, and choose "View Public Profile". Find the "add magyarman to ignore list" link and click it, then confirm. Problem gone.

Share this post


Link to post
Share on other sites
Guest guy_mancuso
Don't worry - it's empty now!

 

Of course, it's hard to tell, but I really don't think that AWB on 1.09 would have managed that - and it really is very good too (I know, I'm looking at the scene right now).

 

It probably will be hard to tell too . Now you don't know how the other older firmware would have recorded it. Just as long as it helps us than that is the good part

Share this post


Link to post
Share on other sites

This is completely as shot - no alterations 16mm fish-eye, SF24-D flash and uploaded and converted to TIFF in C1 and then to JPEG in PS. I think the Auto WB is pretty good on the new firmware - significant improvement.

 

Wilson

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...