Jump to content
Sign in to follow this  
Philippe D.

Firmware v.1.91 for M8 available

Recommended Posts

Gentlemen:

(I love the camera). I followed the posted instructions and dropped the .xml file downloaded by Safari - my Mac's inablility to open it notwithstanding - onto a formatted card and loaded it into the M8. Properly prompted, it took about 1 min to load. However, even after "rebooting" and resetting there appears no difference: it still says enabled/disabled and not on/off, there is no speed and ISO data over the replay (only alongside the image when the info view is chosen) and the firmware version still shows as 1.09, not 1.09(1). Am I missing something? Might there be a way to assure that I have uploaded the latest firmware? Thanks in advance.

David Ruck

 

Mike and David, if you backtrack through this thread you'll see that Leice only briefly posted the firmware update, then returned it to the earlier version. This was only done on the German site.

 

I installed it and it looks OK, but Leica's typically odd behavior does not comfort me.

 

Maybe you're better off waiting for a few days. I was put on this planet to serve as an warning to others.

Share this post


Link to post
Share on other sites
Guest guy_mancuso

It may have been pulled because they may have wanted to announce it with the fixes and enhancements. The firmware is fine , it would not have been there if it was not fully tested by Leica and supporting cast.

 

Geez need to get back to work here. LOL

Share this post


Link to post
Share on other sites

Hello Guys,

 

Both the German and US sites on my Safari still shows and downloads v1.09. I tried it, it is still the same old 1.09. Was 1.091 removed?

Share this post


Link to post
Share on other sites
BTW, does anyone have a copy of the 1.09 update from a download. I'd lilke to have it available so I can regress if necessary.

 

Bill,

You can just go to the download site now and pull down v. 1.09.....again, as that is all that is posted

 

LJ

Share this post


Link to post
Share on other sites

maybe they just need to rename it to 1.1?

 

I do not need to rename the file on my mac. works fine with an xml extension

Share this post


Link to post
Share on other sites

Guy, I thought I saw a PDF which seemed to list the changes.

 

One thing to bear in mind is that bugs in software are not always obvious. It can often take a combination of events to produce a problem After saying that I think it unlikely that Leica would have found bugs in the few minutes that the update was available

Share this post


Link to post
Share on other sites
Guest magyarman
t would not have been there if it was not fully tested by Leica and supporting cast.

 

Is not same cast what did not find about IR, banding, grin blops, and all others prablems why now need new firmware, before was M8 sale to people?

Share this post


Link to post
Share on other sites

I just downloaded the file from Guy's site, loaded without problems and now I cannot take any photos. The red light flashes but nothing is recorded and I have to pull the battery to stop the flashing. All menus work just fine. I'll try re-loading the update and if no help then I'll re-install old firmware. (The body is a recent one with latest hardware.)

Share this post


Link to post
Share on other sites

LJ, thanks for the heads-up. When I saw the post just ahead of yours I went to the first posting in this thread and went to Leica's site and downloaded 1.09.

 

Now I can regress (I'm talking about the camera here, folks) tonite if I decide I don't like this new version.

 

This is so cool. When the few monsters who got cameras before everyone else were posting about the wonderful, new M8 and displaying their pix, I was so jealous. Now, I'm on the cutting edge myself. If I get the expected bloody hands, I'll report.

 

Regards,

Share this post


Link to post
Share on other sites

Gentlemen: I must have reloaded the 1.09. Interesting thread and problem, it is, but I think I'll go out and take some more photos of purple-clad people and check back after the sun's gone down. But it should be said that I have had more fun - and better concentration - with this camera than I've had in a long time. Thanks to all for your hard work, as I go play.

David Ruck

Share this post


Link to post
Share on other sites
Guest guy_mancuso
I just downloaded the file from Guy's site, loaded without problems and now I cannot take any photos. The red light flashes but nothing is recorded and I have to pull the battery to stop the flashing. All menus work just fine. I'll try re-loading the update and if no help then I'll re-install old firmware. (The body is a recent one with latest hardware.)

 

 

Robert make sure you reformat the card first and get it clean , i also put one in the computer and just dumped the folder so nothing was on the card at all. try that and make sure your battery is good

Share this post


Link to post
Share on other sites

Hello,

 

I think they pulled it back because (like the title of this thread) the question in the beginning of the upgrade asks 1.91, but it is 1.091.

 

Mine works fine!

 

 

Regards, Arne

Share this post


Link to post
Share on other sites
You people are like small child what cant to wait second for got what he want it! First one you buy new M8 what is not finish to test, then when is bat you complaint prablem. Now you take new firmware in first minute he life, before Leica even got chance to make it annoncing. If is something bat in new firmware what gonna spoilt your M8, now you gonna complaint Leica again

 

If you have nothing constructive to contribute, I suggest you join a more mature forum - perhaps CBBC.

 

Wilson

Share this post


Link to post
Share on other sites
I think they pulled it back because (like the title of this thread) the question in the beginning of the upgrade asks 1.91, but it is 1.091.
No, it was my typing mistake, correction has been made inside the message as it was not possible anymore to correct on the title.

Share this post


Link to post
Share on other sites

Just for the record, and taking my cue from Magyarman, I was expecting that Allan Brewer would be informing us that a new version of firmware was ready. I would have expected to hear him say something like, "Leica have (not 'has' as we say on this side of the Puddle) announced the availability of ... and direct us to the Leica site where there would be an announcement with a link for the download.

.

Share this post


Link to post
Share on other sites

It is "Leica has" isn't it? Leica is singular. Just like a sports team "Manchester United has tried to throw the game away".

Share this post


Link to post
Share on other sites
It is "Leica has" isn't it? Leica is singular. Just like a sports team "Manchester United has tried to throw the game away".

 

Two nations divided by a common (or not so common

) language!

Share this post


Link to post
Share on other sites
No, it was my typing mistake, correction has been made inside the message as it was not possible anymore to correct on the title.

 

Hi Philippe,

 

Leica has the the same typing mistake in the first screen of the upgrade. (At least in German language)

 

Arne

Share this post


Link to post
Share on other sites

Guy - you really are a star - I couldn't find the damn thing on the website, but this seems to work fine - it doesn't download with an .XML extension, and the camera recognises it (mine is currently updating). . . . . now it's done! (posting before it'd finished seemed rash).

 

AWB seems to work in some very funny situations.

 

cautiously WHOOOOPING!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...