Jump to content

Recommended Posts

Advertisement (gone after registration)

Another series from our recent Montana trip. I asked my brothers to go out and play there guitars. It was a bit cold but having grown up in Michigan it was not a stretch for them.

I wanted to get the fading sun and get them together to play it was pretty cool. They just started playing and I started shooting.

Link to post
Share on other sites

Advertisement (gone after registration)

Welcome to the forum, Eric! Lots of friends and priceless sources of information here!

This is a beautiful series of images, with fantastic colors and atmosphere.

I know you from FLICKR; Please, do post some more photos, especially your B/W ones...

Mauro,

 

Thanks for you encouragement. I will post some B/W images once I process my film.

I agree this is a great site.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gwpics
      Just selected by LFI for their gallery. Leica M7 with 35mm Summarit f2.5 and using Kodak Tri-X lab processed. Permission given by drag artist to photograph.
      Gerry

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By gwpics
      This was taken before the coronavirus problems we now all have.
      Leica M7 + Fuji Neopan T400CN film commercially processed and home scanned.
      Gerry

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
    • By FakeRazer
      Hello there!
      I have a slight but not to severe problem. I've noticed that my Leica M7 is not able to read the DX code of these two specific films: Fujifilm Superia X-Tra 400 and Fujifilm Fujicolor C200. For these two films I get the ISO value of 5000 and 3200 which are obviously wrong. For example, Fujifilm Pro 400H is working perfectly fine, the ISO detection works without problems. Further I tried several other films like Kodak Ektar 100, Kodak Portra 160 and 400, Ilford FP4+ 125 and so on... and the dx detection worked perfectly fine on every single one of these films. I compared the working ones with the "malfunctioning" films and the only difference I noticed is that the black paint in the dx code is a kind of green, it's not a perfect black, more like a darkish green, definitely not a true black. Could this maybe be the reason?
      The thing is, I've sent my camera to Leitz for a grand- overhaul just 3 weeks back. They changed and renewed a lot of parts including thr DX- reader so the camera is like brand new. Unluckily I've no clue if it had the same problem before it went to Leitz because I've not shot one of these films before.
      It would be a great help if somebody has an answer or maybe a similar problem!

      Regards
      Alex
    • By gwpics
      I haven't posted for quite some time because being a street photographer when there is virtually nobody on the streets during these crazy times is difficult. This was taken prior to the time when we knew the term COVID-19 in 2017.
      Leica M7 + 35mm Summarit-MM f2.5. Fuji Neopan 400CN (C-41) film commercially processed and then scanned by me.
      Gerry

      Hello guest! Please register or sign in to view the hidden content. Hallo Gast! Du willst die Bilder sehen? Einfach registrieren oder anmelden!
×
×
  • Create New...