Jump to content
Sign in to follow this  
fabiobarbato

My M6 TTL is jamming around frame 25

Recommended Posts

Advertisement (gone after registration)

It has happened more than one time. When I'm around frame 25 of a film, I can't advance the film anymore....it is like I have reached the end of the film.

Does anyone know why it this happening??

 

thanks

Share this post


Link to post
Share on other sites

It's probably caused by the washers under the rewind crank jamming as the film is advanced. I had the same problem, but in my case it was after 15-18 frames.

 

If you want to try and fix it yourself there are some details here...

 

rewind mechanism transport problem

 

To remove the rewind crank insert a screwdriver in the slot you can see in the crank, and then turn the rewind crank anti-clockwise whicle holding the screwdriver firmly.

 

There are a number of washers underneath the crank itself. Having no mechanical skills what so ever I sent mine away to be fixed.

Share this post


Link to post
Share on other sites

I can confirm what Steve said. It happened to my fried's M4-2 and we brought the camera to Kindermann (authorized Leica repair center in Toronto).

Gerry the technician let us watch: It was a pretty easy fix and he was done in litterally 5 minutes.

Edited by maurometallo

Share this post


Link to post
Share on other sites
Hehehe....thanks, but I'm sure I'm using a 36 frames.

 

I've done it myself, wondered why the camera jammed then realised I'd picked up a 24exp roll of film!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...