Jump to content

Search the Community

Showing results for tags 'battery'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Leica Forum

  • International User Forum
    • Leica M System
    • Leica L-Mount
    • Leica Q / Leica Q2
    • Leica X
    • Leica D-Lux / Digilux / V-Lux / C-Lux
    • Leica R System
    • Leica S System
    • Leica FOTOS App
    • Leica Collectors & Historica
    • Photo Forum
    • Leica & General Discussions
    • Leica Forum Discussions
    • LHSA Member Forum
    • Events & Member Meetings
  • Deutsches Leica Forum
    • Leica M-System
    • Leica L-Mount
    • Leica Q / Leica Q2
    • Leica X
    • Leica D-Lux / Digilux / V-Lux / C-Lux
    • Leica R System
    • Leica S System
    • Leica FOTOS App
    • Leica Sammler & Historica
    • Foto-Forum
    • Leica & Allgemeine Diskussionen
    • Leica Forum Diskussionen
  • Challenges / Wettbewerbe

Calendars

  • Community Calendar

Categories

  • Leica M Objektive

Categories

  • Leica Q
  • Leica M (Typ 240)
  • Leica SL (Typ 601)

Categories

  • Leica Q
  • Leica M (Typ 240)
  • Leica M Monochrom (Typ 246)
  • Leica SL (Typ 601)

Product Groups

  • Premium

Categories

  • Leica M System
    • Leica M Cameras
    • Leica M Lenses
    • Leica M Accessories
    • Leica M Wanted
  • Leica L-Mount
  • Leica S System
  • Leica Q
  • Leica X
  • Leica D-LUX / V-LUX / DIGILUX
  • Historica
    • Leica R System
    • Screwmount Leica
  • Misc

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


City


Hobbies


Job


Name


Your Leica Products / Deine Leica Produkte


Website


PLZ

Found 29 results

  1. I've had the Nitecore charger for few years without problems charging batteries for M240. Just bought couple of new BP-SCL2 batteries at very attractive price via FEDEX from Hong Kong. When I try to charge them for first time with the Nitecore there appears the " EE EE " message indicating shorted battery. HK seller now says that I must "activate" them via first time charge from original Leica charger. Said original charger is misplaced or lost somewhere over past few years. So two questions: 1. Is it true about having to "activate" a BP-SCL2 with original charger? 2. If so, is there another member of the forum in/near Pinellas County, Florida, who might be able (taking precautions all round) to charge them on an original charger? Thanks, Harry
  2. So, I recently bought a preowned m240 from a Leica store and realized there was a problem when I was charging the battery. The CHARGE LED would blink and after several hours both the CHARGE and 80% would be flashing at the same time. Tried it several times but the battery would not charge properly. I contacted the Leica store and told them what the issue was, so they decided to send me a replacement battery that was also used, but unfortunately, the issue still happens when I tried to charge the replacement. I'm planning on ordering one of the Nitecore USB chargers and maybe a new Leica charger to test the batteries. Has anyone heard of issues with Leica chargers for the m240s? Thanks!
  3. eritho

    M9 Battery

    I have not used my M9 for a couple of years and need two new batteries. Remembering the discussion years ago about generic batteries and wonder if anything has approved. Is it possible today to by generic batteries working OK with the M9? If anyone has succeeded in buying one please let me know where and how.
  4. Hi, The datat sheets state that the battery for the Q is BP-DC 12. A search for that model shows that the battery for the V-LUX4 is the same model. But is it really the same battery? On B&H site there are two listings with same model name and specs: 1: BP-DC 12 for Leica Q that costs $190 http://www.bhphotovideo.com/c/product/1160034-REG/leica_19500_bp_dc_12_lithium_ion_battery.html 2: BP-DC 12 for V-LUX 4 that costs only $79.95 http://www.bhphotovideo.com/c/product/894736-REG/Leica_18729_BP_DC12_Lithium_Ion_Battery.html and of course there are third party batteries like the Wasabi Power that you get 2 batteries plus charger for only $30 http://www.ebay.com/itm/Wasabi-Power-Battery-2-Pack-and-Charger-for-Leica-BP-DC12-/251621940689?pt=LH_DefaultDomain_0&hash=item3a95d61dd1 Will the V-Lux battery or the Wasabi batteries will work with the Leica Q? I've ordered the camera but will need extra battery and don't feel like paying $190... Thanks for any input
  5. I posted this topic over on rangefinder forum here, but someone suggested i post here too. Gist of the situation; m240 camera, battery was around ~70% last night and ~95% a few days ago when checked it prior to my trip. (have taken ~200 shots on this battery so far) This particular battery recently started to display the "Check Battery Age" message about a month ago, but I believe I had just recently charged it. Maybe 2 weeks prior to this trip. I'm on a biz trip at the moment, so I didnt bring any spare batteries or a charger, so my test & diagnosis options are limited. I may have the chance to goto the LA Leica Store to try a couple of things. When I turn on the camera, the LED on the back blinks like normal, but then stay illuminated for an extra long time (~3-5s?). Normally it turns off after a few fast blinks. All of the buttons are unresponsive (Menu, Set, Info, LV, etc). The framelines are not being projected. Neither is the ISO, EV Comp, or Shutter info. Pressing the shutter button makes the LED blink like when taking a picture, but nothing happens, and then the LED stays lit again for a few seconds. I have tried pulling the battery while on and off. Leaving the battery out for a few minutes. Tried a friends SD card that was just formatted in my computer. Tried it with and without the one lens I brought on my trip. Tried it on S, C, and Self Timer. Basically, just about everything I can do without having access to my spare batteries at home or a charger. Does anyone have any other ideas? Thanks in advance, Phil
  6. Before I owned the M6, I used to have the Canonet QL 17 GIII. It was working perfectly until I stopped using it for 3 months. The shutter got stuck. When I took it to the repair shop, they asked if I have left the battery inside as the shutter/ self timer is very sticky and dry. So I'm wondering if I should remove my M6's battery when not in use to prevent shutter jam?
  7. Am sorry, am in hurry, leaving for Alaska. I got this unit while buying DMR but don't know what this is for. Can somebody please let me know about it- http://www.facebook.com/photo.php?fbid=344915062307079&set=a.344915045640414.1073741826.141740022624585&type=3&theater
  8. Hi, I just found this website that seems to sell some kind of M8 and M9 generic batteries for very cheap (compared to Leica products) I was wondering if anyone had used these batteries with the M9... At this price it's a real bargain, but I don't want to waste my money... Any thoughts? Thanks!
  9. Has anyone experience of using Lumix branded comparable batteries instead of Leica on the D-Lux 3 or on any other Leica models? I am assuming they would be compatible, and/or does someone have some suggestions please are.
  10. 37 months after the Leica M9 disappeared into the closet, the Leica M9 returned... I've been using the Leica M9 for the last five weeks and found it so pleasant to use that I decided to add a Page 19 to my Leica M9 article series. It also contains a dictionary of Leica words as well as a visual guide to the features of the Leica M9. Enjoy! Leica M9 Confessions by Thorsten Overgaard http://overgaard.dk/leica-M9-digital-rangefinder-camera-page-19-Leica-M9-Confessions-Definitions-and-What-is-That-Details-Explained.html
  11. Hi, I'm new here and I created my account because I desperately need help with this and would be grateful for any help I've been using my M6 for some time now and everything has been functioning perfectly However, when I bought some new batteries for it, the light meter would stop working, while if I put the old batteries back in, everything would work again. The batteries I have tested include, LR44 alkaline battery from energizer, and a CR-1/3N lithium battery. If anyone has any idea what the problem could be, and if there are any possible fixes, it would be greatly appreciated.
  12. I recently bought a NOS TL. I'm still figuring out the best way to use it - but nevertheless, so far, it's hard not to like the camera. One issue that I have with the TL does not seem to be normal however: when I remove the battery for charging, and the camera is without battery for eg one night, I loose all settings: date and time, and the settings in which I was working before I removed the battery. Saved profiles are still there. Just a problem with the internal battery, or… normal for a TL? Marc
  13. I really like my Q. That said, nothing is perfect and one of the weaknesses of the Q is that it is power hungry. Even though I have automatic review turned off and EVG-LCD set to EVF Extended so the LCD is rarely powered I only get about 100 shots/battery charge. That is a guestimate -- I've not actually bothered to note the exact number of images. In addition to the stock battery, I bought two Wasabi work-alikes. They were cheap and reportedly made in Japan using good Japanese cells. Also, where the stock battery is rated at 1200 mAh the Wasabi batteries are rated at 1400 maH. 16% more. Win. Except... the Leica battery seemed to last longer. Hmmm. I use the Nitecore charger for both Leica and Wasabi batteries. One of the pieces of information the charger gives me is "how many mAh" were added to the battery during charging. I used the batteries until the camera automatically turned off due to low power and then paid attention to how much of a charge they took. The 1200 mAh stock battery took about 1000 mAh when being recharged. The 1400 mAh Wasabi battery took about 860 mAh when being recharged. The "bigger" Wasabi battery actually gives me 14% less power. Neither battery gives me its rated value. That does not surprise me. I'm glad I have three batteries.
  14. Hi all, Sometimes when I insert a battery into the charger, after a few moments both LEDs come up flashing rapidly. If I remove the battery and insert it again, all seems to work fine. Is it the battery or the charger? Does it happen sometimes, or it's better to investigate it further? Thank you S.
  15. Hi, The R8 I purchased on eBay came with the motor and that's great. I would, however, like to get the standard battery compartment for the R8 for times when I don't want the extra weight. Can anyone recommend a source for this part? I have been in touch with Dave Elwell of Leica Camera in NJ and he says there are no such parts in stock in the US or Germany. Thanks in advance, Danny dszpiro@gmail.com
  16. I know there were many threads about this with the M8....but I didn't have the problem then, and this may be a different beast? I have two batteries....one works perfectly and charges fully, the other was fine also, but now didn't charge at all (once, yesterday) and then charged only halfway, at least according to the INFO meter.... It is a somewhat older one (left over from M8 days)...is this a sign that the battery is dying (it isn't really that old and hasn't been used that much) or that the INFO might not be correct? Or that the camera might be reading it incorrectly somehow? I haven't yet used it up to see how many shots it will take.... Thanks!
  17. Dear all I just got a nice Leicameter MR 4 No 94991 for my M3. How do I know which battery I need? I have both an EPX625G (Alkaline 1.5 V) and a Wine Cell MRB625 (1.35 V). I read that originally the Leicameter was designed for the Mallory PX 625 1.35 V battery, but later models were adjusted for 1.5 V Alkaline. How do I know which model is mine? Can you please help? Thank you in advance. Regards Swiss leica fan
  18. Hello, We've been using DIGILUX 1 for couple years now and we like it a lot. We bought the camera used and since the beginning it drains a battery while not used. It is very annoying to pull out the camera and realize the battery is empty. Is it normal? Can we do something about it like change some settings etc.? I tried to get a new battery which did not help. Thank you, Radovan
  19. hi L-forum, has anybody experienced sudden battery drain on the Digilux-2? I will charge up the battery to full, pop it in the camera, and can take 15 pics or so (JPEG) before the camera tells me that the battery is nearly empty, and then won't turn back on. I replaced the battery and same problem. When I put the battery in the charger, it charges pretty quickly, so I am leaning towards something being funny with the battery sensor and not the battery itself?? I can't imagine that there is an electrical short that would drain the battery so quickly -- the camera doesn't get hot, so where would all that energy go? Has anybody else seen this happen? Any insight? I haven't seen other posts about this problem, but my apologies if it's already been discussed. If so, I would appreciate a point in the right direction. Anybody have any suggestions on a repair shop in NYC that can handle the electricals? thanks L-forum. ndg
  20. I have had the M9 for about a month now. It takes great pictures. However on at least 4 occasions I turned on the Leica (it had been off) and the low battery sign comes up. I had used the camera the day before, the battery was 80%, I took about 10 pictures, and it was 75% full. It had been in the off position for the last 24 hours. This is now the 4th time it has happened and is VERY frustrating. I know the camera was OFF because I have paid attention to it. Why would a battery drain from 75% full to empty in 24 hours while OFF? I am VERY VERY frustrated. Anyone else has this experience? Any suggestions? My previous Nikon kept a full battery for months even after taking 100s of photos.
  21. I need a battery charger for the D-Lux 4 and cannot find one. Does anyone have suggestions for a US source? Thank you!
  22. Hi For a week already I am not able to charge the battery past 50%. The charger indicates that charging was completed ( = both lights are on) while the camera shows 50%. Has anyone had this problem or has any suggestions? -Dan
  23. Being frugal with money so I can save for my travels, and having good experience in the past with Chinese batteries I ordered a $12 (shipping included) battery for the X1 on eBay to try out. I figured I'd share my experience with you folks here in case there's some other's looking for a less expensive battery alternative. Since the X1 doesn't use "smart" batteries like my DSLR, the kind that have unique electronic serial numbers with communication to the camera to monitor performance and shutter clicks per given battery, I wasn't concerned with using non-OEM batteries. There's no electronics in these batteries. For this type, a battery is a battery assuming it performs within spec. At full charge the output for both of the batteries is 4.19v Both batteries weight 34 grams. I also ordered one of the $12 chargers that has a nice folding plug and the function I absolutely need - a 12v plug so I can charge it off my motorbike on my travels. These same cheap Chinese chargers I have used on every camera I've had for years. The output on the Chinese charger is 4.29v The output on the Leica one is 4.49v Close enough for me. This past holiday weekend I used both batteries up twice each with a family wedding thrown in and witnesses identical performance. Given the facts and then experience I believe that this non Leica battery is just fine along with the charger. Just like the rest of these types of batteries I've used, there's no reason to pay a premium for a re-labeled battery already made in Asia. I think I'll order 3 more now.... There's various ones available from China, just be sure you get the 1600mAh ones or PM me for the specific seller if you want.
  24. Hello. I have a problem. I have Leica 60 type 240. I have a non-original charger (nitecore) I don't know how old the battery is. The charger is new. I bought it a week ago. While charging the battery the EE message appears after about 10 seconds. Yes, I know the manual says it is short circuit protection but what causes the short circuit? The battery? All in all, it doesn't make sense to me. Maybe there is someone from Poland who reads this and lives in Gdansk, Sopot or Gdynia and could help me? Or you know what could the reason be. Some people wrote that it was the charger and they had the same problem and they say we have to use only the original charger. Unfortunately, I do not have the original Leica charger and I don't think I can get it quickly. I don't want to buy it. I have had the camera for 2 weeks. I wanted to take some pictures but as I can see there is no chance. Do you have any solution? I can’t get the battery or the charger here. Can it be charged any other way? Do I have to go to Leica Store Poland in Warsaw?
  25. Whenever I remove my SL2 battery, I lose all language, app, date and time settings, etc., and I'm forced to set them each time I remove the battery. Has anyone experienced this? I'm now charging with the usb-c port, but would like to figure this one out...... Cheers, Scott
×
×
  • Create New...