Jump to content

Solsticephoto

Members
  • Content Count

    7
  • Joined

  • Last visited

About Solsticephoto

  • Rank
    Neuer Benutzer

Profile Information

  • Country
    USA

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have had my M10M for almost a year now. I am a previous owner of a M246 and a M9M and a current owner of an SL2 and a M10P. Due to the pandemic and a move I was not able to get out and shoot with the M10M until last fall. Once I seriously dug into the files I noticed an issue with the sensor. In landscope orientation there is a distinct line / shift in tonal values directly in the center of the frame from top to bottom. When shooting bland blue skys the effect is visible, applying a dehaze in LR at +50 highlights the issue more. In February I contacted Leica and after some trading of D
  2. I have made contact with DAG, Sherry and Youxin as independent servicers. Its interesting that whithin 2-3 hours of emailing each last night they all resonded with ball park pricing and service times. Now its just a matter of getting the Camera back from L-NJ and sending it out again. thanks for everyone's input
  3. @Steve. Yes but one repair service is telling me that all work will be done in 2 weeks -- so no real difference in waiting leica NJ has not offered any reason for the delay. E.g parts are needed
  4. Phillip Good to hear they are reasonable to some extent. At this point I have already asked for my Camera back and have two strong leads for alternative repair. I was / am worried that the delay is due to the M9 which bothers me even more. A quoted time for a fix is a reservation based on first come first served in my universe. If I am getting bumped for M9 fixes / upgrades that is more aggravating....... Thing is I am getting close to purchasing an M9 and this is souring my thinking......... Cheers Eric
  5. I bought a used M4 a couple of months ago and realized it needed a new shutter and a CLA. I sent it to Leica NJ for service and was told it would take 6-7 weeks to get serviced. At 6.5 weeks I inquited about status and was told that it would be another "2 to 3 weeks, or so" At 8.5 weeks I again inquired about status and was told "sorry it will be another 2 weeks, or so" At this point I have lost patience and will seek an alternate repair facility. Question is whether this is par for the course with this facility ? I can accept that it might take a while to get to my camera but wha
×
×
  • Create New...